summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
diff options
context:
space:
mode:
authorLeonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com>2015-09-08 11:39:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-09-09 14:27:51 +0100
commit8be95c5fbe6ad970943edabe288fd47d1dcac288 (patch)
treea3a658ff9b01a28d607aa68ea08789fcc666bbed /meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
parent7cde0ebd59f12da363e780126ca4284e0930721d (diff)
downloadpoky-8be95c5fbe6ad970943edabe288fd47d1dcac288.tar.gz
devtool: add upgrade feature
Upgrades a recipe to a particular version and downloads the source code into a folder. User can avoid patching the source code. These are the general steps of the upgrade function: - Extract current recipe source code into srctree and create a branch - Extract upgrade recipe source code into srctree and rebase with previous branch. In case the rebase is not correctly applied, source code will not be deleted, so user correct the patches - Creates the new recipe under the workspace [YOCTO #7642] (From OE-Core rev: 4020f5d91b3e4d011150d5081d36215f8eab732e) Signed-off-by: Leonardo Sandoval <leonardo.sandoval.gonzalez@linux.intel.com> Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb')
-rw-r--r--meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb b/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
new file mode 100644
index 0000000000..33ffc8803a
--- /dev/null
+++ b/meta-selftest/recipes-test/devtool/devtool-upgrade_0.1.bb
@@ -0,0 +1,25 @@
1#
2# This file was derived from the 'Hello World!' example recipe in the
3# Yocto Project Development Manual.
4#
5
6DESCRIPTION = "Simple helloworld application used to test the devtool upgrade feature"
7SECTION = "devtool"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10PR = "r0"
11
12SRC_URI = "file://${THISDIR}/files/${P}.tar.gz \
13 file://0001-helloword.c-exit-with-EXIT_SUCCESS-instead-of-a-magi.patch \
14 "
15
16S = "${WORKDIR}/${P}"
17
18do_compile() {
19 ${CC} helloworld.c -o helloworld
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 helloworld ${D}${bindir}
25}