summaryrefslogtreecommitdiffstats
path: root/meta-selftest/recipes-devtools
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2018-11-30 12:38:28 +1300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-03 12:20:00 +0000
commit5cd79e81471ca392bb697c2161526423b5a5dc07 (patch)
tree6f5b7dd880e6fb96876ba56303d746f9929052cc /meta-selftest/recipes-devtools
parent1c0a6cdf428f8a7378ac739ff5193bf8fb372264 (diff)
downloadpoky-5cd79e81471ca392bb697c2161526423b5a5dc07.tar.gz
oe-selftest: add some tests for recipeutils module
Add some tests for functions in meta/lib/oe/recipeutils.py, in particular for a few issues I've just fixed. I haven't added tests for all of the functions - some of them are already being tested via devtool in any case. (From OE-Core rev: 72d0cb3f8f1e69aeef93ea0bc90db3e8b8d6f94c) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-selftest/recipes-devtools')
-rw-r--r--meta-selftest/recipes-devtools/python/python-async-test.inc16
-rw-r--r--meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb2
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-selftest/recipes-devtools/python/python-async-test.inc b/meta-selftest/recipes-devtools/python/python-async-test.inc
new file mode 100644
index 0000000000..c9602e8e52
--- /dev/null
+++ b/meta-selftest/recipes-devtools/python/python-async-test.inc
@@ -0,0 +1,16 @@
1SUMMARY = "Python framework to process interdependent tasks in a pool of workers"
2HOMEPAGE = "http://github.com/gitpython-developers/async"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=88df8e78b9edfd744953862179f2d14e"
6
7inherit pypi
8
9PYPI_PACKAGE = "async"
10
11SRC_URI[md5sum] = "9b06b5997de2154f3bc0273f80bcef6b"
12SRC_URI[sha256sum] = "ac6894d876e45878faae493b0cf61d0e28ec417334448ac0a6ea2229d8343051"
13
14RDEPENDS_${PN} += "${PYTHON_PN}-threading"
15
16BBCLASSEXTEND = "nativesdk"
diff --git a/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb b/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb
new file mode 100644
index 0000000000..22e241afb3
--- /dev/null
+++ b/meta-selftest/recipes-devtools/python/python3-async-test_0.6.2.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-async-test.inc