diff options
author | Darren Hart <dvhart@linux.intel.com> | 2010-12-20 15:05:33 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-01-20 21:36:58 +0000 |
commit | 212b6874d1727755c1210c039efadab794f9a9ef (patch) | |
tree | 1cb853d578eb73cb4bbc03418f2970dd1e0830f6 /meta-rt | |
parent | 0b17496c4412321bda2e14115c14a1f8c2cd3153 (diff) | |
download | poky-212b6874d1727755c1210c039efadab794f9a9ef.tar.gz |
meta-rt/poky-image-*rt: Add initial PREEMPT_RT image recipes
Add poky-image-minimal-rt* image recipes. They are based on the minimal recipe
and add rt-tests for basic evaluation of a board with a PREEMPT_RT kernel.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Cc: Tom Zanussi <tom.zanussi@intel.com>
Cc: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-rt')
-rw-r--r-- | meta-rt/images/poky-image-minimal-rt-directdisk.bb | 15 | ||||
-rw-r--r-- | meta-rt/images/poky-image-minimal-rt-live.bb | 15 | ||||
-rw-r--r-- | meta-rt/images/poky-image-minimal-rt.bb | 12 |
3 files changed, 42 insertions, 0 deletions
diff --git a/meta-rt/images/poky-image-minimal-rt-directdisk.bb b/meta-rt/images/poky-image-minimal-rt-directdisk.bb new file mode 100644 index 0000000000..b68fe568b6 --- /dev/null +++ b/meta-rt/images/poky-image-minimal-rt-directdisk.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # | ||
2 | # Copyright (C) 2010 Intel Corporation. | ||
3 | # | ||
4 | |||
5 | require recipes-core/images/poky-image-directdisk.inc | ||
6 | |||
7 | DESCRIPTION = "Bootable Minimal Real-Time Direct Disk Image" | ||
8 | |||
9 | ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-rt-${MACHINE}.ext3" | ||
10 | |||
11 | LICENSE = "MIT" | ||
12 | |||
13 | do_bootdirectdisk[depends] += "poky-image-minimal-rt:do_rootfs" | ||
14 | |||
15 | |||
diff --git a/meta-rt/images/poky-image-minimal-rt-live.bb b/meta-rt/images/poky-image-minimal-rt-live.bb new file mode 100644 index 0000000000..01628dcc3f --- /dev/null +++ b/meta-rt/images/poky-image-minimal-rt-live.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # | ||
2 | # Copyright (C) 2010 Intel Corporation. | ||
3 | # | ||
4 | |||
5 | DESCRIPTION = "Bootable Live Minimal Real-Time Linux Image" | ||
6 | |||
7 | require recipes-core/images/poky-image-live.inc | ||
8 | |||
9 | LABELS += "boot install" | ||
10 | |||
11 | ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-rt-${MACHINE}.ext3" | ||
12 | |||
13 | LICENSE = "MIT" | ||
14 | |||
15 | do_bootimg[depends] += "poky-image-minimal-rt:do_rootfs" | ||
diff --git a/meta-rt/images/poky-image-minimal-rt.bb b/meta-rt/images/poky-image-minimal-rt.bb new file mode 100644 index 0000000000..6f5700c67a --- /dev/null +++ b/meta-rt/images/poky-image-minimal-rt.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | # | ||
2 | # Copyright (C) 2010 Intel Corporation. | ||
3 | # | ||
4 | |||
5 | DESCRIPTION = "Minimal Real-Time Linux Image" | ||
6 | DEPENDS = "linux-yocto-rt" | ||
7 | |||
8 | require recipes-core/images/poky-image-minimal.bb | ||
9 | |||
10 | IMAGE_INSTALL += "rt-tests" | ||
11 | |||
12 | LICENSE = "MIT" | ||