summaryrefslogtreecommitdiffstats
path: root/meta-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-19 15:31:45 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:21:55 +0100
commit897f83efc04af1104ce71baede95de86885ffd3a (patch)
tree74593ed8d2b69341c75e2d2151e7471bb651ac3e /meta-rt
parent3e8a98489dddb3bfc26309adcf83434852238445 (diff)
downloadpoky-897f83efc04af1104ce71baede95de86885ffd3a.tar.gz
meta-rt: refresh linux-yocto-rt recipe
Rename the recipe to match the linux-yocto recipe renames using the kernel version in the PV portion of the filename. Add the SRCREVs to the recipe as was done with the core linux-yocto recipes. Add qemux86 as it is also present in the linux-yocto-2.6.34.git repository. (From OE-Core rev: 6e9e19230ee731856639f71c5adfb01a92f620d8) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-rt')
-rw-r--r--meta-rt/conf/layer.conf6
-rw-r--r--meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb (renamed from meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb)12
2 files changed, 9 insertions, 9 deletions
diff --git a/meta-rt/conf/layer.conf b/meta-rt/conf/layer.conf
index 94ebc02520..f105405784 100644
--- a/meta-rt/conf/layer.conf
+++ b/meta-rt/conf/layer.conf
@@ -15,9 +15,3 @@ BBFILE_PRIORITY_rt = "8"
15# specified kernel providers and leave it up to the kernel recipe to 15# specified kernel providers and leave it up to the kernel recipe to
16# determine COMPATIBLE_MACHINE. 16# determine COMPATIBLE_MACHINE.
17PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt" 17PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
18
19# preempt_rt SRCREVs, one for meta, one per machine
20SRCREV_meta_pn-linux-yocto-rt ?= "b0615811ce38836d1ade230e3bdb1efaaa68471f"
21SRCREV_machine_pn-linux-yocto-rt_qemux86-64 ?= "f49444f06875894389e640bcda6c3f6ceb1f0c3e"
22SRCREV_machine_pn-linux-yocto-rt_atom-pc ?= "78dacaf8222c9492ba17f652989ef3466423bdc2"
23
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
index cba132176a..01a6761f7a 100644
--- a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb
+++ b/meta-rt/recipes-kernel/linux-yocto-rt_2.6.34.bb
@@ -1,6 +1,7 @@
1inherit kernel 1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc 2require recipes-kernel/linux/linux-yocto.inc
3 3
4KMACHINE_qemux86 = "common_pc"
4KMACHINE_qemux86-64 = "common_pc_64" 5KMACHINE_qemux86-64 = "common_pc_64"
5KMACHINE_atom-pc = "atom-pc" 6KMACHINE_atom-pc = "atom-pc"
6 7
@@ -11,11 +12,16 @@ LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
11KMETA = wrs_meta 12KMETA = wrs_meta
12KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE} 13KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
13 14
14PR = "r1" 15SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749"
16SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
17SRCREV_machine_atom-pc = "269d71029adcf4d1dbf8441f091d824478d8c87d"
18SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
19
20PR = "r2"
15PV = "${LINUX_VERSION}+git${SRCPV}" 21PV = "${LINUX_VERSION}+git${SRCPV}"
16SRCREV_FORMAT = "meta_machine" 22SRCREV_FORMAT = "meta_machine"
17 23
18COMPATIBLE_MACHINE = "(qemux86-64|atom-pc)" 24COMPATIBLE_MACHINE = "(qemux86|qemux86-64|atom-pc)"
19 25
20# this performs a fixup on the SRCREV for new/undefined BSPs 26# this performs a fixup on the SRCREV for new/undefined BSPs
21python __anonymous () { 27python __anonymous () {
@@ -25,7 +31,7 @@ python __anonymous () {
25 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d) 31 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
26} 32}
27 33
28SRC_URI = "git://git.yoctoproject.org/linux-2.6-windriver.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta" 34SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
29 35
30# Functionality flags 36# Functionality flags
31KERNEL_REVISION_CHECKING ?= "t" 37KERNEL_REVISION_CHECKING ?= "t"