summaryrefslogtreecommitdiffstats
path: root/meta-rt
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-25 11:10:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:21:57 +0100
commit15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471 (patch)
tree6c11b0eac733dbb884fe7587b64dbc069788176d /meta-rt
parentd9bf0a05c2b6676b5d4a4de5c3ccdbb70a25be17 (diff)
downloadpoky-15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471.tar.gz
Move meta-rt recipes to oe-core (meta)
Keeping the rt recipes in their own layer has led to maintenance issues, particularly with the linux-yocto-rt recipes. As these kernel types are part of the same linux-yocto source repository, it seems reasonable to include the rt kernel recipes alongside the standard recipes. A new recipes-rt directory for the other recipes provides adequate separation and eliminates the need for a separate layer. As there is no meta-rt/conf/layer.conf to force the kernel, users must now specify the rt kernel in their local.conf or in the machine.conf: PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt" The merging of the rt recipes into the core also eliminates complications with multiple layer dependencies for new BSP layers. Having to either separate RT BSPs from standard BSPs or force users to add meta-rt to bblayers even when not building an RT BSP (because the RT BSPs in the same layer would fail to parse without it) was sub-optimal at best. (From OE-Core rev: bafaaad264fe3e745c714951ddcf2784d33b755a) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-rt')
-rw-r--r--meta-rt/conf/layer.conf18
-rw-r--r--meta-rt/images/core-image-rt-sdk.bb15
-rw-r--r--meta-rt/images/core-image-rt.bb12
-rw-r--r--meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb44
-rw-r--r--meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb46
-rw-r--r--meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb22
6 files changed, 0 insertions, 157 deletions
diff --git a/meta-rt/conf/layer.conf b/meta-rt/conf/layer.conf
deleted file mode 100644
index 59f42b62fe..0000000000
--- a/meta-rt/conf/layer.conf
+++ /dev/null
@@ -1,18 +0,0 @@
1# Default to first disk/first partition
2RSP_ROOT ?= "sda1"
3
4# We have a conf and classes directory, add to BBPATH
5BBPATH := "${BBPATH}:${LAYERDIR}"
6
7# We have an images and various recipe-* directories, add to BBFILES
8BBFILES := "${BBFILES} ${LAYERDIR}/images/*.bb ${LAYERDIR}/images/*.bbappend \
9 ${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
10
11BBFILE_COLLECTIONS += "rt"
12BBFILE_PATTERN_rt := "^${LAYERDIR}/"
13BBFILE_PRIORITY_rt = "8"
14
15# This layer builds images using a PREEMPT_RT kernel. Override any machine
16# specified kernel providers and leave it up to the kernel recipe to
17# determine COMPATIBLE_MACHINE.
18PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
diff --git a/meta-rt/images/core-image-rt-sdk.bb b/meta-rt/images/core-image-rt-sdk.bb
deleted file mode 100644
index 6e983433aa..0000000000
--- a/meta-rt/images/core-image-rt-sdk.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1#
2# Copyright (C) 2011 Intel Corporation.
3#
4
5DESCRIPTION = "Real-Time Linux Image with SDK support"
6DEPENDS = "linux-yocto-rt"
7
8require recipes-core/images/core-image-minimal.bb
9
10IMAGE_FEATURES += "dev-pkgs tools-sdk"
11EXTRA_IMAGE_FEATURES += "tools-debug tools-profile tools-testapps debug-tweaks"
12
13IMAGE_INSTALL += "rt-tests"
14
15LICENSE = "MIT"
diff --git a/meta-rt/images/core-image-rt.bb b/meta-rt/images/core-image-rt.bb
deleted file mode 100644
index e11f159f7a..0000000000
--- a/meta-rt/images/core-image-rt.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1#
2# Copyright (C) 2010 Intel Corporation.
3#
4
5DESCRIPTION = "Real-Time Linux Image"
6DEPENDS = "linux-yocto-rt"
7
8require recipes-core/images/core-image-minimal.bb
9
10IMAGE_INSTALL += "rt-tests"
11
12LICENSE = "MIT"
diff --git a/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
deleted file mode 100644
index 0ca53ae436..0000000000
--- a/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common_pc"
6KMACHINE_qemux86-64 = "common_pc_64"
7
8LINUX_VERSION ?= "2.6.34"
9LINUX_KERNEL_TYPE = "preempt_rt"
10LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}"
11
12KMETA = wrs_meta
13KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE}
14
15SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749"
16SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e"
17SRCREV_machine = "439602eb6acd53d9beb8493710310214fc7bd749"
18SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b"
19
20PR = "r2"
21PV = "${LINUX_VERSION}+git${SRCPV}"
22SRCREV_FORMAT = "meta_machine"
23
24COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
25
26# this performs a fixup on the SRCREV for new/undefined BSPs
27python __anonymous () {
28 import bb, re, string
29
30 kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-")
31 bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d)
32}
33
34SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta"
35
36# Functionality flags
37KERNEL_REVISION_CHECKING ?= "t"
38KERNEL_FEATURES=features/netfilter
39
40# extra tasks
41addtask kernel_link_vmlinux after do_compile before do_install
42addtask validate_branches before do_patch after do_kernel_checkout
43
44require recipes-kernel/linux/linux-tools.inc
diff --git a/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb
deleted file mode 100644
index c8a175dad8..0000000000
--- a/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common-pc"
6KMACHINE_qemux86-64 = "common-pc-64"
7KMACHINE_qemuarm = "arm-versatile-926ejs"
8KMACHINE_qemuppc = "qemu-ppc32"
9KMACHINE_qemumips = "mti-malta32-be"
10
11KBRANCH = "yocto/standard/preempt-rt/base"
12KMETA = meta
13
14LINUX_VERSION ?= "3.0"
15LINUX_KERNEL_TYPE = "preempt-rt"
16LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
17
18SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"
19SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8"
20
21PR = "r0"
22PV = "${LINUX_VERSION}+git${SRCPV}"
23SRCREV_FORMAT = "meta_machine"
24
25SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
26
27# Omit broken machines from COMPATIBLE_MACHINE
28# qemuppc hangs at boot
29# qemumips panics at boot
30COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
31
32# Functionality flags
33KERNEL_REVISION_CHECKING ?= "t"
34KERNEL_FEATURES=features/netfilter
35KERNEL_FEATURES_append=" features/taskstats"
36KERNEL_FEATURES_append_qemux86=" cfg/sound"
37KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
38
39YOCTO_KERNEL_META_DATA=t
40
41# extra tasks
42addtask kernel_link_vmlinux after do_compile before do_install
43addtask validate_branches before do_patch after do_kernel_checkout
44addtask kernel_configcheck after do_configure before do_compile
45
46require recipes-kernel/linux/linux-tools.inc
diff --git a/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb b/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb
deleted file mode 100644
index 6334bcdeef..0000000000
--- a/meta-rt/recipes-tests/rt-tests/rt-tests_0.73.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1DESCRIPTION = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
4DEPENDS = "linux-libc-headers eglibc"
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
7 file://src/cyclictest/cyclictest.c;beginline=7;endline=9;md5=ce162fe491d19d2ec67dff6dbc938d50 \
8 file://src/pi_tests/pi_stress.c;beginline=6;endline=19;md5=bd426a634a43ec612e9fbf125dfcc949"
9SRCREV = v0.73
10PV = "git${SRCPV}"
11PR = "r0"
12
13SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/clrkwllms/rt-tests.git;protocol=git"
14
15S = "${WORKDIR}/git"
16
17CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnull"
18
19do_install() {
20 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
21 INCLUDEDIR=${includedir}
22}