diff options
author | Darren Hart <dvhart@linux.intel.com> | 2011-07-25 11:10:17 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-08-12 17:21:57 +0100 |
commit | 15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471 (patch) | |
tree | 6c11b0eac733dbb884fe7587b64dbc069788176d /meta-rt/recipes-kernel | |
parent | d9bf0a05c2b6676b5d4a4de5c3ccdbb70a25be17 (diff) | |
download | poky-15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471.tar.gz |
Move meta-rt recipes to oe-core (meta)
Keeping the rt recipes in their own layer has led to maintenance issues,
particularly with the linux-yocto-rt recipes. As these kernel types are part of
the same linux-yocto source repository, it seems reasonable to include the rt
kernel recipes alongside the standard recipes. A new recipes-rt directory for
the other recipes provides adequate separation and eliminates the need for a
separate layer.
As there is no meta-rt/conf/layer.conf to force the kernel, users must now
specify the rt kernel in their local.conf or in the machine.conf:
PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
The merging of the rt recipes into the core also eliminates complications with
multiple layer dependencies for new BSP layers. Having to either separate RT
BSPs from standard BSPs or force users to add meta-rt to bblayers even when not
building an RT BSP (because the RT BSPs in the same layer would fail to parse
without it) was sub-optimal at best.
(From OE-Core rev: bafaaad264fe3e745c714951ddcf2784d33b755a)
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-rt/recipes-kernel')
-rw-r--r-- | meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb | 44 | ||||
-rw-r--r-- | meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb | 46 |
2 files changed, 0 insertions, 90 deletions
diff --git a/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb b/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb deleted file mode 100644 index 0ca53ae436..0000000000 --- a/meta-rt/recipes-kernel/linux/linux-yocto-rt_2.6.34.bb +++ /dev/null | |||
@@ -1,44 +0,0 @@ | |||
1 | inherit kernel | ||
2 | require recipes-kernel/linux/linux-yocto.inc | ||
3 | |||
4 | KMACHINE = "common-pc" | ||
5 | KMACHINE_qemux86 = "common_pc" | ||
6 | KMACHINE_qemux86-64 = "common_pc_64" | ||
7 | |||
8 | LINUX_VERSION ?= "2.6.34" | ||
9 | LINUX_KERNEL_TYPE = "preempt_rt" | ||
10 | LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}" | ||
11 | |||
12 | KMETA = wrs_meta | ||
13 | KBRANCH = ${KMACHINE}-${LINUX_KERNEL_TYPE} | ||
14 | |||
15 | SRCREV_machine_qemux86 = "439602eb6acd53d9beb8493710310214fc7bd749" | ||
16 | SRCREV_machine_qemux86-64 = "3c84c45ad3c3592f9c7ff4076de9bee417cd322e" | ||
17 | SRCREV_machine = "439602eb6acd53d9beb8493710310214fc7bd749" | ||
18 | SRCREV_meta = "e1f85a470934a0cf6abde5d95533e74501822c6b" | ||
19 | |||
20 | PR = "r2" | ||
21 | PV = "${LINUX_VERSION}+git${SRCPV}" | ||
22 | SRCREV_FORMAT = "meta_machine" | ||
23 | |||
24 | COMPATIBLE_MACHINE = "(qemux86|qemux86-64)" | ||
25 | |||
26 | # this performs a fixup on the SRCREV for new/undefined BSPs | ||
27 | python __anonymous () { | ||
28 | import bb, re, string | ||
29 | |||
30 | kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-") | ||
31 | bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d) | ||
32 | } | ||
33 | |||
34 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.34.git;protocol=git;nocheckout=1;branch=${KBRANCH},wrs_meta;name=machine,meta" | ||
35 | |||
36 | # Functionality flags | ||
37 | KERNEL_REVISION_CHECKING ?= "t" | ||
38 | KERNEL_FEATURES=features/netfilter | ||
39 | |||
40 | # extra tasks | ||
41 | addtask kernel_link_vmlinux after do_compile before do_install | ||
42 | addtask validate_branches before do_patch after do_kernel_checkout | ||
43 | |||
44 | require recipes-kernel/linux/linux-tools.inc | ||
diff --git a/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb deleted file mode 100644 index c8a175dad8..0000000000 --- a/meta-rt/recipes-kernel/linux/linux-yocto-rt_3.0.bb +++ /dev/null | |||
@@ -1,46 +0,0 @@ | |||
1 | inherit kernel | ||
2 | require recipes-kernel/linux/linux-yocto.inc | ||
3 | |||
4 | KMACHINE = "common-pc" | ||
5 | KMACHINE_qemux86 = "common-pc" | ||
6 | KMACHINE_qemux86-64 = "common-pc-64" | ||
7 | KMACHINE_qemuarm = "arm-versatile-926ejs" | ||
8 | KMACHINE_qemuppc = "qemu-ppc32" | ||
9 | KMACHINE_qemumips = "mti-malta32-be" | ||
10 | |||
11 | KBRANCH = "yocto/standard/preempt-rt/base" | ||
12 | KMETA = meta | ||
13 | |||
14 | LINUX_VERSION ?= "3.0" | ||
15 | LINUX_KERNEL_TYPE = "preempt-rt" | ||
16 | LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}" | ||
17 | |||
18 | SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f" | ||
19 | SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8" | ||
20 | |||
21 | PR = "r0" | ||
22 | PV = "${LINUX_VERSION}+git${SRCPV}" | ||
23 | SRCREV_FORMAT = "meta_machine" | ||
24 | |||
25 | SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" | ||
26 | |||
27 | # Omit broken machines from COMPATIBLE_MACHINE | ||
28 | # qemuppc hangs at boot | ||
29 | # qemumips panics at boot | ||
30 | COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)" | ||
31 | |||
32 | # Functionality flags | ||
33 | KERNEL_REVISION_CHECKING ?= "t" | ||
34 | KERNEL_FEATURES=features/netfilter | ||
35 | KERNEL_FEATURES_append=" features/taskstats" | ||
36 | KERNEL_FEATURES_append_qemux86=" cfg/sound" | ||
37 | KERNEL_FEATURES_append_qemux86-64=" cfg/sound" | ||
38 | |||
39 | YOCTO_KERNEL_META_DATA=t | ||
40 | |||
41 | # extra tasks | ||
42 | addtask kernel_link_vmlinux after do_compile before do_install | ||
43 | addtask validate_branches before do_patch after do_kernel_checkout | ||
44 | addtask kernel_configcheck after do_configure before do_compile | ||
45 | |||
46 | require recipes-kernel/linux/linux-tools.inc | ||