diff options
author | Darren Hart <dvhart@linux.intel.com> | 2010-12-20 15:02:40 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-01-20 21:36:58 +0000 |
commit | 0d7d5666509c013228242b87c1dfd15395af6701 (patch) | |
tree | 64e733a571982bc274e7a96a562de306b2731656 /meta-rt/recipes-kernel | |
parent | 4de544015b41cde2938d8bb00fec48f470e6d7fb (diff) | |
download | poky-0d7d5666509c013228242b87c1dfd15395af6701.tar.gz |
meta-rt: Initial PREEMPT_RT layer and kernel recipes
The meta-rt layer provides a preempt_rt kernel recipe
using the linux-yocto-stable git tree. It overrides
the virtual/kernel provider and defines the compatible
machines and per-machine SRCREVs. The initial layer
supports only qemux86-64.
Signed-off-by: Darren Hart <dvhart@linux.intel.com>
Cc: Tom Zanussi <tom.zanussi@intel.com>
Cc: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-rt/recipes-kernel')
-rw-r--r-- | meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb new file mode 100644 index 0000000000..361b6806cd --- /dev/null +++ b/meta-rt/recipes-kernel/linux-yocto-rt_stablegit.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | inherit kernel | ||
2 | require recipes-kernel/linux/linux-yocto.inc | ||
3 | |||
4 | KMACHINE_qemux86-64 = "common_pc_64" | ||
5 | |||
6 | LINUX_VERSION ?= "2.6.34" | ||
7 | LINUX_KERNEL_TYPE = "preempt_rt" | ||
8 | LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE_EXTENSION}" | ||
9 | |||
10 | PR = "r0" | ||
11 | PV = "${LINUX_VERSION}+git${SRCPV}" | ||
12 | SRCREV_FORMAT = "meta_machine" | ||
13 | |||
14 | COMPATIBLE_MACHINE = "(qemux86-64)" | ||
15 | |||
16 | # this performs a fixup on the SRCREV for new/undefined BSPs | ||
17 | python __anonymous () { | ||
18 | import bb, re, string | ||
19 | |||
20 | rev = bb.data.getVar("SRCREV_machine", d, 1) | ||
21 | if rev == "standard": | ||
22 | bb.data.setVar("SRCREV_machine", "${SRCREV_meta}", d) | ||
23 | |||
24 | kerntype = string.replace(bb.data.expand("${LINUX_KERNEL_TYPE}", d), "_", "-") | ||
25 | bb.data.setVar("LINUX_KERNEL_TYPE_EXTENSION", kerntype, d) | ||
26 | } | ||
27 | |||
28 | SRC_URI = "git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;fullclone=1;branch=${KBRANCH};name=machine \ | ||
29 | git://git.pokylinux.org/linux-2.6-windriver.git;protocol=git;noclone=1;branch=wrs_meta;name=meta" | ||
30 | |||
31 | # Functionality flags | ||
32 | KERNEL_REVISION_CHECKING ?= "t" | ||
33 | KERNEL_FEATURES=features/netfilter | ||
34 | |||
35 | # extra tasks | ||
36 | addtask kernel_link_vmlinux after do_compile before do_install | ||
37 | addtask validate_branches before do_patch after do_kernel_checkout | ||
38 | |||
39 | require recipes-kernel/linux/linux-tools.inc | ||