summaryrefslogtreecommitdiffstats
path: root/meta-rt/conf
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2010-12-20 15:02:40 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-01-20 21:36:58 +0000
commit0d7d5666509c013228242b87c1dfd15395af6701 (patch)
tree64e733a571982bc274e7a96a562de306b2731656 /meta-rt/conf
parent4de544015b41cde2938d8bb00fec48f470e6d7fb (diff)
downloadpoky-0d7d5666509c013228242b87c1dfd15395af6701.tar.gz
meta-rt: Initial PREEMPT_RT layer and kernel recipes
The meta-rt layer provides a preempt_rt kernel recipe using the linux-yocto-stable git tree. It overrides the virtual/kernel provider and defines the compatible machines and per-machine SRCREVs. The initial layer supports only qemux86-64. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-rt/conf')
-rw-r--r--meta-rt/conf/layer.conf22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-rt/conf/layer.conf b/meta-rt/conf/layer.conf
new file mode 100644
index 0000000000..dbf4a326ba
--- /dev/null
+++ b/meta-rt/conf/layer.conf
@@ -0,0 +1,22 @@
1# Default to first disk/first partition
2RSP_ROOT ?= "sda1"
3
4# We have a conf and classes directory, add to BBPATH
5BBPATH := "${BBPATH}:${LAYERDIR}"
6
7# We have an images and various recipe-* directories, add to BBFILES
8BBFILES := "${BBFILES} ${LAYERDIR}/images/*.bb ${LAYERDIR}/images/*.bbappend ${LAYERDIR}/recipes-*/*.bb ${LAYERDIR}/recipes-*/*.bbappend"
9
10BBFILE_COLLECTIONS += "rt"
11BBFILE_PATTERN_rt := "^${LAYERDIR}/"
12BBFILE_PRIORITY_rt = "8"
13
14# This layer builds images using a PREEMPT_RT kernel. Override any machine
15# specified kernel providers and leave it up to the kernel recipe to
16# determine COMPATIBLE_MACHINE.
17PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt"
18
19# preempt_rt SRCREVs, one for meta, one per machine
20SRCREV_meta_pn-linux-yocto-rt ?= "50ccd2b3213b6a1bacb3f898c035119802dac420"
21SRCREV_machine_pn-linux-yocto-rt_qemux86-64 ?= "f49444f06875894389e640bcda6c3f6ceb1f0c3e"
22