summaryrefslogtreecommitdiffstats
path: root/meta-poky
diff options
context:
space:
mode:
authorbrian avery <brian.avery@intel.com>2017-07-21 19:39:53 (GMT)
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-24 08:13:55 (GMT)
commit0f20512deac20f3ec7241ff431c8523ce3c66034 (patch)
treeaf71286462adf73c3af3f4ec185a08e0b0c82e4a /meta-poky
parenta2b4731cef542059de589eead5c01c52093a06a9 (diff)
downloadpoky-0f20512deac20f3ec7241ff431c8523ce3c66034.tar.gz
poky: Remove machine specific kernel overrides
This patch removes the machine specific overrides in poky.conf for all the qemu machines. With this patch, if you set PREFERRED_VERSION_linux-yocto="X%" then all the qemu machines as well as the sample hardware boards will use that version. Without this patch, the hardware boards would have used version X but the qemu machines would have needed to have a PREFERRED_VERSION_linux-yocto_qemuarm="X%" for qemuarm to use that version, for example. If we need to force a specific machine (hardware or qemu) to a particular default version we should add it to the machine conf files for that machine, not in the distro conf. (From meta-yocto rev: 6b194a137dcedcae7e4b03f9ebed822d44f53fe2) Signed-off-by: brian avery <brian.avery@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-poky')
-rw-r--r--meta-poky/conf/distro/poky.conf10
1 files changed, 2 insertions, 8 deletions
diff --git a/meta-poky/conf/distro/poky.conf b/meta-poky/conf/distro/poky.conf
index c907969..d15e50e 100644
--- a/meta-poky/conf/distro/poky.conf
+++ b/meta-poky/conf/distro/poky.conf
@@ -22,12 +22,6 @@ POKY_DEFAULT_EXTRA_RRECOMMENDS = "kernel-module-af-packet"
22DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${DISTRO_FEATURES_LIBC} ${POKY_DEFAULT_DISTRO_FEATURES}" 22DISTRO_FEATURES ?= "${DISTRO_FEATURES_DEFAULT} ${DISTRO_FEATURES_LIBC} ${POKY_DEFAULT_DISTRO_FEATURES}"
23 23
24PREFERRED_VERSION_linux-yocto ?= "4.10%" 24PREFERRED_VERSION_linux-yocto ?= "4.10%"
25PREFERRED_VERSION_linux-yocto_qemux86 ?= "4.10%"
26PREFERRED_VERSION_linux-yocto_qemux86-64 ?= "4.10%"
27PREFERRED_VERSION_linux-yocto_qemuarm ?= "4.10%"
28PREFERRED_VERSION_linux-yocto_qemumips ?= "4.10%"
29PREFERRED_VERSION_linux-yocto_qemumips64 ?= "4.10%"
30PREFERRED_VERSION_linux-yocto_qemuppc ?= "4.10%"
31 25
32SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}" 26SDK_NAME = "${DISTRO}-${TCLIBC}-${SDK_ARCH}-${IMAGE_BASENAME}-${TUNE_PKGARCH}"
33SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}" 27SDKPATH = "/opt/${DISTRO}/${SDK_VERSION}"
@@ -84,9 +78,9 @@ SANITY_TESTED_DISTROS ?= " \
84 opensuse-42.2 \n \ 78 opensuse-42.2 \n \
85 " 79 "
86# 80#
87# OELAYOUT_ABI allows us to notify users when the format of TMPDIR changes in 81# OELAYOUT_ABI allows us to notify users when the format of TMPDIR changes in
88# an incompatible way. Such changes should usually be detailed in the commit 82# an incompatible way. Such changes should usually be detailed in the commit
89# that breaks the format and have been previously discussed on the mailing list 83# that breaks the format and have been previously discussed on the mailing list
90# with general agreement from the core team. 84# with general agreement from the core team.
91# 85#
92OELAYOUT_ABI = "12" 86OELAYOUT_ABI = "12"