summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-05-17 15:01:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-05-17 15:01:24 +0100
commit814700d243d8eae70dffa9bef5e5111ad6902d7f (patch)
treea2522e1967f79bb6fa18c38f38d96081ea3199cf /meta-openmoko
parentb8abc2db38a08e803c0b278cbe16f42b5f313a3c (diff)
downloadpoky-814700d243d8eae70dffa9bef5e5111ad6902d7f.tar.gz
Move libsampletate and libsndfile from meta-openmoko -> meta-moblin
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/libnotify/libnotify_0.4.4.bb14
-rw-r--r--meta-openmoko/packages/libsamplerate/libsamplerate0_0.1.2.bb14
-rw-r--r--meta-openmoko/packages/libsndfile/files/add-cxx.patch18
-rw-r--r--meta-openmoko/packages/libsndfile/libsndfile1_1.0.17.bb26
4 files changed, 0 insertions, 72 deletions
diff --git a/meta-openmoko/packages/libnotify/libnotify_0.4.4.bb b/meta-openmoko/packages/libnotify/libnotify_0.4.4.bb
deleted file mode 100644
index 7c95fb2ad6..0000000000
--- a/meta-openmoko/packages/libnotify/libnotify_0.4.4.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "Send desktop notifications to a notification daemon"
2HOMEPAGE = "http://www.galago-project.org/"
3SECTION = "libs"
4LICENSE = "LGPL"
5DEPENDS = "dbus gtk+ dbus-glib"
6PR = "r0"
7
8SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${PN}-${PV}.tar.gz"
9
10inherit autotools pkgconfig
11
12do_stage() {
13 autotools_stage_all
14}
diff --git a/meta-openmoko/packages/libsamplerate/libsamplerate0_0.1.2.bb b/meta-openmoko/packages/libsamplerate/libsamplerate0_0.1.2.bb
deleted file mode 100644
index 78a7f403d4..0000000000
--- a/meta-openmoko/packages/libsamplerate/libsamplerate0_0.1.2.bb
+++ /dev/null
@@ -1,14 +0,0 @@
1DESCRIPTION = "An audio Sample Rate Conversion library"
2SECTION = "libs"
3LICENSE = "GPL libsamplerate"
4PR = "r2"
5
6SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz"
7S = "${WORKDIR}/libsamplerate-${PV}"
8
9inherit autotools pkgconfig
10
11do_stage() {
12 oe_libinstall -a -so -C src libsamplerate ${STAGING_LIBDIR}
13 install -m 0644 ${S}/src/samplerate.h ${STAGING_INCDIR}/
14}
diff --git a/meta-openmoko/packages/libsndfile/files/add-cxx.patch b/meta-openmoko/packages/libsndfile/files/add-cxx.patch
deleted file mode 100644
index da0c4010e6..0000000000
--- a/meta-openmoko/packages/libsndfile/files/add-cxx.patch
+++ /dev/null
@@ -1,18 +0,0 @@
1---
2 configure.ac | 1 +
3 1 file changed, 1 insertion(+)
4
5--- libsndfile-1.0.17.orig/configure.ac
6+++ libsndfile-1.0.17/configure.ac
7@@ -29,10 +29,11 @@ AC_LANG([C])
8 # to 0.
9
10 SHARED_VERSION_INFO="1:17:0"
11
12 AC_PROG_CC
13+AC_PROG_CXX
14 AM_PROG_LIBTOOL
15
16 AC_CHECK_PROG(autogen, autogen, yes, no)
17
18 AC_PROG_INSTALL
diff --git a/meta-openmoko/packages/libsndfile/libsndfile1_1.0.17.bb b/meta-openmoko/packages/libsndfile/libsndfile1_1.0.17.bb
deleted file mode 100644
index f2d134b5e1..0000000000
--- a/meta-openmoko/packages/libsndfile/libsndfile1_1.0.17.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1DESCRIPTION = "An audio format Conversion library"
2HOMEPAGE = "http://www.mega-nerd.com/libsndfile"
3AUTHOR = "Erik de Castro Lopo"
4DEPENDS = "sqlite3"
5SECTION = "libs/multimedia"
6LICENSE = "LGPL"
7PR = "r2"
8
9SRC_URI = "http://www.mega-nerd.com/libsndfile/libsndfile-${PV}.tar.gz \
10 file://add-cxx.patch;patch=1"
11
12S = "${WORKDIR}/libsndfile-${PV}"
13
14inherit autotools lib_package pkgconfig
15
16do_configure_prepend_arm() {
17 export ac_cv_sys_largefile_source=1
18 export ac_cv_sys_file_offset_bits=64
19 ac_cv_sizeof_off_t=8
20}
21
22do_stage() {
23 oe_libinstall -a -so -C src libsndfile ${STAGING_LIBDIR}
24 install -m 0644 ${S}/src/sndfile.h ${STAGING_INCDIR}/
25}
26