summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-07-22 16:26:54 +0000
commit43aab47cfc79563a192b49f0ca40a86d04e93f8f (patch)
tree496118724ae8bcef5f2d646d4039802b758f2bb8 /meta-openmoko
parent0a968eeb415dc0aa829b1457ec8f404926ea6780 (diff)
downloadpoky-43aab47cfc79563a192b49f0ca40a86d04e93f8f.tar.gz
gsmd2: taken from OE, cleaned, fixed deps/building, improved packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4933 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb21
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch135
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2_git.bb25
3 files changed, 181 insertions, 0 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..410ac36e2f
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsm0710muxd_git.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "GSM 07.10 muxer userspace daemon"
2HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
3AUTHOR = "M. Dietrich"
4SECTION = "console/network"
5DEPENDS = "dbus dbus-glib"
6LICENSE = "GPL"
7PV = "0.9.1+gitr${SRCREV}"
8
9SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
10S = "${WORKDIR}/git"
11
12inherit autotools
13
14# install init script for people who want to manually
15# start/stop it, but don't add runlevels.
16do_install_append() {
17 install -d ${D}${sysconfdir}/init.d
18 install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
19}
20
21FILES_${PN} += "${datadir} ${sysconfdir}"
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
new file mode 100644
index 0000000000..01c598af48
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsmd2/fix-dbus-location.patch
@@ -0,0 +1,135 @@
1---
2 libfreesmartphone/Makefile.am | 14 +++++++-------
3 serial/Makefile.am | 2 +-
4 src/Makefile.am | 14 +++++++-------
5 3 files changed, 15 insertions(+), 15 deletions(-)
6
7--- git.orig/libfreesmartphone/Makefile.am
8+++ git/libfreesmartphone/Makefile.am
9@@ -21,47 +21,47 @@ fso-marshallers.h: $(top_srcdir)/src/sma
10 fso-marshallers.c: $(top_srcdir)/src/smartphone_marshaller.txt
11 glib-genmarshal --prefix fso_marshaller --body $(top_srcdir)/src/smartphone_marshaller.txt > fso-marshallers.c
12
13
14 freesmartphone-call-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
15- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
16+ $(LIBTOOL) --mode=execute dbus-binding-tool \
17 --prefix=smartphone_call --mode=glib-client \
18 --output=freesmartphone-call-binding.h \
19 $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
20
21 freesmartphone-sms-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
22- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
23+ $(LIBTOOL) --mode=execute dbus-binding-tool \
24 --prefix=smartphone_sms --mode=glib-client \
25 --output=freesmartphone-sms-binding.h \
26 $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
27
28 freesmartphone-device-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
29- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
30+ $(LIBTOOL) --mode=execute dbus-binding-tool \
31 --prefix=smartphone_device --mode=glib-client \
32 --output=freesmartphone-device-binding.h \
33 $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
34
35 freesmartphone-sim-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
36- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
37+ $(LIBTOOL) --mode=execute dbus-binding-tool \
38 --prefix=smartphone_sim --mode=glib-client \
39 --output=freesmartphone-sim-binding.h \
40 $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
41
42 freesmartphone-phonebook-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
43- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
44+ $(LIBTOOL) --mode=execute dbus-binding-tool \
45 --prefix=smartphone_phonebook --mode=glib-client \
46 --output=freesmartphone-phonebook-binding.h \
47 $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
48
49 freesmartphone-pdp-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
50- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
51+ $(LIBTOOL) --mode=execute dbus-binding-tool \
52 --prefix=smartphone_pdp --mode=glib-client \
53 --output=freesmartphone-pdp-binding.h \
54 $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
55
56 freesmartphone-network-binding.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
57- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
58+ $(LIBTOOL) --mode=execute dbus-binding-tool \
59 --prefix=smartphone_network --mode=glib-client \
60 --output=freesmartphone-network-binding.h \
61 $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
62
63 CLEANFILES = $(BUILT_SOURCES)
64--- git.orig/serial/Makefile.am
65+++ git/serial/Makefile.am
66@@ -11,11 +11,11 @@ COMMON_LDFLAGS = -avoid-version -module
67 BUILT_SOURCES = fsomuxer_client.h
68
69 CLEANFILES = $(BUILT_SOURCES)
70
71 fsomuxer_client.h: fsomuxer.xml
72- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
73+ $(LIBTOOL) --mode=execute dbus-binding-tool \
74 --mode=glib-client \
75 --output=fsomuxer_client.h \
76 fsomuxer.xml
77
78
79--- git.orig/src/Makefile.am
80+++ git/src/Makefile.am
81@@ -30,47 +30,47 @@ dbus_marshal.h: $(srcdir)/smartphone_mar
82 dbus_marshal.c: $(srcdir)/smartphone_marshaller.txt
83 glib-genmarshal --prefix gsmd_smartphone_marshaller --body $(srcdir)/smartphone_marshaller.txt > dbus_marshal.c
84
85
86 dbus_call_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
87- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
88+ $(LIBTOOL) --mode=execute dbus-binding-tool \
89 --prefix=smartphone_call --mode=glib-server \
90 --output=dbus_call_glue.h \
91 $(top_srcdir)/interface/org.freesmartphone.GSM.Call.xml
92
93 dbus_sms_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
94- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
95+ $(LIBTOOL) --mode=execute dbus-binding-tool \
96 --prefix=smartphone_sms --mode=glib-server \
97 --output=dbus_sms_glue.h \
98 $(top_srcdir)/interface/org.freesmartphone.GSM.SMS.xml
99
100 dbus_device_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
101- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
102+ $(LIBTOOL) --mode=execute dbus-binding-tool \
103 --prefix=smartphone_device --mode=glib-server \
104 --output=dbus_device_glue.h \
105 $(top_srcdir)/interface/org.freesmartphone.GSM.Device.xml
106
107 dbus_sim_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
108- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
109+ $(LIBTOOL) --mode=execute dbus-binding-tool \
110 --prefix=smartphone_sim --mode=glib-server \
111 --output=dbus_sim_glue.h \
112 $(top_srcdir)/interface/org.freesmartphone.GSM.SIM.xml
113
114 dbus_phonebook_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
115- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
116+ $(LIBTOOL) --mode=execute dbus-binding-tool \
117 --prefix=smartphone_phonebook --mode=glib-server \
118 --output=dbus_phonebook_glue.h \
119 $(top_srcdir)/interface/org.freesmartphone.GSM.Phonebook.xml
120
121 dbus_pdp_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
122- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
123+ $(LIBTOOL) --mode=execute dbus-binding-tool \
124 --prefix=smartphone_pdp --mode=glib-server \
125 --output=dbus_pdp_glue.h \
126 $(top_srcdir)/interface/org.freesmartphone.GSM.PDP.xml
127
128 dbus_network_glue.h: $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
129- $(LIBTOOL) --mode=execute /usr/bin/dbus-binding-tool \
130+ $(LIBTOOL) --mode=execute dbus-binding-tool \
131 --prefix=smartphone_network --mode=glib-server \
132 --output=dbus_network_glue.h \
133 $(top_srcdir)/interface/org.freesmartphone.GSM.Network.xml
134
135 gsmd-types.h: $(srcdir)/gsmd-error.h
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
new file mode 100644
index 0000000000..5983702d81
--- /dev/null
+++ b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "GSM 07.07 phone server"
2HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
3AUTHOR = "Ixonos Team"
4SECTION = "console/network"
5DEPENDS = "dbus-native dbus dbus-glib"
6RDEPENDS = "gsm0710muxd"
7LICENSE = "GPL"
8PV = "0.1.0+gitr${SRCREV}"
9PR = "r1"
10
11SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master \
12 file://fix-dbus-location.patch;patch=1"
13
14S = "${WORKDIR}/git"
15
16inherit autotools
17
18EXTRA_OECONF = "--disable-tests"
19
20PACKAGES =+ "libgsmd2 libfreesmartphone"
21
22FILES_libgsmd2 = "${libdir}/libgsmd2.so.* ${libdir}/gsmd2/*.so"
23FILES_libfreesmartphone = "${libdir}/libfreesmartphone.so.*"
24FILES_${PN}-dev += "${libdir}/gsmd2/*.*a"
25FILES_${PN} = "${bindir}/gsmd2"