summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-08-05 13:25:20 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-19 20:06:25 +0100
commit369920107edd8ae2487d71a324072fcfaba0731e (patch)
tree14aea71394438111dd1eda29db443ce9784aa314 /meta-openmoko
parent29ca8936493b2044c6926becca0ffcf3747b2528 (diff)
downloadpoky-369920107edd8ae2487d71a324072fcfaba0731e.tar.gz
deploy.bbclass: use new style staging for deploy tasks
All tasks which implement a do_deploy should inherit this class to have the changes in the deploy task staged. Update recipes which include a do_deploy function to inherit this class and to use DEPLOYDIR rather than DEPLOY_DIR_IMAGE. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
index 13948b9aa3..c049500a61 100644
--- a/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
+++ b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
@@ -1,12 +1,11 @@
1require dfu-util_${PV}.bb 1require dfu-util_${PV}.bb
2 2
3inherit native 3inherit native deploy
4 4
5DEPENDS = "libusb-native usbpath-native" 5DEPENDS = "libusb-native usbpath-native"
6 6
7do_deploy() { 7do_deploy() {
8 install -d ${DEPLOY_DIR_IMAGE} 8 install -m 0755 src/dfu-util_static ${DEPLOYDIR}/dfu-util
9 install -m 0755 src/dfu-util_static ${DEPLOY_DIR_IMAGE}/dfu-util
10} 9}
11 10
12addtask deploy before do_package after do_install 11addtask deploy before do_package after do_install