summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-05 15:48:38 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-05 15:48:38 +0000
commit139d1570605aeef3238a173ca90d81bb791d6b8a (patch)
tree0b41993a2a63e9e5eb1ebd8779837c37102aabb2 /meta-openmoko
parent5853cf2e14840e1ba15eeb78c474cc20813a8b4d (diff)
downloadpoky-139d1570605aeef3238a173ca90d81bb791d6b8a.tar.gz
dfu-util: added from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3068 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb17
-rw-r--r--meta-openmoko/packages/dfu-util/dfu-util_svn.bb17
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
new file mode 100644
index 0000000000..457094df9e
--- /dev/null
+++ b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
@@ -0,0 +1,17 @@
1require dfu-util_${PV}.bb
2
3inherit native
4
5DEPENDS = "libusb-native usbpath-native"
6
7do_stage() {
8 install -d ${STAGING_BINDIR_NATIVE}
9 install -m 0755 src/dfu-util ${STAGING_BINDIR_NATIVE}/
10}
11
12do_deploy() {
13 install -d ${DEPLOY_DIR_IMAGE}
14 install -m 0755 src/dfu-util_static ${DEPLOY_DIR_IMAGE}/dfu-util
15}
16
17addtask deploy before do_package after do_install
diff --git a/meta-openmoko/packages/dfu-util/dfu-util_svn.bb b/meta-openmoko/packages/dfu-util/dfu-util_svn.bb
new file mode 100644
index 0000000000..1f34a5bc24
--- /dev/null
+++ b/meta-openmoko/packages/dfu-util/dfu-util_svn.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "USB Device Firmware Upgrade utility"
2SECTION = "devel"
3AUTHOR = "Harald Welte"
4LICENSE = "GPL"
5PV = "0.1+svnr${SRCREV}"
6PR = "r0"
7
8DEPENDS = "libusb usbpath"
9
10SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=dfu-util;proto=http"
11S = "${WORKDIR}/dfu-util"
12
13inherit autotools
14
15do_stage() {
16 autotools_stage_all
17}