diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-21 17:40:55 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-04-21 17:40:55 +0100 |
commit | 5df6deaa32e4f6d0a8985403970a137270491991 (patch) | |
tree | bfc61fc292038a9cf5c35e0dccc8d7c101e96085 /meta-openmoko/packages | |
parent | 12856d95a7e729914f8d0dbe55d9c28df65bc718 (diff) | |
download | poky-5df6deaa32e4f6d0a8985403970a137270491991.tar.gz |
puslseaudio: Upgrade to 0.9.10
Upgrade to 0.9.10, moving pulseaudio to meta-moblin cleaning up and
merging in some changes from OE.dev. Also add libcanberra 0.10.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-openmoko/packages')
14 files changed, 0 insertions, 355 deletions
diff --git a/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch b/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch deleted file mode 100644 index 31d147be7d..0000000000 --- a/meta-openmoko/packages/pulseaudio/files/disable-using-glibc-tls.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | Index: pulseaudio-0.9.9/configure.ac | ||
2 | =================================================================== | ||
3 | --- pulseaudio-0.9.9.orig/configure.ac 2008-01-24 01:06:06.000000000 +0000 | ||
4 | +++ pulseaudio-0.9.9/configure.ac 2008-02-05 17:45:59.000000000 +0000 | ||
5 | @@ -139,8 +139,8 @@ | ||
6 | ret=$? | ||
7 | rm -f conftest.o conftest | ||
8 | if test $ret -eq 0 ; then | ||
9 | - AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().]) | ||
10 | - AC_MSG_RESULT([yes]) | ||
11 | +dnl AC_DEFINE([HAVE_TLS_BUILTIN], 1, [Have __thread().]) | ||
12 | + AC_MSG_RESULT([no]) | ||
13 | else | ||
14 | AC_MSG_RESULT([no]) | ||
15 | fi | ||
16 | @@ -325,8 +325,7 @@ | ||
17 | rm -f conftest.o conftest | ||
18 | |||
19 | if test $ret -eq 0 ; then | ||
20 | - AC_DEFINE([HAVE_PTHREAD_PRIO_INHERIT], 1, [Have PTHREAD_PRIO_INHERIT.]) | ||
21 | - AC_MSG_RESULT([yes]) | ||
22 | + AC_MSG_RESULT([no]) | ||
23 | else | ||
24 | AC_MSG_RESULT([no]) | ||
25 | fi | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch b/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch deleted file mode 100644 index f8ac5674a6..0000000000 --- a/meta-openmoko/packages/pulseaudio/files/fix-dbus-without-hal.patch +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | Index: pulseaudio-0.9.8/src/Makefile.am | ||
2 | =================================================================== | ||
3 | --- pulseaudio-0.9.8.orig/src/Makefile.am | ||
4 | +++ pulseaudio-0.9.8/src/Makefile.am | ||
5 | @@ -1424,8 +1424,8 @@ | ||
6 | # HAL | ||
7 | libdbus_util_la_SOURCES = modules/dbus-util.c modules/dbus-util.h | ||
8 | libdbus_util_la_LDFLAGS = -avoid-version | ||
9 | -libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) libpulsecore.la | ||
10 | -libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) | ||
11 | +libdbus_util_la_LIBADD = $(AM_LIBADD) $(HAL_LIBS) $(DBUS_LIBS) libpulsecore.la | ||
12 | +libdbus_util_la_CFLAGS = $(AM_CFLAGS) $(HAL_CFLAGS) $(DBUS_CFLAGS) | ||
13 | |||
14 | module_hal_detect_la_SOURCES = modules/module-hal-detect.c | ||
15 | module_hal_detect_la_LDFLAGS = -module -avoid-version | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/fix-shm.patch b/meta-openmoko/packages/pulseaudio/files/fix-shm.patch deleted file mode 100644 index 3bf61d0d34..0000000000 --- a/meta-openmoko/packages/pulseaudio/files/fix-shm.patch +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | # fixes building against uclibc | ||
2 | # fixed upstream, see http://www.pulseaudio.org/ticket/200 | ||
3 | Index: pulseaudio-0.9.9/src/pulsecore/shm.c | ||
4 | =================================================================== | ||
5 | --- pulseaudio-0.9.9/src/pulsecore/shm.c (revision 1971) | ||
6 | +++ pulseaudio-0.9.9/src/pulsecore/shm.c (revision 2110) | ||
7 | @@ -319,4 +319,5 @@ | ||
8 | int pa_shm_cleanup(void) { | ||
9 | |||
10 | +#ifdef HAVE_SHM_OPEN | ||
11 | #ifdef SHM_PATH | ||
12 | DIR *d; | ||
13 | @@ -376,5 +377,6 @@ | ||
14 | |||
15 | closedir(d); | ||
16 | -#endif | ||
17 | +#endif /* SHM_PATH */ | ||
18 | +#endif /* HAVE_SHM_OPEN */ | ||
19 | |||
20 | return 0; | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch b/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch deleted file mode 100644 index 34ad026e4d..0000000000 --- a/meta-openmoko/packages/pulseaudio/files/gcc4-compile-fix.patch +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | | fix for more strict syntax compliance in gcc4.x | ||
2 | | pulsecore/core-util.c: In function 'pa_raise_priority': | ||
3 | | pulsecore/core-util.c:547: error: label at end of compound statement | ||
4 | | Signed off: mickey@openmoko.org | ||
5 | | | ||
6 | Index: pulseaudio-0.9.6/src/pulsecore/core-util.c | ||
7 | =================================================================== | ||
8 | --- pulseaudio-0.9.6.orig/src/pulsecore/core-util.c | ||
9 | +++ pulseaudio-0.9.6/src/pulsecore/core-util.c | ||
10 | @@ -535,7 +535,7 @@ void pa_raise_priority(void) { | ||
11 | pa_log_info("Successfully gained high priority class."); | ||
12 | #endif | ||
13 | |||
14 | -fail: | ||
15 | +fail:; | ||
16 | |||
17 | #if defined(HAVE_SYS_CAPABILITY_H) | ||
18 | if (caps) { | ||
diff --git a/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse b/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse deleted file mode 100644 index 5b1998032b..0000000000 --- a/meta-openmoko/packages/pulseaudio/files/volatiles.04_pulse +++ /dev/null | |||
@@ -1,2 +0,0 @@ | |||
1 | # <type> <owner> <group> <mode> <path> <linksource> | ||
2 | d pulse pulse 0755 /var/run/pulse none | ||
diff --git a/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch b/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch deleted file mode 100644 index 51161dbe0f..0000000000 --- a/meta-openmoko/packages/pulseaudio/libatomics-ops/fedora/libatomic_ops-1.2-ppclwzfix.patch +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | http://cvs.fedoraproject.org/viewcvs/devel/libatomic_ops/libatomic_ops-1.2-ppclwzfix.patch | ||
2 | |||
3 | * add fix for bad variable handling on PPC | ||
4 | |||
5 | --- libatomic_ops-1.2.orig/src/atomic_ops/sysdeps/gcc/powerpc.h 2007-05-29 19:29:52.000000000 +0200 | ||
6 | +++ libatomic_ops-1.2/src/atomic_ops/sysdeps/gcc/powerpc.h 2007-05-29 19:30:48.000000000 +0200 | ||
7 | @@ -72,7 +72,7 @@ | ||
8 | /* registers. I always got "impossible constraint" when I */ | ||
9 | /* tried the "y" constraint. */ | ||
10 | __asm__ __volatile__ ( | ||
11 | - "lwz %0,%1\n" | ||
12 | + "lwz%U1%X1 %0,%1\n" | ||
13 | "cmpw cr7,%0,%0\n" | ||
14 | "bne- cr7,1f\n" | ||
15 | "1: isync\n" | ||
diff --git a/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb b/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb deleted file mode 100644 index 0563eb6382..0000000000 --- a/meta-openmoko/packages/pulseaudio/libatomics-ops_1.2.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | DESCRIPTION = "A library for atomic integer operations" | ||
2 | LICENSE = "MIT" | ||
3 | |||
4 | PR = "r1" | ||
5 | |||
6 | SRC_URI = "http://www.hpl.hp.com/research/linux/atomic_ops/download/libatomic_ops-1.2.tar.gz \ | ||
7 | file://fedora/libatomic_ops-1.2-ppclwzfix.patch;patch=1" | ||
8 | |||
9 | S = "${WORKDIR}/libatomic_ops-${PV}" | ||
10 | |||
11 | inherit autotools pkgconfig | ||
12 | |||
13 | do_stage() { | ||
14 | autotools_stage_all | ||
15 | } | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulse.inc b/meta-openmoko/packages/pulseaudio/pulse.inc deleted file mode 100644 index 4b13980cc4..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulse.inc +++ /dev/null | |||
@@ -1,101 +0,0 @@ | |||
1 | DESCRIPTION = "Pulseaudio is a sound server for Linux and Unix-like operating systems." | ||
2 | HOMEPAGE = "http://www.pulseaudio.org" | ||
3 | AUTHOR = "Lennart Poettering" | ||
4 | SECTION = "libs/multimedia" | ||
5 | LICENSE = "LGPL" | ||
6 | DEPENDS = "libatomics-ops liboil avahi libsamplerate0 libsndfile1 libtool hal" | ||
7 | # optional | ||
8 | DEPENDS += "alsa-lib glib-2.0" | ||
9 | |||
10 | SRC_URI = "http://0pointer.de/lennart/projects/pulseaudio/pulseaudio-${PV}.tar.gz \ | ||
11 | file://gcc4-compile-fix.patch;patch=1 \ | ||
12 | file://volatiles.04_pulse" | ||
13 | |||
14 | inherit autotools pkgconfig | ||
15 | |||
16 | EXTRA_OECONF = "\ | ||
17 | --disable-lynx \ | ||
18 | --without-x \ | ||
19 | --without-jack \ | ||
20 | --with-glib \ | ||
21 | --with-alsa \ | ||
22 | --with-oss \ | ||
23 | --with-hal \ | ||
24 | " | ||
25 | |||
26 | PARALLEL_MAKE = "" | ||
27 | |||
28 | export TARGET_PFPU = "${TARGET_FPU}" | ||
29 | |||
30 | # TODO: Use more fine granular version | ||
31 | #OE_LT_RPATH_ALLOW=":${libdir}/pulse-0.9:" | ||
32 | OE_LT_RPATH_ALLOW = "any" | ||
33 | OE_LT_RPATH_ALLOW[export]="1" | ||
34 | |||
35 | do_stage() { | ||
36 | autotools_stage_all | ||
37 | } | ||
38 | |||
39 | do_install_append() { | ||
40 | install -d ${D}${sysconfdir}/default/volatiles | ||
41 | install -m 0644 ${WORKDIR}/volatiles.04_pulse ${D}${sysconfdir}/default/volatiles/volatiles.04_pulse | ||
42 | |||
43 | if [ "x${TARGET_PFPU}" == "xsoft" ] ; then | ||
44 | sed -i -e s:\;\ resample-method\ =\ sinc-fastest:resample-method\ =\ trivial: ${D}${sysconfdir}/pulse/daemon.conf | ||
45 | fi | ||
46 | } | ||
47 | |||
48 | PACKAGES =+ "libpulsecore libpulse libpulse-simple libpulse-browse libpulse-mainloop-glib \ | ||
49 | pulseaudio-server pulseaudio-misc pulseaudio-gconf-helper" | ||
50 | |||
51 | #upgrade path: | ||
52 | RREPLACES_pulseaudio-server = "libpulse-bin libpulse-conf" | ||
53 | |||
54 | PACKAGES_DYNAMIC = "pulseaudio-lib* pulseaudio-module* libpulse-lib* libpulse-module* " | ||
55 | |||
56 | FILES_libpulsecore = "${libdir}/libpulsecore.so.*" | ||
57 | FILES_libpulse = "${libdir}/libpulse.so.*" | ||
58 | FILES_libpulse-simple = "${libdir}/libpulse-simple.so.*" | ||
59 | FILES_libpulse-browse = "${libdir}/libpulse-browse.so.*" | ||
60 | FILES_libpulse-mainloop-glib = "${libdir}/libpulse-mainloop-glib.so.*" | ||
61 | |||
62 | FILES_${PN}-dbg += "${libexecdir}/pulse/.debug \ | ||
63 | ${libdir}/pulse-0.9/modules/.debug" | ||
64 | FILES_${PN}-dev += "${libdir}/pulse-0.9/modules/*.la" | ||
65 | FILES_${PN}-conf = "${sysconfdir}" | ||
66 | FILES_${PN}-bin = "${bindir}/* \ | ||
67 | ${sysconfdir}/default/volatiles/volatiles.04_pulse" | ||
68 | FILES_${PN}-server = "${bindir}/pulseaudio ${sysconfdir}" | ||
69 | FILES_${PN}-gconf-helper = "${libexecdir}/pulse/gconf-helper" | ||
70 | FILES_${PN}-misc = "${bindir}/*" | ||
71 | |||
72 | CONFFILES_pulseaudio-server = "\ | ||
73 | ${sysconfdir}/pulse/default.pa \ | ||
74 | ${sysconfdir}/pulse/daemon.conf \ | ||
75 | ${sysconfdir}/pulse/client.conf \ | ||
76 | " | ||
77 | |||
78 | pkg_postinst_${PN}-server() { | ||
79 | # can't do this offline | ||
80 | if [ "x$D" != "x" ]; then | ||
81 | exit 1 | ||
82 | fi | ||
83 | grep -q pulse: /etc/group || addgroup pulse | ||
84 | grep -q pulse: /etc/passwd || \ | ||
85 | adduser --disabled-password --home=/var/run/pulse --system \ | ||
86 | --ingroup pulse --no-create-home -g "Pulse audio daemon" pulse | ||
87 | addgroup pulse audio | ||
88 | /etc/init.d/populate-volatile.sh update | ||
89 | } | ||
90 | |||
91 | pkg_postrm_${PN}-server() { | ||
92 | deluser pulse || true | ||
93 | } | ||
94 | |||
95 | python populate_packages_prepend() { | ||
96 | #bb.data.setVar('PKG_pulseaudio', 'pulseaudio', d) | ||
97 | |||
98 | plugindir = bb.data.expand('${libdir}/pulse-0.9/modules/', d) | ||
99 | do_split_packages(d, plugindir, '^module-(.*)\.so$', 'pulseaudio-module-%s', 'PulseAudio module for %s', extra_depends='' ) | ||
100 | do_split_packages(d, plugindir, '^lib(.*)\.so$', 'pulseaudio-lib-%s', 'PulseAudio library for %s', extra_depends='' ) | ||
101 | } | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff deleted file mode 100644 index 666ed34ad3..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2113.diff +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | from upstream svn r2113 | ||
2 | |||
3 | Index: configure.ac | ||
4 | =================================================================== | ||
5 | --- configure.ac (wersja 2112) | ||
6 | +++ configure.ac (wersja 2113) | ||
7 | @@ -172,6 +172,12 @@ | ||
8 | AC_SUBST(LIBLTDL) | ||
9 | AC_CONFIG_SUBDIRS(libltdl) | ||
10 | |||
11 | +old_LIBS=$LIBS | ||
12 | +LIBS="$LIBS $LIBLTDL" | ||
13 | +AC_CHECK_FUNCS([lt_dlmutex_register]) | ||
14 | +LIBS=$old_LIBS | ||
15 | +AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>]) | ||
16 | + | ||
17 | if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then | ||
18 | AC_MSG_ERROR([[ | ||
19 | |||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff deleted file mode 100644 index cbd82eeb84..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/2114.diff +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | from upstream svn r2114 | ||
2 | |||
3 | Index: configure.ac | ||
4 | =================================================================== | ||
5 | --- configure.ac (wersja 2113) | ||
6 | +++ configure.ac (wersja 2114) | ||
7 | @@ -176,7 +176,7 @@ | ||
8 | LIBS="$LIBS $LIBLTDL" | ||
9 | AC_CHECK_FUNCS([lt_dlmutex_register]) | ||
10 | LIBS=$old_LIBS | ||
11 | -AC_CHECK_TYPES([lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>]) | ||
12 | +AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>]) | ||
13 | |||
14 | if test "x$enable_ltdl_install" = "xno" && test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then | ||
15 | AC_MSG_ERROR([[ | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch deleted file mode 100644 index 4234af5f53..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libpulsedsp-references-libpulsecore.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | upstream: http://pulseaudio.org/ticket/287 | ||
2 | |||
3 | Index: pulseaudio-0.9.10/src/Makefile.am | ||
4 | =================================================================== | ||
5 | --- pulseaudio-0.9.10.orig/src/Makefile.am 2008-03-30 03:43:05.000000000 +0200 | ||
6 | +++ pulseaudio-0.9.10/src/Makefile.am 2008-05-03 11:55:46.000000000 +0200 | ||
7 | @@ -605,7 +605,7 @@ | ||
8 | |||
9 | libpulsedsp_la_SOURCES = utils/padsp.c | ||
10 | libpulsedsp_la_CFLAGS = $(AM_CFLAGS) | ||
11 | -libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la | ||
12 | +libpulsedsp_la_LIBADD = $(AM_LIBADD) libpulse.la libpulsecore.la | ||
13 | libpulsedsp_la_LDFLAGS = -avoid-version | ||
14 | |||
15 | ################################### | ||
16 | @@ -888,7 +888,7 @@ | ||
17 | |||
18 | libpstream_util_la_SOURCES = pulsecore/pstream-util.c pulsecore/pstream-util.h | ||
19 | libpstream_util_la_LDFLAGS = -avoid-version | ||
20 | -libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la | ||
21 | +libpstream_util_la_LIBADD = $(AM_LIBADD) libpacket.la libpstream.la libtagstruct.la libpulsecore.la | ||
22 | |||
23 | libpdispatch_la_SOURCES = pulsecore/pdispatch.c pulsecore/pdispatch.h | ||
24 | libpdispatch_la_LDFLAGS = -avoid-version | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch deleted file mode 100644 index 9e9e5f55d3..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4 | ||
2 | |||
3 | --- | ||
4 | configure.ac | 26 +++++++++++++++++++------- | ||
5 | 1 file changed, 19 insertions(+), 7 deletions(-) | ||
6 | |||
7 | --- pulseaudio-0.9.10.orig/configure.ac | ||
8 | +++ pulseaudio-0.9.10/configure.ac | ||
9 | @@ -242,20 +242,32 @@ if test $ret -eq 0 ; then | ||
10 | else | ||
11 | AC_MSG_RESULT([no]) | ||
12 | fi | ||
13 | |||
14 | #### libtool stuff #### | ||
15 | - | ||
16 | -AC_LTDL_ENABLE_INSTALL | ||
17 | -AC_LIBLTDL_INSTALLABLE | ||
18 | -AC_LIBTOOL_DLOPEN | ||
19 | -AC_LIBTOOL_WIN32_DLL | ||
20 | +LT_PREREQ([2.2]) | ||
21 | +LT_INIT([dlopen win32-dll]) | ||
22 | AC_PROG_LIBTOOL | ||
23 | -AC_SUBST(LTDLINCL) | ||
24 | -AC_SUBST(LIBLTDL) | ||
25 | +#AC_SUBST(LTDLINCL) | ||
26 | +#AC_SUBST(LIBLTDL) | ||
27 | AC_CONFIG_SUBDIRS(libltdl) | ||
28 | |||
29 | +AC_ARG_WITH(libltdl-libs, | ||
30 | + [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval) | ||
31 | +if test x$libltdl_libs_prefix != x; then | ||
32 | + LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl" | ||
33 | +fi | ||
34 | +AC_SUBST(LIBLTDL) | ||
35 | + | ||
36 | +AC_ARG_WITH(libltdl-includes, | ||
37 | + [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval) | ||
38 | +if test x$libltdl_prefix != x; then | ||
39 | + LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so" | ||
40 | +fi | ||
41 | +AC_SUBST(LTDLINCL) | ||
42 | + | ||
43 | + | ||
44 | old_LIBS=$LIBS | ||
45 | LIBS="$LIBS $LIBLTDL" | ||
46 | AC_CHECK_FUNCS([lt_dlmutex_register]) | ||
47 | LIBS=$old_LIBS | ||
48 | AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>]) | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch deleted file mode 100644 index 74ea6ac060..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/pa-drop-caps-returns-void.patch +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | upstream: http://pulseaudio.org/changeset/2213 | ||
2 | |||
3 | Index: pulseaudio-0.9.10/src/daemon/caps.c | ||
4 | =================================================================== | ||
5 | --- pulseaudio-0.9.10.orig/src/daemon/caps.c 2008-05-03 12:10:26.000000000 +0200 | ||
6 | +++ pulseaudio-0.9.10/src/daemon/caps.c 2008-05-03 12:10:30.000000000 +0200 | ||
7 | @@ -131,9 +131,8 @@ | ||
8 | return 0; | ||
9 | } | ||
10 | |||
11 | -int pa_drop_caps(void) { | ||
12 | +void pa_drop_caps(void) { | ||
13 | pa_drop_root(); | ||
14 | - return 0; | ||
15 | } | ||
16 | |||
17 | #endif | ||
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb b/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb deleted file mode 100644 index 671fb66a96..0000000000 --- a/meta-openmoko/packages/pulseaudio/pulseaudio_0.9.10.bb +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | require pulse.inc | ||
2 | |||
3 | DEPENDS += "dbus" | ||
4 | PR = "r2" | ||
5 | |||
6 | # this is not correct (see below) | ||
7 | SRC_URI += "\ | ||
8 | file://disable-using-glibc-tls.patch;patch=1 \ | ||
9 | file://libpulsedsp-references-libpulsecore.patch;patch=1 \ | ||
10 | file://pa-drop-caps-returns-void.patch;patch=1 \ | ||
11 | file://2113.diff;patch=1;pnum=0 \ | ||
12 | file://2114.diff;patch=1;pnum=0 \ | ||
13 | file://libtool2.patch;patch=1 \ | ||
14 | " | ||
15 | |||
16 | EXTRA_OECONF += "--with-libltdl-includes=${STAGING_INCDIR}/libltdl/ --with-libltdl-libs=${STAGING_LIBDIR}" | ||
17 | |||
18 | # problems w/ pulseaudio 0.9.10 atm: | ||
19 | # 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime) | ||
20 | # 2.) doesn't build w/ glibc TLS support (hence patched out) | ||
21 | # 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out) | ||