summaryrefslogtreecommitdiffstats
path: root/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2008-05-23 14:09:11 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2008-05-23 14:09:11 +0000
commitf4db03f644ea8e36d10273f9bdda74c58730dde5 (patch)
treed7e84b0509c396b39161b352d1ae09fae32f9d23 /meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
parentd4740e0ebca2579c69ac6da6703c4d91472b39c1 (diff)
downloadpoky-f4db03f644ea8e36d10273f9bdda74c58730dde5.tar.gz
pulseaudio: merge with OE + patches for libtool 2.2
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@4550 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch')
-rw-r--r--meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
new file mode 100644
index 0000000000..9e9e5f55d3
--- /dev/null
+++ b/meta-openmoko/packages/pulseaudio/pulseaudio-0.9.10/libtool2.patch
@@ -0,0 +1,48 @@
1Tell where is libltdl from libtool - was needed to get it built with libtool 2.2.4
2
3---
4 configure.ac | 26 +++++++++++++++++++-------
5 1 file changed, 19 insertions(+), 7 deletions(-)
6
7--- pulseaudio-0.9.10.orig/configure.ac
8+++ pulseaudio-0.9.10/configure.ac
9@@ -242,20 +242,32 @@ if test $ret -eq 0 ; then
10 else
11 AC_MSG_RESULT([no])
12 fi
13
14 #### libtool stuff ####
15-
16-AC_LTDL_ENABLE_INSTALL
17-AC_LIBLTDL_INSTALLABLE
18-AC_LIBTOOL_DLOPEN
19-AC_LIBTOOL_WIN32_DLL
20+LT_PREREQ([2.2])
21+LT_INIT([dlopen win32-dll])
22 AC_PROG_LIBTOOL
23-AC_SUBST(LTDLINCL)
24-AC_SUBST(LIBLTDL)
25+#AC_SUBST(LTDLINCL)
26+#AC_SUBST(LIBLTDL)
27 AC_CONFIG_SUBDIRS(libltdl)
28
29+AC_ARG_WITH(libltdl-libs,
30+ [ --with-libltdl-libs=DIR path to libltdl libs], libltdl_libs_prefix=$withval)
31+if test x$libltdl_libs_prefix != x; then
32+ LIBLTDL="-L${libltdl_libs_prefix}/libltdl.so -lltdl"
33+fi
34+AC_SUBST(LIBLTDL)
35+
36+AC_ARG_WITH(libltdl-includes,
37+ [ --with-libltdl-includes=DIR path to libltdl includes], libltdl_prefix=$withval)
38+if test x$libltdl_prefix != x; then
39+ LTDLINCL="-I${libltdl_prefix} ${libltdl_libs_prefix}/libltdl.so"
40+fi
41+AC_SUBST(LTDLINCL)
42+
43+
44 old_LIBS=$LIBS
45 LIBS="$LIBS $LIBLTDL"
46 AC_CHECK_FUNCS([lt_dlmutex_register])
47 LIBS=$old_LIBS
48 AC_CHECK_TYPES([struct lt_user_dlloader, lt_dladvise], , , [#include <ltdl.h>])