diff options
author | Joshua Lock <josh@linux.intel.com> | 2010-05-24 12:05:01 +0100 |
---|---|---|
committer | Joshua Lock <josh@linux.intel.com> | 2010-05-24 12:05:25 +0100 |
commit | 9f23e3e49119c4529aee1f4879a59c2482b9292c (patch) | |
tree | c3b29ef7889ef91d0af14bee564bf944c9f5d2b4 /meta-moblin | |
parent | 6bf1f8c76e0d69ed64c5f0bb9e9b24215c32dfbe (diff) | |
download | poky-9f23e3e49119c4529aee1f4879a59c2482b9292c.tar.gz |
Update directdisk images to use common inc files
Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta-moblin')
3 files changed, 18 insertions, 20 deletions
diff --git a/meta-moblin/packages/images/moblin-image-directdisk.inc b/meta-moblin/packages/images/moblin-image-directdisk.inc new file mode 100644 index 0000000000..bcce9d5389 --- /dev/null +++ b/meta-moblin/packages/images/moblin-image-directdisk.inc | |||
@@ -0,0 +1,8 @@ | |||
1 | inherit boot-directdisk | ||
2 | |||
3 | do_bootdirectdisk_prepend () { | ||
4 | import bb | ||
5 | fstypes = bb.data.getVar('IMAGE_FSTYPES', d, True) | ||
6 | if 'ext3' not in fstypes: | ||
7 | bb.msg.fatal(bb.msg.domain.Build, "ext3 not in IMAGE_FSTYPES") | ||
8 | } | ||
diff --git a/meta-moblin/packages/images/moblin-image-netbook-directdisk.bb b/meta-moblin/packages/images/moblin-image-netbook-directdisk.bb new file mode 100644 index 0000000000..3de2944c80 --- /dev/null +++ b/meta-moblin/packages/images/moblin-image-netbook-directdisk.bb | |||
@@ -0,0 +1,10 @@ | |||
1 | # | ||
2 | # Copyright (C) 2010 Intel Corporation. | ||
3 | # | ||
4 | require moblin-image-directdisk.inc | ||
5 | |||
6 | DESCRIPTION = "Moblin Direct Disk Image" | ||
7 | |||
8 | ROOTFS = "${DEPLOY_DIR_IMAGE}/moblin-image-netbook-${MACHINE}.ext3" | ||
9 | |||
10 | do_bootdirectdisk[depends] += "moblin-image-netbook:do_rootfs" | ||
diff --git a/meta-moblin/packages/images/moblin-image-netbook.directdisk.bb b/meta-moblin/packages/images/moblin-image-netbook.directdisk.bb deleted file mode 100644 index c64e77bd2d..0000000000 --- a/meta-moblin/packages/images/moblin-image-netbook.directdisk.bb +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | # | ||
2 | # Copyright (C) 2008 Intel Corporation. | ||
3 | # | ||
4 | DESCRIPTION = "Moblin Direct Disk Image" | ||
5 | |||
6 | IMAGE_FEATURES += "apps-console-core ${NETBOOK_IMAGE_FEATURES}" | ||
7 | |||
8 | inherit boot-directdisk | ||
9 | inherit moblin-image | ||
10 | |||
11 | do_bootdirectdisk_prepend () { | ||
12 | import bb | ||
13 | fstypes = bb.data.getVar('IMAGE_FSTYPES', d, True) | ||
14 | if 'ext3' not in fstypes: | ||
15 | bb.msg.fatal(bb.msg.domain.Build, "ext3 not in IMAGE_FSTYPES") | ||
16 | } | ||
17 | |||
18 | ROOTFS = "${DEPLOY_DIR_IMAGE}/moblin-image-netbook-${MACHINE}.ext3" | ||
19 | |||
20 | do_bootdirectdisk[depends] += "moblin-image-netbook:do_rootfs" | ||