diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-06-23 18:25:28 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-06-23 18:25:28 +0100 |
commit | 579e8506155a05ddffab00de8bd0e751a9c4c885 (patch) | |
tree | 7cb7d4148f313c0710446298cb060babfb26e9a7 /meta-moblin | |
parent | 03cd4f4b519fb8c68063b171f565410827f3a96b (diff) | |
download | poky-579e8506155a05ddffab00de8bd0e751a9c4c885.tar.gz |
moblin-web-browser: Update against latest SCM changes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin')
3 files changed, 49 insertions, 13 deletions
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch new file mode 100644 index 0000000000..a8675868a3 --- /dev/null +++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | Index: git/configure.ac | ||
2 | =================================================================== | ||
3 | --- git.orig/configure.ac 2009-06-10 15:01:55.000000000 +0100 | ||
4 | +++ git/configure.ac 2009-06-10 15:19:36.000000000 +0100 | ||
5 | @@ -36,6 +36,13 @@ | ||
6 | MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul-unstable`"/unstable" | ||
7 | AC_SUBST([MOZIDLDIR]) | ||
8 | |||
9 | +IDLPREFIX= | ||
10 | +AC_ARG_WITH(idl-prefix, AC_HELP_STRING([--with-idl-prefix=DIR],[prefix to add to access to the idl files]), with_idl_prefix=${withval}) | ||
11 | +if test x"${with_idl_prefix}" != x ; then | ||
12 | + IDLPREFIX=${with_idl_prefix} | ||
13 | +fi | ||
14 | +AC_SUBST([IDLPREFIX]) | ||
15 | + | ||
16 | AC_PATH_PROG(DBUSBINDINGTOOL, dbus-binding-tool) | ||
17 | |||
18 | AC_OUTPUT([ | ||
19 | Index: git/libmwbpages/Makefile.am | ||
20 | =================================================================== | ||
21 | --- git.orig/libmwbpages/Makefile.am 2009-06-10 15:01:55.000000000 +0100 | ||
22 | +++ git/libmwbpages/Makefile.am 2009-06-10 15:20:12.000000000 +0100 | ||
23 | @@ -23,10 +23,10 @@ | ||
24 | mwb-start-page.lo : MwbIStartPage.h | ||
25 | |||
26 | MwbIStartPage.h : MwbIStartPage.idl | ||
27 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m header $< | ||
28 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m header $< | ||
29 | |||
30 | MwbIStartPage.xpt : MwbIStartPage.idl | ||
31 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $< | ||
32 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $< | ||
33 | |||
34 | xpt_DATA = MwbIStartPage.xpt | ||
35 | xptdir = $(MOZHOME)/components | ||
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch index a8675868a3..e920b50eeb 100644 --- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch +++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch | |||
@@ -1,9 +1,9 @@ | |||
1 | Index: git/configure.ac | 1 | Index: git/configure.ac |
2 | =================================================================== | 2 | =================================================================== |
3 | --- git.orig/configure.ac 2009-06-10 15:01:55.000000000 +0100 | 3 | --- git.orig/configure.ac 2009-06-23 17:46:31.000000000 +0100 |
4 | +++ git/configure.ac 2009-06-10 15:19:36.000000000 +0100 | 4 | +++ git/configure.ac 2009-06-23 17:46:48.000000000 +0100 |
5 | @@ -36,6 +36,13 @@ | 5 | @@ -44,6 +44,13 @@ |
6 | MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul-unstable`"/unstable" | 6 | MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul`"" |
7 | AC_SUBST([MOZIDLDIR]) | 7 | AC_SUBST([MOZIDLDIR]) |
8 | 8 | ||
9 | +IDLPREFIX= | 9 | +IDLPREFIX= |
@@ -18,18 +18,18 @@ Index: git/configure.ac | |||
18 | AC_OUTPUT([ | 18 | AC_OUTPUT([ |
19 | Index: git/libmwbpages/Makefile.am | 19 | Index: git/libmwbpages/Makefile.am |
20 | =================================================================== | 20 | =================================================================== |
21 | --- git.orig/libmwbpages/Makefile.am 2009-06-10 15:01:55.000000000 +0100 | 21 | --- git.orig/libmwbpages/Makefile.am 2009-06-23 17:46:31.000000000 +0100 |
22 | +++ git/libmwbpages/Makefile.am 2009-06-10 15:20:12.000000000 +0100 | 22 | +++ git/libmwbpages/Makefile.am 2009-06-23 17:47:46.000000000 +0100 |
23 | @@ -23,10 +23,10 @@ | 23 | @@ -27,10 +27,10 @@ |
24 | mwb-start-page.lo : MwbIStartPage.h | 24 | mwb-gettext.lo : MwbIGettext.h |
25 | 25 | ||
26 | MwbIStartPage.h : MwbIStartPage.idl | 26 | .idl.h : |
27 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m header $< | 27 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m header $< |
28 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m header $< | 28 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m header $< |
29 | 29 | ||
30 | MwbIStartPage.xpt : MwbIStartPage.idl | 30 | .idl.xpt : |
31 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $< | 31 | - $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $< |
32 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $< | 32 | + xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $< |
33 | 33 | ||
34 | xpt_DATA = MwbIStartPage.xpt | 34 | dist_xpt_DATA = MwbIStartPage.xpt MwbIGettext.xpt |
35 | xptdir = $(MOZHOME)/components | 35 | xptdir = $(MOZHOME)/components |
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb index bb7e2ff0d7..3b84542c05 100644 --- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb +++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb | |||
@@ -1,9 +1,10 @@ | |||
1 | DESCRIPTION = "Moblin web browser (based on clutter + mozilla-headless/mozilla-offscreen)" | 1 | DESCRIPTION = "Moblin web browser (based on clutter + mozilla-headless/mozilla-offscreen)" |
2 | SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \ | 2 | SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \ |
3 | file://xpidl.patch;patch=1" | 3 | file://xpidl-b55d523da7681febfabf9fc40dcd6fcee982b079.patch;patch=1;rev=b55d523da7681febfabf9fc40dcd6fcee982b079 \ |
4 | file://xpidl.patch;patch=1;notrev=b55d523da7681febfabf9fc40dcd6fcee982b079" | ||
4 | LICENSE = "LGPLv2.1" | 5 | LICENSE = "LGPLv2.1" |
5 | PV = "0.0+git${SRCPV}" | 6 | PV = "0.0+git${SRCPV}" |
6 | PR = "r2" | 7 | PR = "r3" |
7 | 8 | ||
8 | DEPENDS = "clutter clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless" | 9 | DEPENDS = "clutter clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless" |
9 | 10 | ||