summaryrefslogtreecommitdiffstats
path: root/meta-moblin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-08-13 14:47:46 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-08-13 14:47:46 +0100
commit5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33 (patch)
tree49768aabc3f85f642febf08d1ce2922caa7ef9fe /meta-moblin
parent5a5fdd72bc1e3aac12e812f3f23a4ad46b0729bb (diff)
downloadpoky-5c3a5e9ec2f23e782618a8a2dceecbe4bb771d33.tar.gz
moblin-web-browser: Update patch against master
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch28
-rw-r--r--meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb2
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
index e920b50eeb..73abea2c12 100644
--- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser/xpidl.patch
@@ -1,26 +1,26 @@
1Index: git/configure.ac 1Index: git/configure.ac
2=================================================================== 2===================================================================
3--- git.orig/configure.ac 2009-06-23 17:46:31.000000000 +0100 3--- git.orig/configure.ac 2009-08-12 15:12:47.000000000 +0100
4+++ git/configure.ac 2009-06-23 17:46:48.000000000 +0100 4+++ git/configure.ac 2009-08-12 15:13:47.000000000 +0100
5@@ -44,6 +44,13 @@ 5@@ -54,6 +54,13 @@
6 MOZIDLDIR=`${PKG_CONFIG} --variable=idldir libxul`"" 6 PKG_CHECK_MODULES(CLUTTER_MOZEMBED, clutter-mozembed-0.10)
7 AC_SUBST([MOZIDLDIR]) 7 PKG_CHECK_MODULES(GTK, gtk+-2.0)
8 8
9+IDLPREFIX= 9+IDLPREFIX=
10+AC_ARG_WITH(idl-prefix, AC_HELP_STRING([--with-idl-prefix=DIR],[prefix to add to access to the idl files]), with_idl_prefix=${withval}) 10+AC_ARG_WITH(idl-prefix, AC_HELP_STRING([--with-idl-prefix=DIR],[prefix to add to access to the idl files]), with_idl_prefix=${withval})
11+if test x"${with_idl_prefix}" != x ; then 11+if test x"${with_idl_prefix}" != x ; then
12+ IDLPREFIX=${with_idl_prefix} 12+ IDLPREFIX=${with_idl_prefix}
13+fi 13+fi
14+AC_SUBST([IDLPREFIX]) 14+AC_SUBST([IDLPREFIX])
15+ 15+
16 AC_PATH_PROG(DBUSBINDINGTOOL, dbus-binding-tool) 16 if test "x$build_browser" = "xyes"; then
17 17 PKG_CHECK_MODULES(MWB,
18 AC_OUTPUT([ 18 clutter-1.0
19Index: git/libmwbpages/Makefile.am 19Index: git/libmwbpages/Makefile.am
20=================================================================== 20===================================================================
21--- git.orig/libmwbpages/Makefile.am 2009-06-23 17:46:31.000000000 +0100 21--- git.orig/libmwbpages/Makefile.am 2009-08-12 15:12:47.000000000 +0100
22+++ git/libmwbpages/Makefile.am 2009-06-23 17:47:46.000000000 +0100 22+++ git/libmwbpages/Makefile.am 2009-08-12 15:12:47.000000000 +0100
23@@ -27,10 +27,10 @@ 23@@ -31,10 +31,10 @@
24 mwb-gettext.lo : MwbIGettext.h 24 mwb-gettext.lo : MwbIGettext.h
25 25
26 .idl.h : 26 .idl.h :
@@ -31,5 +31,5 @@ Index: git/libmwbpages/Makefile.am
31- $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $< 31- $(MOZHOME)/xpidl -I $(MOZIDLDIR) -m typelib $<
32+ xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $< 32+ xpidl -I $(IDLPREFIX)$(MOZIDLDIR) -m typelib $<
33 33
34 dist_xpt_DATA = MwbIStartPage.xpt MwbIGettext.xpt 34 dist_xpt_DATA = MwbISettings.xpt MwbIStartPage.xpt MwbIGettext.xpt
35 xptdir = $(MOZHOME)/components 35 xptdir = $(pkgdatadir)/components
diff --git a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
index 5e42fc5a50..09dd21a4ff 100644
--- a/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
+++ b/meta-moblin/packages/moblin-web-browser/moblin-web-browser_git.bb
@@ -4,7 +4,7 @@ SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
4 file://xpidl.patch;patch=1;notrev=b55d523da7681febfabf9fc40dcd6fcee982b079" 4 file://xpidl.patch;patch=1;notrev=b55d523da7681febfabf9fc40dcd6fcee982b079"
5LICENSE = "LGPLv2.1" 5LICENSE = "LGPLv2.1"
6PV = "0.0+git${SRCPV}" 6PV = "0.0+git${SRCPV}"
7PR = "r5" 7PR = "r6"
8 8
9DEPENDS = "clutter-1.0 clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless" 9DEPENDS = "clutter-1.0 clutter-mozembed clutter-gtk libunique mozilla-headless-services libccss nbtk mozilla-headless"
10 10