summaryrefslogtreecommitdiffstats
path: root/meta-moblin
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-07-13 13:29:23 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 00:46:57 +0100
commit9fcba301febcfce937b3d0890d4ba3b43369fcd6 (patch)
tree6835e8e023dd9a075a8eac705e6b0f3f468969c1 /meta-moblin
parenta4fb2c9666129c0df55f871ddc7bb989909cd31f (diff)
downloadpoky-9fcba301febcfce937b3d0890d4ba3b43369fcd6.tar.gz
libpcre: move from meta-moblin to meta and update to 8.10
Move the libpcre from meta-moblin, update to the latest release and enable native build. Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/libpcre/files/pcre-cross.patch25
-rw-r--r--meta-moblin/packages/libpcre/libpcre_7.6.bb51
2 files changed, 0 insertions, 76 deletions
diff --git a/meta-moblin/packages/libpcre/files/pcre-cross.patch b/meta-moblin/packages/libpcre/files/pcre-cross.patch
deleted file mode 100644
index 0626fb347a..0000000000
--- a/meta-moblin/packages/libpcre/files/pcre-cross.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1To be upstreamable, this patch requires check for *_FOR_BUILD, otherwise
2it needs to pass special variables.
3
4It would be nice to implement per-target compiler specification to
5automake, as it is done for linker.
6
7Even better it would be nice to implement native build time targets in
8automake.
9
10Index: pcre-7.6/Makefile.am
11===================================================================
12--- pcre-7.6.orig/Makefile.am 2008-01-23 17:58:28.000000000 +0000
13+++ pcre-7.6/Makefile.am 2008-04-03 22:32:00.000000000 +0000
14@@ -147,6 +147,11 @@
15
16 noinst_PROGRAMS += dftables
17 dftables_SOURCES = dftables.c
18+dftables_LINK = $(LINK_FOR_BUILD) -o $@
19+dftables_LDFLAGS = $(LDFLAGS_FOR_BUILD)
20+
21+dftables.o: $(srcdir)/dftables.c
22+ $(CC_FOR_BUILD) -c $(CFLAGS_FOR_BUILD) -o $@ $(srcdir)/dftables.c
23
24 pcre_chartables.c: dftables$(EXEEXT)
25 ./dftables$(EXEEXT) $@
diff --git a/meta-moblin/packages/libpcre/libpcre_7.6.bb b/meta-moblin/packages/libpcre/libpcre_7.6.bb
deleted file mode 100644
index 2cca2b19d2..0000000000
--- a/meta-moblin/packages/libpcre/libpcre_7.6.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
2API, but a set of 'wrapper' functions that are based on the POSIX API \
3are also supplied in the library libpcreposix. Note that this just \
4provides a POSIX calling interface to PCRE; the regular expressions \
5themselves still follow Perl syntax and semantics. The header file for \
6the POSIX-style functions is called pcreposix.h."
7SECTION = "devel"
8PR = "r4"
9LICENSE = "BSD"
10SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
11 file://pcre-cross.patch;patch=1"
12S = "${WORKDIR}/pcre-${PV}"
13
14PROVIDES = "pcre"
15
16inherit autotools binconfig
17
18PARALLEL_MAKE = ""
19
20CFLAGS_append = " -D_REENTRANT"
21CXXFLAGS_powerpc += "-lstdc++"
22EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
23
24do_compile () {
25 # stop libtool from trying to link with host libraries - fix from #33
26 # this resolve build problem on amd64 - #1015
27 if [ -e ${S}/${TARGET_SYS}-libtool ] ; then
28 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
29 else
30 ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool
31 sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
32 fi
33
34 # The generation of dftables can lead to timestamp problems with ccache
35 # because the generated config.h seems newer. It is sufficient to ensure that the
36 # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
37 # only used for this).
38 oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
39}
40
41python populate_packages_prepend () {
42 pcre_libdir = bb.data.expand('${libdir}', d)
43 pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d)
44 do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True)
45 do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
46 do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev')
47 do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True)
48}
49
50FILES_${PN} = "${libdir}/libpcre.so.*"
51FILES_${PN}-dev += "${bindir}/*"