summaryrefslogtreecommitdiffstats
path: root/meta-moblin
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2010-07-20 19:07:52 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 16:00:55 +0100
commit912a5c9c6ad68b1a7e1b24af280d9cd1d834ad53 (patch)
treec6853773f3b7897972b2623ccf40d0bc1ede0dea /meta-moblin
parent61d808bf4a5f93c1eccbf6dd2a22a57e849b641c (diff)
downloadpoky-912a5c9c6ad68b1a7e1b24af280d9cd1d834ad53.tar.gz
latencytop: upgrade from 0.4 to the latest version 0.5
Add BUGTRACKER Rebase the patch latencytop-makefile.patch and update the patch folder's name Add LIC_FILES_CHKSUM Reset PR to "r0" Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch32
-rw-r--r--meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch32
-rw-r--r--meta-moblin/packages/latencytop/latencytop_0.5.bb (renamed from meta-moblin/packages/latencytop/latencytop_0.4.bb)9
3 files changed, 39 insertions, 34 deletions
diff --git a/meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch b/meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch
deleted file mode 100644
index 8840d3880c..0000000000
--- a/meta-moblin/packages/latencytop/latencytop-0.4/latencytop-makefile.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1--- a/Makefile 2008-11-14 22:55:51.000000000 +0800
2+++ b/Makefile 2008-11-14 23:00:51.000000000 +0800
3@@ -1,7 +1,8 @@
4 DESTDIR =
5 SBINDIR = /usr/sbin
6 XCFLAGS = -W `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
7-LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncursesw
8+LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncurses
9+CC ?= gcc
10
11 #
12 # The w in -lncursesw is not a typo; it is the wide-character version
13@@ -14,10 +15,10 @@ LDF = -Wl,--as-needed `pkg-config --libs
14
15 # We write explicity this "implicit rule"
16 %.o : %.c
17- gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
18+ $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
19
20 latencytop: latencytop.o display.o latencytop.h translate.o Makefile
21- gcc $(CFLAGS) latencytop.o display.o translate.o $(LDF) -o latencytop
22+ $(CC) $(CFLAGS) latencytop.o display.o translate.o $(LDF) -o latencytop
23
24
25 clean:
26@@ -25,5 +26,6 @@ clean:
27
28 install: latencytop
29 mkdir -p $(DESTDIR)/usr/share/latencytop
30+ mkdir -p $(DESTDIR)$(SBINDIR)
31 install -m 0644 latencytop.trans $(DESTDIR)/usr/share/latencytop/latencytop.trans
32 install -m 0755 latencytop $(DESTDIR)$(SBINDIR)/
diff --git a/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch b/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch
new file mode 100644
index 0000000000..b979f57cae
--- /dev/null
+++ b/meta-moblin/packages/latencytop/latencytop-0.5/latencytop-makefile.patch
@@ -0,0 +1,32 @@
1--- a/Makefile 2010-07-20 18:51:32.000000000 +0800
2+++ b/Makefile 2010-07-20 18:54:54.000000000 +0800
3@@ -4,7 +4,8 @@
4 DESTDIR =
5 SBINDIR = /usr/sbin
6 XCFLAGS = -W -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
7-LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncursesw
8+LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncurses
9+CC ?= gcc
10
11 OBJS= latencytop.o text_display.o translate.o fsync.o
12
13@@ -26,16 +27,17 @@
14
15 # We write explicity this "implicit rule"
16 %.o : %.c
17- gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
18+ $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
19
20 latencytop: $(OBJS) latencytop.h Makefile
21- gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop
22+ $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop
23
24 clean:
25 rm -f *~ latencytop DEADJOE *.o
26
27 install: latencytop
28 mkdir -p $(DESTDIR)/usr/share/latencytop
29+ mkdir -p $(DESTDIR)/$(SBINDIR)
30 install -m 0644 latencytop.trans $(DESTDIR)/usr/share/latencytop/latencytop.trans
31 install -m 0644 *.png $(DESTDIR)/usr/share/latencytop/
32 install -m 0755 latencytop $(DESTDIR)$(SBINDIR)/
diff --git a/meta-moblin/packages/latencytop/latencytop_0.4.bb b/meta-moblin/packages/latencytop/latencytop_0.5.bb
index 706d0817b5..2deb7303b0 100644
--- a/meta-moblin/packages/latencytop/latencytop_0.4.bb
+++ b/meta-moblin/packages/latencytop/latencytop_0.5.bb
@@ -1,11 +1,16 @@
1DESCRIPTION = "LatencyTOP, a Linux tool measuring and fixing latency" 1DESCRIPTION = "LatencyTOP, a Linux tool measuring and fixing latency"
2HOMEPAGE = "http://www.latencytop.org/" 2HOMEPAGE = "http://www.latencytop.org/"
3BUGTRACKER = "n/a"
4
3LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://latencytop.c;endline=23;md5=ee9ea9b1415356e5734adad4a87dc7fa"
7
4DEPENDS = "virtual/libintl ncurses glib-2.0" 8DEPENDS = "virtual/libintl ncurses glib-2.0"
5PR = "r1" 9
10PR = "r0"
6 11
7SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \ 12SRC_URI = "http://www.latencytop.org/download/latencytop-${PV}.tar.gz \
8 file://latencytop-makefile.patch;patch=1" 13 file://latencytop-makefile.patch"
9 14
10CFLAGS += "${LDFLAGS}" 15CFLAGS += "${LDFLAGS}"
11 16