diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2009-07-16 12:09:07 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2009-07-16 12:09:07 +0100 |
commit | d4d60b9ad9b3c16e1f795e8eb8c6996dca4553e7 (patch) | |
tree | a639003167671987236d829ce0fc485a6c11353b /meta-moblin | |
parent | 43e94412c45b4b79485a64010c76d89b245bb235 (diff) | |
download | poky-d4d60b9ad9b3c16e1f795e8eb8c6996dca4553e7.tar.gz |
Add libpcre from OE.dev
Diffstat (limited to 'meta-moblin')
-rw-r--r-- | meta-moblin/packages/libpcre/files/pcre-cross.patch | 25 | ||||
-rw-r--r-- | meta-moblin/packages/libpcre/libpcre_7.6.bb | 57 |
2 files changed, 82 insertions, 0 deletions
diff --git a/meta-moblin/packages/libpcre/files/pcre-cross.patch b/meta-moblin/packages/libpcre/files/pcre-cross.patch new file mode 100644 index 0000000000..0626fb347a --- /dev/null +++ b/meta-moblin/packages/libpcre/files/pcre-cross.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | To be upstreamable, this patch requires check for *_FOR_BUILD, otherwise | ||
2 | it needs to pass special variables. | ||
3 | |||
4 | It would be nice to implement per-target compiler specification to | ||
5 | automake, as it is done for linker. | ||
6 | |||
7 | Even better it would be nice to implement native build time targets in | ||
8 | automake. | ||
9 | |||
10 | Index: pcre-7.6/Makefile.am | ||
11 | =================================================================== | ||
12 | --- pcre-7.6.orig/Makefile.am 2008-01-23 17:58:28.000000000 +0000 | ||
13 | +++ pcre-7.6/Makefile.am 2008-04-03 22:32:00.000000000 +0000 | ||
14 | @@ -147,6 +147,11 @@ | ||
15 | |||
16 | noinst_PROGRAMS += dftables | ||
17 | dftables_SOURCES = dftables.c | ||
18 | +dftables_LINK = $(LINK_FOR_BUILD) -o $@ | ||
19 | +dftables_LDFLAGS = $(LDFLAGS_FOR_BUILD) | ||
20 | + | ||
21 | +dftables.o: $(srcdir)/dftables.c | ||
22 | + $(CC_FOR_BUILD) -c $(CFLAGS_FOR_BUILD) -o $@ $(srcdir)/dftables.c | ||
23 | |||
24 | pcre_chartables.c: dftables$(EXEEXT) | ||
25 | ./dftables$(EXEEXT) $@ | ||
diff --git a/meta-moblin/packages/libpcre/libpcre_7.6.bb b/meta-moblin/packages/libpcre/libpcre_7.6.bb new file mode 100644 index 0000000000..aa038c6e95 --- /dev/null +++ b/meta-moblin/packages/libpcre/libpcre_7.6.bb | |||
@@ -0,0 +1,57 @@ | |||
1 | DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \ | ||
2 | API, but a set of 'wrapper' functions that are based on the POSIX API \ | ||
3 | are also supplied in the library libpcreposix. Note that this just \ | ||
4 | provides a POSIX calling interface to PCRE; the regular expressions \ | ||
5 | themselves still follow Perl syntax and semantics. The header file for \ | ||
6 | the POSIX-style functions is called pcreposix.h." | ||
7 | SECTION = "devel" | ||
8 | PR = "r4" | ||
9 | LICENSE = "BSD" | ||
10 | SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \ | ||
11 | file://pcre-cross.patch;patch=1" | ||
12 | S = "${WORKDIR}/pcre-${PV}" | ||
13 | |||
14 | PROVIDES = "pcre" | ||
15 | |||
16 | inherit autotools binconfig | ||
17 | |||
18 | PARALLEL_MAKE = "" | ||
19 | |||
20 | CFLAGS_append = " -D_REENTRANT" | ||
21 | CXXFLAGS_powerpc += "-lstdc++" | ||
22 | EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8" | ||
23 | |||
24 | do_compile () { | ||
25 | # stop libtool from trying to link with host libraries - fix from #33 | ||
26 | # this resolve build problem on amd64 - #1015 | ||
27 | if [ -e ${S}/${TARGET_SYS}-libtool ] ; then | ||
28 | sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool | ||
29 | else | ||
30 | ln -sf ${S}/libtool ${S}/${TARGET_SYS}-libtool | ||
31 | sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool | ||
32 | fi | ||
33 | |||
34 | # The generation of dftables can lead to timestamp problems with ccache | ||
35 | # because the generated config.h seems newer. It is sufficient to ensure that the | ||
36 | # attempt to build dftables inside make will actually work (foo_FOR_BUILD is | ||
37 | # only used for this). | ||
38 | oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib" | ||
39 | } | ||
40 | |||
41 | do_stage () { | ||
42 | autotools_stage_all | ||
43 | install -d ${STAGING_BINDIR_NATIVE} | ||
44 | install -m 0755 ${S}/dftables ${STAGING_BINDIR_NATIVE}/ | ||
45 | } | ||
46 | |||
47 | python populate_packages_prepend () { | ||
48 | pcre_libdir = bb.data.expand('${libdir}', d) | ||
49 | pcre_libdir_dbg = bb.data.expand('${libdir}/.debug', d) | ||
50 | do_split_packages(d, pcre_libdir, '^lib(.*)\.so$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev', allow_links=True) | ||
51 | do_split_packages(d, pcre_libdir, '^lib(.*)\.la$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev') | ||
52 | do_split_packages(d, pcre_libdir, '^lib(.*)\.a$', 'lib%s-dev', 'libpcre %s development package', extra_depends='${PN}-dev') | ||
53 | do_split_packages(d, pcre_libdir, '^lib(.*)\.so\.*', 'lib%s', 'libpcre %s library', extra_depends='', allow_links=True) | ||
54 | } | ||
55 | |||
56 | FILES_${PN} = "${libdir}/libpcre.so.*" | ||
57 | FILES_${PN}-dev += "${bindir}/*" | ||