summaryrefslogtreecommitdiffstats
path: root/meta-moblin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-10-05 21:15:39 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-10-05 21:15:39 +0100
commitb819bd9da17af415fb45936063e95fdf04a04def (patch)
treeafbb61dd12f2dacdaad56ca535d67137166a3347 /meta-moblin
parent5ce319a9b8e0e392cf534d7376df3bf1f85674ea (diff)
downloadpoky-b819bd9da17af415fb45936063e95fdf04a04def.tar.gz
libsexy: Add along with dependencies (aspell + enchant) from OE.dev
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin')
-rw-r--r--meta-moblin/packages/aspell/aspell_0.60.6.bb15
-rw-r--r--meta-moblin/packages/enchant/enchant_1.3.0.bb20
-rw-r--r--meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch15
-rw-r--r--meta-moblin/packages/libsexy/libsexy.inc13
-rw-r--r--meta-moblin/packages/libsexy/libsexy_0.1.11.bb2
5 files changed, 65 insertions, 0 deletions
diff --git a/meta-moblin/packages/aspell/aspell_0.60.6.bb b/meta-moblin/packages/aspell/aspell_0.60.6.bb
new file mode 100644
index 0000000000..de0cfa6aa6
--- /dev/null
+++ b/meta-moblin/packages/aspell/aspell_0.60.6.bb
@@ -0,0 +1,15 @@
1SRC_URI = "ftp://ftp.gnu.org/gnu/aspell/aspell-${PV}.tar.gz"
2DESCRIPTION = "GNU Aspell spell-checker"
3SECTION = "console/utils"
4LICENSE="LGPL"
5
6PACKAGES += "libaspell libpspell libpspell-dev aspell-utils"
7
8FILES_${PN}-dbg += "${libdir}/aspell-0.60/.debu*"
9FILES_libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
10FILES_aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
11FILES_${PN} = "${bindir}/aspell"
12FILES_libpspell = "${libdir}/libpspell.so.*"
13FILES_libpspell-dev = "${libdir}/libpspell* ${bindir}/pspell-config ${includedir}/pspell"
14
15inherit autotools_stage
diff --git a/meta-moblin/packages/enchant/enchant_1.3.0.bb b/meta-moblin/packages/enchant/enchant_1.3.0.bb
new file mode 100644
index 0000000000..e9e8a898cd
--- /dev/null
+++ b/meta-moblin/packages/enchant/enchant_1.3.0.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "Enchant Spell checker API Library"
2SECTION = "libs"
3LICENSE = "LGPL"
4DEPENDS = "aspell"
5RDEPENDS = "aspell"
6
7inherit autotools_stage pkgconfig
8
9PR = "r1"
10
11S = "${WORKDIR}/enchant-${PV}"
12
13SRC_URI = "http://www.abisource.com/downloads/enchant/${PV}/enchant-${PV}.tar.gz"
14
15EXTRA_OECONF = "--with-aspell-prefix=${STAGING_DIR_HOST}${prefix} --enable-aspell --disable-binreloc"
16
17FILES_${PN} = "${bindir} ${libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/*.so"
18FILES_${PN}-dev += "${libdir}/${PN}/*{SOLIBSDEV} ${libdir}/${PN}/*.la ${libdir}/${PN}/*.a"
19
20export CXXFLAGS += " -L${STAGING_LIBDIR} -lstdc++ "
diff --git a/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch
new file mode 100644
index 0000000000..61da9474df
--- /dev/null
+++ b/meta-moblin/packages/libsexy/files/libsexy-pkgconfig-fixes.patch
@@ -0,0 +1,15 @@
1Index: libsexy-0.1.11/libsexy.pc.in
2===================================================================
3--- libsexy-0.1.11.orig/libsexy.pc.in 2005-11-10 10:21:18.000000000 +0000
4+++ libsexy-0.1.11/libsexy.pc.in 2008-03-05 14:36:39.000000000 +0000
5@@ -6,7 +6,8 @@
6 Name: libsexy
7 Description: Doing naughty things to good widgets
8 Version: @VERSION@
9-Libs: -L${libdir} -lsexy @PACKAGE_LIBS@
10-Cflags: -I${includedir} @PACKAGE_CFLAGS@
11
12+Requires: pango glib-2.0 gtk+-2.0 libxml-2.0
13+Libs: -L${libdir} -lsexy
14+Cflags: -I${includedir}
15
diff --git a/meta-moblin/packages/libsexy/libsexy.inc b/meta-moblin/packages/libsexy/libsexy.inc
new file mode 100644
index 0000000000..473faf5e6e
--- /dev/null
+++ b/meta-moblin/packages/libsexy/libsexy.inc
@@ -0,0 +1,13 @@
1DESCRIPTION = "Libsexy is a collection of GTK+ widgets that extend the functionality of such standard widgets as GtkEntry and GtkLabel"
2HOMEPAGE = "http://wiki.chipx86.com/wiki/Libsexy"
3AUTHOR = "Christian Hammond <chipx86@chipx86.com>"
4SECTION = "x11/libs"
5
6DEPENDS = "gtk+ enchant libxml2"
7
8SRC_URI = "http://releases.chipx86.com/libsexy/${PN}/${PN}-${PV}.tar.gz \
9 file://libsexy-pkgconfig-fixes.patch;patch=1"
10
11inherit autotools_stage pkgconfig
12
13
diff --git a/meta-moblin/packages/libsexy/libsexy_0.1.11.bb b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb
new file mode 100644
index 0000000000..91784ffb49
--- /dev/null
+++ b/meta-moblin/packages/libsexy/libsexy_0.1.11.bb
@@ -0,0 +1,2 @@
1require libsexy.inc
2PR = "r1"