summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/xorg-xserver
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:15:49 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-12-30 17:15:49 +0000
commitc8a24cd00235a4ccb501e2cdea606730e166c572 (patch)
tree02d76961863352ce43bbee08c6779ed825f4e8fd /meta-moblin/packages/xorg-xserver
parent459a7f4a342bd9c74e2bc812cd1e6601a8095264 (diff)
downloadpoky-c8a24cd00235a4ccb501e2cdea606730e166c572.tar.gz
meta-moblin: Add initial menlow support
Diffstat (limited to 'meta-moblin/packages/xorg-xserver')
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc45
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch13
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch50
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch30
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf87
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb7
-rw-r--r--meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc37
7 files changed, 269 insertions, 0 deletions
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc b/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc
new file mode 100644
index 0000000000..d31e97a0e2
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-common.inc
@@ -0,0 +1,45 @@
1DESCRIPTION = "The X.Org X server"
2HOMEPAGE = "http://www.x.org"
3SECTION = "x11/base"
4LICENSE = "MIT-X"
5
6# xf86-*-* packages depend on an X server built with the xfree86 DDX
7# so we have a virtual to represent that:
8PROVIDES = "virtual/xserver-xf86"
9
10# Other packages tend to just care that there is *an* X server:
11PROVIDES += "virtual/xserver"
12
13XORG_PN = "xorg-server"
14SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
15 file://xorg.conf"
16
17S = "${WORKDIR}/${XORG_PN}-${PV}"
18
19inherit autotools pkgconfig
20
21PACKAGES =+ "${PN}-utils"
22
23FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
24FILES_${PN} = "${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/xorg/modules/*.so ${libdir}/xorg/modules/*/*.so ${libdir}/xorg/modules/*/*/*.so /etc/X11 "
25FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
26
27FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
28 ${libdir}/xorg/modules/*/.debug \
29 ${libdir}/xorg/modules/*/*/.debug \
30 "
31
32CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
33
34SRC_URI += "file://macro_tweak.patch;patch=1"
35
36do_stage() {
37 autotools_stage_all
38}
39
40do_install_append () {
41 install -d ${D}/${sysconfdir}/X11
42 install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
43 ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
44}
45
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch
new file mode 100644
index 0000000000..a62a767f23
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/drmfix.patch
@@ -0,0 +1,13 @@
1Index: xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am
2===================================================================
3--- xorg-server-1.4.orig/hw/xfree86/os-support/linux/Makefile.am 2007-08-23 21:04:53.000000000 +0200
4+++ xorg-server-1.4/hw/xfree86/os-support/linux/Makefile.am 2008-03-13 18:27:23.000000000 +0100
5@@ -41,7 +41,7 @@
6
7 AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(DIX_CFLAGS) $(XORG_CFLAGS) $(PLATFORM_DEFINES)
8
9-INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) -I/usr/include/drm # FIXME this last part is crack
10+INCLUDES = $(XORG_INCS) $(PLATFORM_INCLUDES) $(LIBDRM_CFLAGS)
11
12 # FIXME: These need to be added to the build
13 LNX_EXTRA_SRCS = \
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch
new file mode 100644
index 0000000000..db29da93ca
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/libdri-xinerama-symbol.patch
@@ -0,0 +1,50 @@
1Index: xorg-server-1.5.0/hw/xfree86/dri/dri.c
2===================================================================
3--- xorg-server-1.5.0.orig/hw/xfree86/dri/dri.c 2008-09-24 17:43:04.000000000 +0100
4+++ xorg-server-1.5.0/hw/xfree86/dri/dri.c 2008-09-24 17:46:38.000000000 +0100
5@@ -73,10 +73,6 @@
6
7 #define PCI_BUS_NO_DOMAIN(bus) ((bus) & 0xffu)
8
9-#if !defined(PANORAMIX)
10-extern Bool noPanoramiXExtension;
11-#endif
12-
13 static int DRIEntPrivIndex = -1;
14 static DevPrivateKey DRIScreenPrivKey = &DRIScreenPrivKey;
15 static DevPrivateKey DRIWindowPrivKey = &DRIWindowPrivKey;
16@@ -307,7 +303,6 @@
17 drm_context_t * reserved;
18 int reserved_count;
19 int i;
20- Bool xineramaInCore = FALSE;
21 DRIEntPrivPtr pDRIEntPriv;
22 ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
23 DRIContextFlags flags = 0;
24@@ -320,20 +315,13 @@
25 return FALSE;
26 }
27
28- /*
29- * If Xinerama is on, don't allow DRI to initialise. It won't be usable
30- * anyway.
31- */
32- if (xf86LoaderCheckSymbol("noPanoramiXExtension"))
33- xineramaInCore = TRUE;
34-
35- if (xineramaInCore) {
36- if (!noPanoramiXExtension) {
37- DRIDrvMsg(pScreen->myNum, X_WARNING,
38- "Direct rendering is not supported when Xinerama is enabled\n");
39- return FALSE;
40- }
41+#if defined(PANORAMIX)
42+ if (!noPanoramiXExtension) {
43+ DRIDrvMsg(pScreen->myNum, X_WARNING,
44+ "Direct rendering is not supported when Xinerama is enabled\n");
45+ return FALSE;
46 }
47+#endif
48
49 if (!DRIOpenDRMMaster(pScrn, pDRIInfo->SAREASize,
50 pDRIInfo->busIdString,
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch
new file mode 100644
index 0000000000..f2ba37fbb0
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/macro_tweak.patch
@@ -0,0 +1,30 @@
1Index: xorg-server-1.4/xorg-server.m4
2===================================================================
3--- xorg-server-1.4.orig/xorg-server.m4 2007-08-23 20:04:55.000000000 +0100
4+++ xorg-server-1.4/xorg-server.m4 2008-12-26 23:59:53.000000000 +0000
5@@ -28,9 +28,12 @@
6 # Checks for the $1 define in xorg-server.h (from the sdk). If it
7 # is defined, then add $1 to $REQUIRED_MODULES.
8
9+m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
10+
11 AC_DEFUN([XORG_DRIVER_CHECK_EXT],[
12+ PKG_PROG_PKG_CONFIG
13 SAVE_CFLAGS="$CFLAGS"
14- CFLAGS="$CFLAGS -I`pkg-config --variable=sdkdir xorg-server`"
15+ CFLAGS="$CFLAGS -I$PKG_CONFIG_SYSROOT_DIR`pkg-config --variable=sdkdir xorg-server`"
16 AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
17 #include "xorg-server.h"
18 #if !defined $1
19Index: xorg-server-1.4/xorg-server.pc.in
20===================================================================
21--- xorg-server-1.4.orig/xorg-server.pc.in 2008-12-27 00:07:37.000000000 +0000
22+++ xorg-server-1.4/xorg-server.pc.in 2008-12-27 00:08:39.000000000 +0000
23@@ -8,5 +8,6 @@
24 Name: xorg-server
25 Description: Modular X.Org X Server
26 Version: @PACKAGE_VERSION@
27-Cflags: -I${sdkdir} @PIXMAN_CFLAGS@
28+Requires: pixman-1
29+Cflags: -I${sdkdir}
30 Libs: -L${libdir}
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf
new file mode 100644
index 0000000000..6a9953cb65
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb/xorg.conf
@@ -0,0 +1,87 @@
1
2Section "Files"
3EndSection
4
5#Section "InputDevice"
6# Identifier "Generic Keyboard"
7# Driver "kbd"
8# Option "CoreKeyboard"
9# Option "XkbRules" "xorg"
10# Option "XkbModel" "pc105"
11# Option "XkbLayout" "us"
12#EndSection
13#
14#Section "InputDevice"
15# Identifier "Configured Mouse"
16# Driver "mouse"
17# Option "CorePointer"
18# Option "Device" "/dev/input/mice"
19# Option "Protocol" "ImPS/2"
20# Option "ZAxisMapping" "4 5"
21# Option "Emulate3Buttons" "true"
22#EndSection
23
24#Section "InputDevice"
25# Identifier "Synaptics Touchpad"
26# Driver "synaptics"
27# Option "SendCoreEvents" "true"
28# Option "Device" "/dev/psaux"
29# Option "Protocol" "auto-dev"
30# Option "HorizEdgeScroll" "0"
31#EndSection
32
33#Section "InputDevice"
34# Driver "wacom"
35# Identifier "stylus"
36# Option "Device" "/dev/input/wacom"
37# Option "Type" "stylus"
38# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
39#EndSection
40
41#Section "InputDevice"
42# Driver "wacom"
43# Identifier "eraser"
44# Option "Device" "/dev/input/wacom"
45# Option "Type" "eraser"
46# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
47#EndSection
48
49#Section "InputDevice"
50# Driver "wacom"
51# Identifier "cursor"
52# Option "Device" "/dev/input/wacom"
53# Option "Type" "cursor"
54# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
55#EndSection
56
57Section "Device"
58 Identifier "PSB Graphics Controller"
59 Driver "psb"
60# BusID "PCI:0:2:0"
61EndSection
62
63Section "Monitor"
64 Identifier "Generic Monitor"
65 Option "DPMS"
66EndSection
67
68Section "Screen"
69 Identifier "Default Screen"
70 Device "PSB Graphics Controller"
71 Monitor "Generic Monitor"
72 DefaultDepth 24
73EndSection
74
75Section "ServerLayout"
76 Identifier "Default Layout"
77 Screen "Default Screen"
78# InputDevice "Generic Keyboard"
79# InputDevice "Configured Mouse"
80
81# Uncomment if you have a wacom tablet
82# InputDevice "stylus" "SendCoreEvents"
83# InputDevice "cursor" "SendCoreEvents"
84# InputDevice "eraser" "SendCoreEvents"
85# InputDevice "Synaptics Touchpad"
86EndSection
87
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb
new file mode 100644
index 0000000000..f079a9fce9
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite-psb_1.4.bb
@@ -0,0 +1,7 @@
1require xserver-xf86-lite.inc
2
3PR = "r4"
4
5SRC_URI += "file://drmfix.patch;patch=1 \
6 file://libdri-xinerama-symbol.patch;patch=1 "
7
diff --git a/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc
new file mode 100644
index 0000000000..f0812215b9
--- /dev/null
+++ b/meta-moblin/packages/xorg-xserver/xserver-xf86-lite.inc
@@ -0,0 +1,37 @@
1require xserver-xf86-common.inc
2
3PROVIDES += "xserver-xf86-lite"
4
5PROTO_DEPS = "randrproto renderproto fixesproto damageproto xextproto xproto xf86dgaproto xf86miscproto xf86rushproto xf86vidmodeproto xf86bigfontproto compositeproto recordproto resourceproto videoproto scrnsaverproto evieext trapproto xineramaproto fontsproto kbproto inputproto bigreqsproto xcmiscproto glproto"
6
7LIB_DEPS = "mesa pixman libxfont xtrans libxau libxext libxdmcp libxt libdrm-psb libxkbfile libpciaccess openssl"
8
9DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
10
11RDEPENDS = "hal xorg-minimal-fonts"
12
13FILES_${PN} += "${bindir}/Xorg "
14
15EXTRA_OECONF += "--disable-acfb \
16 --enable-aiglx=yes \
17 --enable-dri=yes \
18 --enable-glx=yes \
19 --enable-glx-tls=yes \
20 --disable-ccfb \
21 --disable-mcfb \
22 --disable-dga \
23 --disable-xinerama \
24 --disable-xf86misc \
25 --disable-xorgcfg \
26 --disable-record \
27 --disable-dmx \
28 --disable-xnest \
29 --disable-xvfb \
30 --enable-composite \
31 --sysconfdir=/etc/X11 \
32 --localstatedir=/var \
33 --with-pic \
34 --with-int10=x86emu \
35 --with-fontdir=/usr/share/fonts/X11 \
36 --with-xkb-output=/var/lib/xkb \
37 ac_cv_file__usr_share_sgml_X11_defs_ent=no"