summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/mutter-moblin
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-19 18:06:20 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-19 18:06:20 +0100
commitcd60a7eb241e7e658cfa88043ca0049845ebdecd (patch)
tree66ea5034858475aed63a906c5184ac20d6b30781 /meta-moblin/packages/mutter-moblin
parent19e1d23dd1c46b11d929d8803f24121b7b8447d3 (diff)
downloadpoky-cd60a7eb241e7e658cfa88043ca0049845ebdecd.tar.gz
meta-moblin: Add recipes for most moblin beta components
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/mutter-moblin')
-rw-r--r--meta-moblin/packages/mutter-moblin/files/background-tile.pngbin0 -> 194031 bytes
-rw-r--r--meta-moblin/packages/mutter-moblin/files/startup-notify.patch51
-rw-r--r--meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb37
3 files changed, 88 insertions, 0 deletions
diff --git a/meta-moblin/packages/mutter-moblin/files/background-tile.png b/meta-moblin/packages/mutter-moblin/files/background-tile.png
new file mode 100644
index 0000000000..b71a55b679
--- /dev/null
+++ b/meta-moblin/packages/mutter-moblin/files/background-tile.png
Binary files differ
diff --git a/meta-moblin/packages/mutter-moblin/files/startup-notify.patch b/meta-moblin/packages/mutter-moblin/files/startup-notify.patch
new file mode 100644
index 0000000000..72ad42cd98
--- /dev/null
+++ b/meta-moblin/packages/mutter-moblin/files/startup-notify.patch
@@ -0,0 +1,51 @@
1Index: git/src/mnb-drop-down.c
2===================================================================
3--- git.orig/src/mnb-drop-down.c 2009-06-09 16:38:46.000000000 +0100
4+++ git/src/mnb-drop-down.c 2009-06-09 16:41:21.000000000 +0100
5@@ -68,6 +68,37 @@
6 gboolean hide_toolbar : 1;
7 };
8
9+
10+#include <dbus/dbus.h>
11+
12+static gboolean
13+emit_loaded_signal (gpointer user_data)
14+{
15+ DBusError error = DBUS_ERROR_INIT;
16+ DBusConnection *conn;
17+ DBusMessage *msg;
18+
19+ conn = dbus_bus_get (DBUS_BUS_SYSTEM, &error);
20+ if (!conn) {
21+ g_printerr ("Cannot connect to system bus: %s", error.message);
22+ dbus_error_free (&error);
23+ return FALSE;
24+ }
25+
26+ msg = dbus_message_new_signal ("/", "org.matchbox_project.desktop", "Loaded");
27+
28+ dbus_connection_send (conn, msg, NULL);
29+ dbus_message_unref (msg);
30+
31+ /* Flush explicitly because we're too lazy to integrate DBus into the main
32+ loop. We're only sending a signal, so if we got as far as here it's
33+ unlikely to block. */
34+ dbus_connection_flush (conn);
35+ dbus_connection_unref (conn);
36+
37+ return FALSE;
38+}
39+
40 static void
41 mnb_drop_down_get_property (GObject *object, guint property_id,
42 GValue *value, GParamSpec *pspec)
43@@ -137,6 +168,8 @@
44
45 g_signal_emit (actor, dropdown_signals[SHOW_COMPLETED], 0);
46 g_object_unref (actor);
47+
48+ g_idle_add (emit_loaded_signal, NULL);
49 }
50
51 static void
diff --git a/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
new file mode 100644
index 0000000000..37d5b2158b
--- /dev/null
+++ b/meta-moblin/packages/mutter-moblin/mutter-moblin_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "A Moblin specific plugin for the Mutter composite window manager"
2SECTION = "x11/wm"
3LICENSE = "GPLv3"
4DEPENDS = "nbtk mutter gnome-menus mojito libjana anerley clutter-mozembed"
5PV = "2.25.2+git${SRCPV}"
6PR = "r3"
7
8SRC_URI = "git://git.moblin.org/${PN}.git;protocol=git \
9 file://startup-notify.patch;patch=1 \
10 file://background-tile.png"
11
12FILES_${PN} += "${libdir}/metacity/plugins/clutter/*.so* ${datadir}/mutter-moblin-netbook-plugin"
13FILES_${PN}-dbg += "${libdir}/metacity/plugins/clutter/.debug/*"
14
15S = "${WORKDIR}/git"
16
17ASNEEDED = ""
18
19EXTRA_OECONF = "--enable-ahoghill --enable-netpanel --enable-people"
20
21inherit autotools_stage
22
23do_configure_prepend () {
24 rm -f ${S}/build/autotools/gtk-doc.m4
25 cp ${WORKDIR}/background-tile.png ${S}/data/theme/panel/
26}
27
28pkg_postinst_${PN} () {
29#!/bin/sh -e
30if [ "x$D" != "x" ]; then
31 exit 1
32fi
33
34. ${sysconfdir}/init.d/functions
35
36gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type list --list-type string --set /apps/metacity/general/clutter_plugins '[moblin-netbook]'
37}