diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-30 22:15:13 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-30 22:16:10 +0100 |
commit | c0c657bd92911788b96d9670620eabf024453752 (patch) | |
tree | 774a5e2d966d6ee87da17cd063580d5970564d00 /meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb | |
parent | e71a306f9cac8e30e689d607e2092e11a756ef5d (diff) | |
download | poky-c0c657bd92911788b96d9670620eabf024453752.tar.gz |
Split meta-extras and meta-moblin out of the main repository
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb')
-rw-r--r-- | meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb | 223 |
1 files changed, 0 insertions, 223 deletions
diff --git a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb b/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb deleted file mode 100644 index 2a5827642d..0000000000 --- a/meta-moblin/packages/matchbox-netbook-session/matchbox-session-netbook_0.1.bb +++ /dev/null | |||
@@ -1,223 +0,0 @@ | |||
1 | DESCRIPTION = "Custom MB session files for poky" | ||
2 | LICENSE = "GPL" | ||
3 | SECTION = "x11" | ||
4 | RDEPENDS = "formfactor gtk-engines initscripts matchbox-session" | ||
5 | PR = "r19" | ||
6 | |||
7 | # This package is architecture specific because the session script is modified | ||
8 | # based on the machine architecture. | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | SRC_URI = "file://session" | ||
12 | S = "${WORKDIR}" | ||
13 | |||
14 | do_install() { | ||
15 | install -d ${D}/${sysconfdir}/matchbox | ||
16 | install ${S}/session ${D}/${sysconfdir}/matchbox/session | ||
17 | chmod +x ${D}/${sysconfdir}/matchbox/session | ||
18 | } | ||
19 | |||
20 | pkg_postinst_${PN} () { | ||
21 | #!/bin/sh -e | ||
22 | if [ "x$D" != "x" ]; then | ||
23 | exit 1 | ||
24 | fi | ||
25 | |||
26 | . ${sysconfdir}/init.d/functions | ||
27 | |||
28 | |||
29 | # Theme | ||
30 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
31 | --direct --type string -s \ | ||
32 | /apps/metacity/general/theme "Moblin-Netbook" | ||
33 | |||
34 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
35 | --direct --type string -s \ | ||
36 | /apps/metacity/general/button_layout ":close" | ||
37 | |||
38 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
39 | --direct --type string -s \ | ||
40 | /desktop/gnome/interface/gtk_theme "Moblin-Netbook" | ||
41 | |||
42 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
43 | --direct --type string -s \ | ||
44 | /desktop/gnome/interface/icon_theme "moblin" | ||
45 | |||
46 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
47 | --direct --type string -s \ | ||
48 | /desktop/gnome/peripherals/mouse/cursor_theme "moblin" | ||
49 | |||
50 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
51 | --direct --type string -s \ | ||
52 | /desktop/gnome/interface/toolbar_style "icons" | ||
53 | |||
54 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
55 | --direct --type bool -s \ | ||
56 | /desktop/gnome/interface/menus_have_icons false | ||
57 | |||
58 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
59 | --direct --type bool -s \ | ||
60 | /desktop/gnome/interface/buttons_have_icons false | ||
61 | |||
62 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
63 | --direct --type string -s \ | ||
64 | /desktop/gnome/sound/theme_name moblin | ||
65 | |||
66 | # Screen shot | ||
67 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
68 | --direct --type string -s \ | ||
69 | /apps/metacity/global_keybindings/run_command_screenshot \ | ||
70 | "Print" | ||
71 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
72 | --direct --type string -s \ | ||
73 | /apps/metacity/keybinding_commands/command_screenshot \ | ||
74 | "gnome-screenshot" | ||
75 | |||
76 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
77 | --direct --type string -s \ | ||
78 | /apps/metacity/global_keybindings/run_command_window_screenshot \ | ||
79 | "<Alt>Print" | ||
80 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
81 | --direct --type string -s \ | ||
82 | /apps/metacity/keybinding_commands/command_window_screenshot \ | ||
83 | "gnome-screenshot --window" | ||
84 | |||
85 | # Window Actions | ||
86 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
87 | --direct --type string -s \ | ||
88 | /apps/metacity/general/action_double_click_titlebar "none" | ||
89 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
90 | --direct --type string -s \ | ||
91 | /apps/metacity/general/action_middle_click_titlebar "none" | ||
92 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
93 | --direct --type string -s \ | ||
94 | /apps/metacity/general/action_right_click_titlebar "none" | ||
95 | |||
96 | |||
97 | # UX Shell | ||
98 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
99 | --direct --type bool -s \ | ||
100 | /apps/mutter/general/clutter_disabled false | ||
101 | |||
102 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
103 | --direct --type list --list-type string -s \ | ||
104 | /apps/mutter/general/clutter_plugins '[moblin-netbook]' | ||
105 | |||
106 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
107 | --direct --type string -s \ | ||
108 | /desktop/gnome/url-handlers/http/command 'moblin-web-browser %s' | ||
109 | |||
110 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
111 | --direct --type string -s \ | ||
112 | /desktop/gnome/url-handlers/https/command 'moblin-web-browser %s' | ||
113 | |||
114 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
115 | --direct --type string -s \ | ||
116 | /desktop/gnome/background/picture_filename \ | ||
117 | '/usr/share/mutter-moblin/theme/moblin-panel-myzone/toys.jpg' | ||
118 | |||
119 | # Fonts | ||
120 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
121 | --direct --type string -s \ | ||
122 | /desktop/gnome/interface/document_font_name \ | ||
123 | 'Liberation Sans 10' | ||
124 | |||
125 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
126 | --direct --type string -s \ | ||
127 | /desktop/gnome/interface/font_name \ | ||
128 | 'Liberation Sans 10' | ||
129 | |||
130 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
131 | --direct --type string -s \ | ||
132 | /desktop/gnome/interface/monospace_font_name \ | ||
133 | 'Liberation Mono 10' | ||
134 | |||
135 | # Nautilus | ||
136 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
137 | --direct --type bool -s \ | ||
138 | /apps/nautilus/preferences/always_use_browser true | ||
139 | |||
140 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
141 | --direct --type bool -s \ | ||
142 | /apps/nautilus/preferences/exit_with_last_window false | ||
143 | |||
144 | # Do not automount, this is done by g-s-d plugin | ||
145 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
146 | --direct --type bool -s \ | ||
147 | /apps/nautilus/preferences/media_automount false | ||
148 | |||
149 | # And should not open new window whenever media mounted | ||
150 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
151 | --direct --type bool -s \ | ||
152 | /apps/nautilus/preferences/media_automount_open false | ||
153 | |||
154 | |||
155 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
156 | --direct --type bool -s \ | ||
157 | /apps/nautilus/icon_view/labels_beside_icons false | ||
158 | |||
159 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
160 | --direct --type string -s \ | ||
161 | /apps/nautilus/icon_view/default_zoom_level standard | ||
162 | |||
163 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
164 | --direct --type string -s \ | ||
165 | /apps/gnome_settings_daemon/keybindings/power "" | ||
166 | |||
167 | # General | ||
168 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
169 | --direct --type float -s \ | ||
170 | /desktop/gnome/peripherals/mouse/mouse_acceleration 0.8 | ||
171 | |||
172 | gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults \ | ||
173 | --direct --type int -s \ | ||
174 | /desktop/gnome/peripherals/mouse/mouse_threshold 2 | ||
175 | |||
176 | # | ||
177 | # The interesting bit - we convert to run the system as the user "pokyuser" | ||
178 | # and setup this user account as needed | ||
179 | # | ||
180 | if [ ! -d /home/pokyuser ]; then | ||
181 | adduser --disabled-password --ingroup users pokyuser | ||
182 | |||
183 | # Setup any .skel files | ||
184 | if [ -d ${sysconfdir}/skel ]; then | ||
185 | cp -pPR ${sysconfdir}/skel/.[a-zA-Z0-9]* /home/pokyuser/ || /bin/true | ||
186 | cp -pPR ${sysconfdir}/skel/* /home/pokyuser/ || /bin/true | ||
187 | fi | ||
188 | |||
189 | # Move any sample media into this user | ||
190 | if [ -d ${sysconfdir}/skel-media ]; then | ||
191 | mv ${sysconfdir}/skel-media/* /home/pokyuser/ || /bin/true | ||
192 | fi | ||
193 | |||
194 | chown pokyuser.users -R /home/pokyuser/* || /bin/true | ||
195 | chown pokyuser.users -R /home/pokyuser/.[a-zA-Z0-9]* || /bin/true | ||
196 | |||
197 | # Make sure Xorg is suid | ||
198 | chmod a+s /usr/bin/Xorg | ||
199 | |||
200 | # Tell X to run as this user | ||
201 | mkdir -p ${sysconfdir}/X11/ | ||
202 | echo "pokyuser" > ${sysconfdir}/X11/Xusername | ||
203 | |||
204 | # Add pokyuser to the audio group | ||
205 | audiousers=`grep ^audio < /etc/group | cut -d ':' -f 4` | ||
206 | if [ "x$audiousers" == "x" ]; then | ||
207 | audiousers=pokyuser | ||
208 | else | ||
209 | audiousers=$audiousers,pokyuser | ||
210 | fi | ||
211 | sed -i -e "s/audio:\(.*\):\(.*\):\(.*\)/audio:\1:\2:$audiousers/" /etc/group | ||
212 | |||
213 | # Add pokyuser to the video group | ||
214 | videousers=`grep ^video < /etc/group | cut -d ':' -f 4` | ||
215 | if [ "x$videousers" == "x" ]; then | ||
216 | videousers=pokyuser | ||
217 | else | ||
218 | videousers=$videousers,pokyuser | ||
219 | fi | ||
220 | sed -i -e "s/video:\(.*\):\(.*\):\(.*\)/video:\1:\2:$videousers/" /etc/group | ||
221 | fi | ||
222 | |||
223 | } | ||