summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/linux
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:11:28 +0100
committerSamuel Ortiz <sameo@linux.intel.com>2008-11-03 19:11:28 +0100
commit7b5d03d08e737dd3637072f60259af5b093b7f70 (patch)
treeaea48a813e03a41ea240443e2669a3a568505783 /meta-moblin/packages/linux
parentb2495018448fb016e91884ff2da8f79a6aec8ca7 (diff)
downloadpoky-7b5d03d08e737dd3637072f60259af5b093b7f70.tar.gz
linux-moblin: Add super readahead ext3 specific patch
We need this patch for sreadahead to generate the to be read file list.
Diffstat (limited to 'meta-moblin/packages/linux')
-rw-r--r--meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch65
-rw-r--r--meta-moblin/packages/linux/linux-moblin_2.6.27.bb3
2 files changed, 67 insertions, 1 deletions
diff --git a/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch b/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch
new file mode 100644
index 0000000000..101c100dd0
--- /dev/null
+++ b/meta-moblin/packages/linux/linux-moblin-2.6.27/0043-superreadahead-patch.patch
@@ -0,0 +1,65 @@
1From: Arjan van de Ven <arjan@linux.intel.com>
2Date: Sun, 21 Sep 2008 11:58:27 -0700
3Subject: [PATCH] superreadahead patch
4
5---
6 fs/ext3/ioctl.c | 3 +++
7 fs/ext3/super.c | 1 +
8 include/linux/ext3_fs.h | 1 +
9 include/linux/fs.h | 2 ++
10 4 files changed, 7 insertions(+), 0 deletions(-)
11
12diff --git a/fs/ext3/ioctl.c b/fs/ext3/ioctl.c
13index 0d0c701..7e62d7d 100644
14--- a/fs/ext3/ioctl.c
15+++ b/fs/ext3/ioctl.c
16@@ -286,6 +286,9 @@ group_add_out:
17 mnt_drop_write(filp->f_path.mnt);
18 return err;
19 }
20+ case EXT3_IOC_INODE_JIFFIES: {
21+ return inode->created_when;
22+ }
23
24
25 default:
26diff --git a/fs/ext3/super.c b/fs/ext3/super.c
27index 2845425..6a896a4 100644
28--- a/fs/ext3/super.c
29+++ b/fs/ext3/super.c
30@@ -456,6 +456,7 @@ static struct inode *ext3_alloc_inode(struct super_block *sb)
31 #endif
32 ei->i_block_alloc_info = NULL;
33 ei->vfs_inode.i_version = 1;
34+ ei->vfs_inode.created_when = jiffies;
35 return &ei->vfs_inode;
36 }
37
38diff --git a/include/linux/ext3_fs.h b/include/linux/ext3_fs.h
39index 36c5403..b409fa7 100644
40--- a/include/linux/ext3_fs.h
41+++ b/include/linux/ext3_fs.h
42@@ -225,6 +225,7 @@ struct ext3_new_group_data {
43 #endif
44 #define EXT3_IOC_GETRSVSZ _IOR('f', 5, long)
45 #define EXT3_IOC_SETRSVSZ _IOW('f', 6, long)
46+#define EXT3_IOC_INODE_JIFFIES _IOR('f', 19, long)
47
48 /*
49 * ioctl commands in 32 bit emulation
50diff --git a/include/linux/fs.h b/include/linux/fs.h
51index c6455da..4ac846d 100644
52--- a/include/linux/fs.h
53+++ b/include/linux/fs.h
54@@ -655,6 +655,8 @@ struct inode {
55 void *i_security;
56 #endif
57 void *i_private; /* fs or device private pointer */
58+
59+ unsigned long created_when; /* jiffies of creation time */
60 };
61
62 /*
63--
641.5.5.1
65
diff --git a/meta-moblin/packages/linux/linux-moblin_2.6.27.bb b/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
index fe26cc555a..b3d990aaa7 100644
--- a/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
+++ b/meta-moblin/packages/linux/linux-moblin_2.6.27.bb
@@ -1,6 +1,6 @@
1require linux-moblin.inc 1require linux-moblin.inc
2 2
3PR = "r2" 3PR = "r3"
4PE = "1" 4PE = "1"
5 5
6DEFAULT_PREFERENCE = "-1" 6DEFAULT_PREFERENCE = "-1"
@@ -49,6 +49,7 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.27.tar.bz2 \
49 file://0040-fastboot-fix-issues-and-improve-output-of-bootgraph.patch;patch=1 \ 49 file://0040-fastboot-fix-issues-and-improve-output-of-bootgraph.patch;patch=1 \
50 file://0041-r8169-8101e.patch;patch=1 \ 50 file://0041-r8169-8101e.patch;patch=1 \
51 file://0042-intelfb-945gme.patch;patch=1 \ 51 file://0042-intelfb-945gme.patch;patch=1 \
52 file://0043-superreadahead-patch.patch;patch=1 \
52 file://defconfig-netbook" 53 file://defconfig-netbook"
53 54
54S = "${WORKDIR}/linux-2.6.27" 55S = "${WORKDIR}/linux-2.6.27"