summaryrefslogtreecommitdiffstats
path: root/meta-moblin/packages/images
diff options
context:
space:
mode:
authorSamuel Ortiz <sameo@linux.intel.com>2008-10-21 16:01:02 +0200
committerSamuel Ortiz <sameo@openedhand.com>2008-10-21 16:01:02 +0200
commite5c53ce035eb36fc1b416e9971582a45754844be (patch)
tree4d14d39f2e5f5c4a371a17563155b3f6bd2f0e93 /meta-moblin/packages/images
parent3e045793c740cbac302c2077cc839f1a64c03bc2 (diff)
downloadpoky-e5c53ce035eb36fc1b416e9971582a45754844be.tar.gz
netbook: changed platform name from eee901 to netbook
We want to have a more generic platform definition. The netbook machine one currently supports the eee901 and the aspire one. We also moved the machine and netbook image definitions to meta-moblin.
Diffstat (limited to 'meta-moblin/packages/images')
-rw-r--r--meta-moblin/packages/images/poky-image-live.bb9
-rw-r--r--meta-moblin/packages/images/poky-image-live.inc18
-rw-r--r--meta-moblin/packages/images/poky-image-minimal-initramfs.bb8
-rw-r--r--meta-moblin/packages/images/poky-image-minimal-live.bb9
-rw-r--r--meta-moblin/packages/images/poky-image-netbook.bb7
-rw-r--r--meta-moblin/packages/images/poky-image-sato-live.bb9
6 files changed, 60 insertions, 0 deletions
diff --git a/meta-moblin/packages/images/poky-image-live.bb b/meta-moblin/packages/images/poky-image-live.bb
new file mode 100644
index 0000000000..a3bfbfc71f
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-live.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "Netbook Bootable Live Image"
2
3require poky-image-live.inc
4
5LABELS += "boot install"
6
7ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-netbook-${MACHINE}.ext3"
8
9do_bootimg[depends] += "poky-image-netbook:do_rootfs"
diff --git a/meta-moblin/packages/images/poky-image-live.inc b/meta-moblin/packages/images/poky-image-live.inc
new file mode 100644
index 0000000000..7f8dd8fba5
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-live.inc
@@ -0,0 +1,18 @@
1AUTO_SYSLINUXCFG = "1"
2INITRD = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-initramfs-${MACHINE}.cpio.gz"
3APPEND += "root=/dev/ram0 "
4TIMEOUT = "10"
5
6EXCLUDE_FROM_WORLD = "1"
7
8do_bootimg[depends] += "poky-image-minimal-initramfs:do_rootfs"
9
10inherit bootimg
11
12do_bootimg_prepend () {
13 import bb
14 fstypes = bb.data.getVar('IMAGE_FSTYPES', d, True)
15 if 'ext3' not in fstypes:
16 bb.msg.fatal(bb.msg.domain.Build, "ext3 not in IMAGE_FSTYPES")
17}
18
diff --git a/meta-moblin/packages/images/poky-image-minimal-initramfs.bb b/meta-moblin/packages/images/poky-image-minimal-initramfs.bb
new file mode 100644
index 0000000000..b2824a7d61
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-minimal-initramfs.bb
@@ -0,0 +1,8 @@
1# Simple initramfs image. Mostly used for live images.
2
3IMAGE_INSTALL = "initramfs-live-boot initramfs-live-install busybox udev"
4
5export IMAGE_BASENAME = "poky-image-minimal-initramfs"
6IMAGE_LINGUAS = ""
7
8inherit poky-image
diff --git a/meta-moblin/packages/images/poky-image-minimal-live.bb b/meta-moblin/packages/images/poky-image-minimal-live.bb
new file mode 100644
index 0000000000..7d9aa5f154
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-minimal-live.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "Minimal Bootable Live Image"
2
3require poky-image-live.inc
4
5LABELS += "boot install"
6
7ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-minimal-${MACHINE}.ext3"
8
9do_bootimg[depends] += "poky-image-minimal:do_rootfs"
diff --git a/meta-moblin/packages/images/poky-image-netbook.bb b/meta-moblin/packages/images/poky-image-netbook.bb
new file mode 100644
index 0000000000..8138e9d598
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-netbook.bb
@@ -0,0 +1,7 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5IMAGE_FEATURES += "apps-console-core ${NETBOOK_IMAGE_FEATURES}"
6
7inherit poky-image
diff --git a/meta-moblin/packages/images/poky-image-sato-live.bb b/meta-moblin/packages/images/poky-image-sato-live.bb
new file mode 100644
index 0000000000..9b686e812c
--- /dev/null
+++ b/meta-moblin/packages/images/poky-image-sato-live.bb
@@ -0,0 +1,9 @@
1DESCRIPTION = "Sato Bootable Live Image"
2
3require poky-image-live.inc
4
5LABELS += "boot install"
6
7ROOTFS = "${DEPLOY_DIR_IMAGE}/poky-image-sato-${MACHINE}.ext3"
8
9do_bootimg[depends] += "poky-image-sato:do_rootfs"