diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-02-04 12:41:16 +0000 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-02-04 12:41:16 +0000 |
commit | fa2470c84637f3e50d76a333a6cb1fdf60617944 (patch) | |
tree | 9930700719ab0197f14878deec553477fd60c178 /meta-moblin/packages/hornsey/Makefile.am | |
parent | 99e23d64fcc3ed8aaf88719cf970844de8954852 (diff) | |
download | poky-fa2470c84637f3e50d76a333a6cb1fdf60617944.tar.gz |
clutter-gst/clutter-gtk: Add API versions to the package names and update to the latest code
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-moblin/packages/hornsey/Makefile.am')
-rw-r--r-- | meta-moblin/packages/hornsey/Makefile.am | 662 |
1 files changed, 662 insertions, 0 deletions
diff --git a/meta-moblin/packages/hornsey/Makefile.am b/meta-moblin/packages/hornsey/Makefile.am new file mode 100644 index 0000000000..bce92c4060 --- /dev/null +++ b/meta-moblin/packages/hornsey/Makefile.am | |||
@@ -0,0 +1,662 @@ | |||
1 | ## Process this file with automake to create Makefile.in. | ||
2 | |||
3 | # We set GPATH here; this gives us semantics for GNU make | ||
4 | # which are more like other make's VPATH. | ||
5 | GPATH = $(srcdir) | ||
6 | |||
7 | if HAVE_FREETYPE | ||
8 | OPENTYPE_SUBDIR=opentype | ||
9 | endif | ||
10 | |||
11 | EXTRA_DIST = | ||
12 | BUILT_GIRSOURCES = | ||
13 | |||
14 | FRIBIDI_SUBDIR=mini-fribidi | ||
15 | |||
16 | SUBDIRS = $(OPENTYPE_SUBDIR) $(FRIBIDI_SUBDIR) | ||
17 | |||
18 | DIST_SUBDIRS = mini-fribidi opentype | ||
19 | |||
20 | INCLUDES = \ | ||
21 | -DG_LOG_DOMAIN=\"Pango\" \ | ||
22 | -DPANGO_ENABLE_BACKEND \ | ||
23 | -DPANGO_ENABLE_ENGINE \ | ||
24 | -DSYSCONFDIR=\"$(sysconfdir)\" \ | ||
25 | -DLIBDIR=\"$(libdir)\" \ | ||
26 | -I$(top_srcdir) \ | ||
27 | $(PANGO_DEBUG_FLAGS) \ | ||
28 | $(GLIB_CFLAGS) \ | ||
29 | $(XFT_CFLAGS) \ | ||
30 | $(CAIRO_CFLAGS) \ | ||
31 | $(FREETYPE_CFLAGS) \ | ||
32 | $(X_CFLAGS) | ||
33 | |||
34 | BUILT_SOURCES = pango-enum-types.h pango-enum-types.c pango-features.h | ||
35 | |||
36 | pangoincludedir=$(includedir)/pango-1.0/pango | ||
37 | |||
38 | if OS_WIN32 | ||
39 | else | ||
40 | libm = -lm | ||
41 | endif | ||
42 | |||
43 | # ------------------- libpango ------------------- | ||
44 | |||
45 | lib_LTLIBRARIES = libpango-1.0.la | ||
46 | BUILT_GIRSOURCES += Pango-1.0.gir | ||
47 | |||
48 | libpango_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
49 | libpango_1_0_la_LIBADD = \ | ||
50 | $(GLIB_LIBS) \ | ||
51 | $(libm) \ | ||
52 | $(INCLUDED_LANG_MODULES) | ||
53 | libpango_1_0_la_DEPENDENCIES = \ | ||
54 | $(INCLUDED_LANG_MODULES) | ||
55 | |||
56 | libpango_1_0_la_LIBADD += mini-fribidi/libmini-fribidi.la | ||
57 | libpango_1_0_la_DEPENDENCIES += mini-fribidi/libmini-fribidi.la | ||
58 | |||
59 | if PLATFORM_WIN32 | ||
60 | libpango_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pango.def -Wl,pango-win32-res.o | ||
61 | libpango_1_0_la_DEPENDENCIES += pango-win32-res.o pango.def | ||
62 | endif | ||
63 | pango-win32-res.o: pango.rc | ||
64 | $(AM_V_GEN) $(WINDRES) $< $@ | ||
65 | |||
66 | libpango_1_0_la_SOURCES = \ | ||
67 | break.c \ | ||
68 | ellipsize.c \ | ||
69 | fonts.c \ | ||
70 | glyphstring.c \ | ||
71 | modules.c \ | ||
72 | pango-attributes.c \ | ||
73 | pango-bidi-type.c \ | ||
74 | pango-color.c \ | ||
75 | pango-color-table.h \ | ||
76 | pango-context.c \ | ||
77 | pango-coverage.c \ | ||
78 | pango-engine.c \ | ||
79 | pango-engine-private.h \ | ||
80 | pango-fontmap.c \ | ||
81 | pango-fontset.c \ | ||
82 | pango-glyph-item.c \ | ||
83 | pango-gravity.c \ | ||
84 | pango-impl-utils.h \ | ||
85 | pango-item.c \ | ||
86 | pango-language.c \ | ||
87 | pango-language-sample-table.h \ | ||
88 | pango-layout.c \ | ||
89 | pango-layout-private.h \ | ||
90 | pango-markup.c \ | ||
91 | pango-matrix.c \ | ||
92 | pango-renderer.c \ | ||
93 | pango-script.c \ | ||
94 | pango-script-lang-table.h \ | ||
95 | pango-script-private.h \ | ||
96 | pango-tabs.c \ | ||
97 | pango-utils.c \ | ||
98 | reorder-items.c \ | ||
99 | shape.c \ | ||
100 | pango-enum-types.c \ | ||
101 | module-defs-lang.c | ||
102 | |||
103 | pango_headers = \ | ||
104 | pango.h \ | ||
105 | pango-attributes.h \ | ||
106 | pango-bidi-type.h \ | ||
107 | pango-break.h \ | ||
108 | pango-context.h \ | ||
109 | pango-coverage.h \ | ||
110 | pango-engine.h \ | ||
111 | pango-font.h \ | ||
112 | pango-fontmap.h \ | ||
113 | pango-fontset.h \ | ||
114 | pango-glyph.h \ | ||
115 | pango-glyph-item.h \ | ||
116 | pango-gravity.h \ | ||
117 | pango-item.h \ | ||
118 | pango-language.h \ | ||
119 | pango-layout.h \ | ||
120 | pango-matrix.h \ | ||
121 | pango-modules.h \ | ||
122 | pango-renderer.h \ | ||
123 | pango-script.h \ | ||
124 | pango-tabs.h \ | ||
125 | pango-types.h \ | ||
126 | pango-utils.h | ||
127 | |||
128 | pangoinclude_HEADERS = \ | ||
129 | $(pango_headers) \ | ||
130 | pango-features.h \ | ||
131 | pango-enum-types.h | ||
132 | |||
133 | pango-enum-types.h: s-enum-types-h | ||
134 | $(AM_V_GEN) true | ||
135 | s-enum-types-h: @REBUILD@ $(pango_headers) Makefile | ||
136 | $(AM_V_GEN) ( cd $(srcdir) && glib-mkenums \ | ||
137 | --fhead "#ifndef __PANGO_ENUM_TYPES_H__\n#define __PANGO_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \ | ||
138 | --fprod "/* enumerations from \"@filename@\" */\n" \ | ||
139 | --vhead "GType @enum_name@_get_type (void);\n#define @ENUMPREFIX@_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n" \ | ||
140 | --ftail "G_END_DECLS\n\n#endif /* __PANGO_ENUM_TYPES_H__ */" \ | ||
141 | $(pango_headers) ) > tmp-pango-enum-types.h \ | ||
142 | && (cmp -s tmp-pango-enum-types.h pango-enum-types.h || cp tmp-pango-enum-types.h pango-enum-types.h ) \ | ||
143 | && rm -f tmp-pango-enum-types.h \ | ||
144 | && echo timestamp > $(@F) | ||
145 | |||
146 | pango-enum-types.c: s-enum-types-c | ||
147 | $(AM_V_GEN) true | ||
148 | s-enum-types-c: @REBUILD@ $(pango_headers) Makefile | ||
149 | $(AM_V_GEN) ( cd $(srcdir) && glib-mkenums \ | ||
150 | --fhead "#include <pango.h>" \ | ||
151 | --fprod "\n/* enumerations from \"@filename@\" */" \ | ||
152 | --vhead "GType\n@enum_name@_get_type (void)\n{\n static GType etype = 0;\n if (etype == 0) {\n static const G@Type@Value values[] = {" \ | ||
153 | --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \ | ||
154 | --vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (g_intern_static_string (\"@EnumName@\"), values);\n }\n return etype;\n}\n" \ | ||
155 | $(pango_headers) ) > tmp-pango-enum-types.c \ | ||
156 | && (cmp -s tmp-pango-enum-types.c pango-enum-types.c || cp tmp-pango-enum-types.c pango-enum-types.c ) \ | ||
157 | && rm -f tmp-pango-enum-types.c \ | ||
158 | && echo timestamp > $(@F) | ||
159 | |||
160 | pango-features.h: | ||
161 | $(AM_V_GEN) cd $(top_builddir) && ./config.status pango/pango-features.h | ||
162 | |||
163 | Pango-1.0.gir: $(libpango_1_0_la_SOURCES) | ||
164 | Pango-1.0.gir: $(pango_headers) | ||
165 | Pango-1.0.gir: libpango-1.0.la | ||
166 | Pango-1.0.gir: $(G_IR_SCANNER) Makefile | ||
167 | $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace Pango --nsversion=1.0 \ | ||
168 | --add-include-path=$(srcdir) --add-include-path=. \ | ||
169 | --include=GObject-2.0 \ | ||
170 | --include=cairo-1.0 \ | ||
171 | --library=libpango-1.0.la \ | ||
172 | --libtool="$(LIBTOOL)" \ | ||
173 | --output $@ \ | ||
174 | --pkg gobject-2.0 \ | ||
175 | --pkg cairo \ | ||
176 | --pkg freetype2 \ | ||
177 | -I$(top_srcdir) \ | ||
178 | $(PANGO_CFLAGS) \ | ||
179 | $(libpango_1_0_la_SOURCES) \ | ||
180 | $(pango_headers) \ | ||
181 | pango-enum-types.h | ||
182 | |||
183 | # ------------------- libpangox ------------------- | ||
184 | |||
185 | if HAVE_X | ||
186 | pangoinclude_HEADERS += $(pangox_headers) | ||
187 | lib_LTLIBRARIES += libpangox-1.0.la | ||
188 | aliasdir = $(sysconfdir)/pango | ||
189 | alias_DATA = pangox.aliases | ||
190 | endif | ||
191 | |||
192 | pangox_headers = pangox.h | ||
193 | pangox_public_sources = pangox.c | ||
194 | |||
195 | libpangox_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
196 | libpangox_1_0_la_LIBADD = \ | ||
197 | libpango-$(PANGO_API_VERSION).la \ | ||
198 | $(INCLUDED_X_MODULES) \ | ||
199 | $(GLIB_LIBS) \ | ||
200 | $(X_LIBS) \ | ||
201 | $(X_EXTRA_LIBS) | ||
202 | libpangox_1_0_la_DEPENDENCIES = \ | ||
203 | libpango-$(PANGO_API_VERSION).la \ | ||
204 | $(INCLUDED_X_MODULES) | ||
205 | |||
206 | if PLATFORM_WIN32 | ||
207 | libpangox_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pangox.def -Wl,pangox-win32-res.o | ||
208 | libpangox_1_0_la_DEPENDENCIES += pangox-win32-res.o pangox.def | ||
209 | endif | ||
210 | |||
211 | pangox-win32-res.o: pangox.rc | ||
212 | $(WINDRES) $< $@ | ||
213 | |||
214 | libpangox_1_0_la_SOURCES = \ | ||
215 | $(pangox_public_sources) \ | ||
216 | modules.h \ | ||
217 | module-defs-x.c \ | ||
218 | pangox-private.h \ | ||
219 | pangox-fontcache.c \ | ||
220 | pangox-fontmap.c | ||
221 | |||
222 | # ------------------- libpangoft2 ------------------- | ||
223 | |||
224 | if HAVE_FREETYPE | ||
225 | pangoinclude_HEADERS += $(pangoft2_headers) | ||
226 | lib_LTLIBRARIES += libpangoft2-1.0.la | ||
227 | BUILT_GIRSOURCES += PangoFT2-1.0.gir | ||
228 | endif | ||
229 | |||
230 | pangoft2_headers = \ | ||
231 | pango-ot.h \ | ||
232 | pangofc-font.h \ | ||
233 | pangofc-fontmap.h \ | ||
234 | pangofc-decoder.h \ | ||
235 | pangoft2.h | ||
236 | |||
237 | pangoft2_public_sources = \ | ||
238 | pangofc-font.c \ | ||
239 | pangofc-fontmap.c \ | ||
240 | pangofc-decoder.c \ | ||
241 | pangoft2.c | ||
242 | |||
243 | libpangoft2_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
244 | libpangoft2_1_0_la_LIBADD = \ | ||
245 | opentype/libharfbuzz.la \ | ||
246 | libpango-$(PANGO_API_VERSION).la \ | ||
247 | $(INCLUDED_FC_MODULES) \ | ||
248 | $(GLIB_LIBS) \ | ||
249 | $(FREETYPE_LIBS) \ | ||
250 | $(libm) | ||
251 | libpangoft2_1_0_la_DEPENDENCIES = \ | ||
252 | opentype/libharfbuzz.la \ | ||
253 | libpango-$(PANGO_API_VERSION).la \ | ||
254 | $(INCLUDED_FC_MODULES) | ||
255 | libpangoft2_1_0_la_SOURCES = \ | ||
256 | $(pangoft2_public_sources) \ | ||
257 | modules.h \ | ||
258 | module-defs-fc.c \ | ||
259 | pangofc-private.h \ | ||
260 | pangoft2.h \ | ||
261 | pangoft2-private.h \ | ||
262 | pangoft2-fontmap.c \ | ||
263 | pangoft2-render.c \ | ||
264 | pango-ot-private.h \ | ||
265 | pango-ot-buffer.c \ | ||
266 | pango-ot-info.c \ | ||
267 | pango-ot-ruleset.c \ | ||
268 | pango-ot-tag.c | ||
269 | |||
270 | |||
271 | if PLATFORM_WIN32 | ||
272 | libpangoft2_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pangoft2.def -Wl,pangoft2-win32-res.o | ||
273 | libpangoft2_1_0_la_DEPENDENCIES += pangoft2-win32-res.o pangoft2.def | ||
274 | endif | ||
275 | pangoft2-win32-res.o: pangoft2.rc | ||
276 | $(AM_V_GEN) $(WINDRES) $< $@ | ||
277 | |||
278 | PangoFT2-1.0.gir: $(pangoft2_headers) | ||
279 | PangoFT2-1.0.gir: $(libpangoft2_1_0_la_SOURCES) | ||
280 | PangoFT2-1.0.gir: libpangoft2-1.0.la | ||
281 | PangoFT2-1.0.gir: Pango-1.0.gir $(G_IR_SCANNER) Makefile | ||
282 | $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoFT2 --nsversion=1.0 \ | ||
283 | --add-include-path=$(srcdir) --add-include-path=. \ | ||
284 | --include=GObject-2.0 \ | ||
285 | --include=Pango-1.0 \ | ||
286 | --include=freetype2-2.0 \ | ||
287 | --include=fontconfig-2.0 \ | ||
288 | --library=libpangoft2-1.0.la \ | ||
289 | --libtool="$(LIBTOOL)" \ | ||
290 | --output $@ \ | ||
291 | --pkg gobject-2.0 \ | ||
292 | --pkg freetype2 \ | ||
293 | --pkg pangoft2 \ | ||
294 | -I$(top_srcdir) \ | ||
295 | $(pangoft2_headers) \ | ||
296 | $(pangoft2_public_sources) | ||
297 | |||
298 | # ------------------- libpangoxft ------------------- | ||
299 | |||
300 | if HAVE_XFT | ||
301 | pangoinclude_HEADERS += $(pangoxft_headers) | ||
302 | lib_LTLIBRARIES += libpangoxft-1.0.la | ||
303 | BUILT_GIRSOURCES += PangoXft-1.0.gir | ||
304 | endif | ||
305 | |||
306 | pangoxft_headers = pangoxft.h pangoxft-render.h | ||
307 | |||
308 | libpangoxft_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
309 | libpangoxft_1_0_la_LIBADD = \ | ||
310 | libpangoft2-$(PANGO_API_VERSION).la \ | ||
311 | libpango-$(PANGO_API_VERSION).la \ | ||
312 | $(GLIB_LIBS) \ | ||
313 | $(X_LIBS) \ | ||
314 | $(XFT_LIBS) \ | ||
315 | $(FREETYPE_LIBS) \ | ||
316 | $(libm) | ||
317 | libpangoxft_1_0_la_DEPENDENCIES = \ | ||
318 | libpangoft2-$(PANGO_API_VERSION).la \ | ||
319 | libpango-$(PANGO_API_VERSION).la | ||
320 | |||
321 | if PLATFORM_WIN32 | ||
322 | libpangoxft_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pangoxft.def -Wl,pangoxft-win32-res.o | ||
323 | libpangoxft_1_0_la_DEPENDENCIES += pangoxft-win32-res.o pangoxft.def | ||
324 | endif | ||
325 | pangoxft-win32-res.o: pangoxft.rc | ||
326 | $(AM_V_GEN) $(WINDRES) $< $@ | ||
327 | |||
328 | libpangoxft_1_0_la_SOURCES = \ | ||
329 | pangoxft-font.c \ | ||
330 | pangoxft-fontmap.c \ | ||
331 | pangoxft-private.h \ | ||
332 | pangoxft-render.c | ||
333 | |||
334 | |||
335 | PangoXft-1.0.gir: $(pangoxft_headers) | ||
336 | PangoXft-1.0.gir: $(libpangoxft_1_0_la_SOURCES) | ||
337 | PangoXft-1.0.gir: libpangoxft-1.0.la | ||
338 | PangoXft-1.0.gir: Pango-1.0.gir PangoFT2-1.0.gir $(G_IR_SCANNER) Makefile | ||
339 | $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoXft --nsversion=1.0 \ | ||
340 | --add-include-path=$(srcdir) --add-include-path=. \ | ||
341 | --include=GObject-2.0 \ | ||
342 | --include=xft-2.0 \ | ||
343 | --include=xlib-2.0 \ | ||
344 | --include=PangoFT2-1.0 \ | ||
345 | --library=libpangoxft-1.0.la \ | ||
346 | --libtool="$(LIBTOOL)" \ | ||
347 | --output $@ \ | ||
348 | --pkg gobject-2.0 \ | ||
349 | --pkg freetype2 \ | ||
350 | -I$(top_srcdir) \ | ||
351 | $(PANGO_CFLAGS) \ | ||
352 | $(pangoxft_headers) \ | ||
353 | $(libpangoxft_1_0_la_SOURCES) | ||
354 | |||
355 | # ------------------- libpangocairo ------------------- | ||
356 | |||
357 | if HAVE_CAIRO | ||
358 | pangoinclude_HEADERS += $(pangocairo_headers) | ||
359 | lib_LTLIBRARIES += libpangocairo-1.0.la | ||
360 | BUILT_GIRSOURCES += PangoCairo-1.0.gir | ||
361 | endif | ||
362 | |||
363 | pangocairo_headers = pangocairo.h | ||
364 | |||
365 | libpangocairo_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
366 | libpangocairo_1_0_la_LIBADD = \ | ||
367 | libpango-$(PANGO_API_VERSION).la \ | ||
368 | $(GLIB_LIBS) \ | ||
369 | $(CAIRO_LIBS) \ | ||
370 | $(libm) | ||
371 | libpangocairo_1_0_la_DEPENDENCIES = \ | ||
372 | libpango-$(PANGO_API_VERSION).la | ||
373 | libpangocairo_1_0_la_SOURCES = \ | ||
374 | pangocairo-context.c \ | ||
375 | pangocairo-font.c \ | ||
376 | pangocairo-fontmap.c \ | ||
377 | pangocairo-render.c \ | ||
378 | pangocairo-private.h | ||
379 | |||
380 | if HAVE_CAIRO_WIN32 | ||
381 | if PLATFORM_WIN32 | ||
382 | libpangocairo_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pangocairo.def | ||
383 | libpangocairo_1_0_la_DEPENDENCIES += pangocairo.def | ||
384 | endif | ||
385 | |||
386 | libpangocairo_1_0_la_LIBADD += libpangowin32-$(PANGO_API_VERSION).la $(WIN32_LIBS) | ||
387 | libpangocairo_1_0_la_DEPENDENCIES += libpangowin32-$(PANGO_API_VERSION).la | ||
388 | |||
389 | libpangocairo_1_0_la_SOURCES += pangocairo-win32font.c pangocairo-win32fontmap.c pangocairo-win32.h | ||
390 | endif | ||
391 | |||
392 | if HAVE_CAIRO_FREETYPE | ||
393 | libpangocairo_1_0_la_LIBADD += libpangoft2-$(PANGO_API_VERSION).la $(FREETYPE_LIBS) | ||
394 | libpangocairo_1_0_la_DEPENDENCIES += libpangoft2-$(PANGO_API_VERSION).la | ||
395 | PANGOCAIRO_FONT_BACKEND_GI_MODULE = PangoFT2-1.0 | ||
396 | |||
397 | libpangocairo_1_0_la_SOURCES += \ | ||
398 | pangocairo-fcfont.c \ | ||
399 | pangocairo-fcfontmap.c \ | ||
400 | pangocairo-fc.h | ||
401 | endif | ||
402 | |||
403 | if HAVE_CAIRO_ATSUI | ||
404 | libpangocairo_1_0_la_SOURCES += \ | ||
405 | modules.h \ | ||
406 | module-defs-atsui.c \ | ||
407 | pangoatsui.h \ | ||
408 | pangoatsui.c \ | ||
409 | pangoatsui-private.h \ | ||
410 | pangoatsui-fontmap.c \ | ||
411 | pangocairo-atsui.h \ | ||
412 | pangocairo-atsuifont.c \ | ||
413 | pangocairo-atsuifont.h \ | ||
414 | pangocairo-atsuifontmap.c | ||
415 | pangoinclude_HEADERS += pangoatsui.h | ||
416 | |||
417 | libpangocairo_1_0_la_CFLAGS = -xobjective-c | ||
418 | libpangocairo_1_0_la_LDFLAGS += -framework CoreFoundation -framework Carbon -framework Cocoa | ||
419 | libpangocairo_1_0_la_LIBADD += $(INCLUDED_ATSUI_MODULES) | ||
420 | # We don't have an ATSUI GIR right now, so this is just hypothetical | ||
421 | PANGOCAIRO_FONT_BACKEND_GI_MODULE = PangoATSUI-1.0 | ||
422 | endif | ||
423 | |||
424 | PangoCairo-1.0.gir: $(libpangocairo_1_0_la_SOURCES) | ||
425 | PangoCairo-1.0.gir: $(pangocairo_headers) | ||
426 | PangoCairo-1.0.gir: libpangocairo-1.0.la | ||
427 | PangoCairo-1.0.gir: Pango-1.0.gir $(PANGOCAIRO_FONT_BACKEND_GI_MODULE).gir $(G_IR_SCANNER) Makefile | ||
428 | $(AM_V_GEN) $(G_IR_SCANNER) -v --namespace PangoCairo --nsversion=1.0 \ | ||
429 | --add-include-path=$(srcdir) --add-include-path=. \ | ||
430 | --include=GObject-2.0 \ | ||
431 | --include=cairo-1.0 \ | ||
432 | --include=Pango-1.0 \ | ||
433 | --add-include-path=. \ | ||
434 | --include=$(PANGOCAIRO_FONT_BACKEND_GI_MODULE) \ | ||
435 | --library=libpangocairo-1.0.la \ | ||
436 | --libtool="$(LIBTOOL)" \ | ||
437 | --output $@ \ | ||
438 | --pkg gobject-2.0 \ | ||
439 | --pkg cairo \ | ||
440 | -I$(top_srcdir) \ | ||
441 | $(PANGO_CFLAGS) \ | ||
442 | $(libpangocairo_1_0_la_SOURCES) \ | ||
443 | $(pangocairo_headers) | ||
444 | |||
445 | # ------------------- libpangowin32 ------------------- | ||
446 | |||
447 | if HAVE_WIN32 | ||
448 | pangoinclude_HEADERS += pangowin32.h | ||
449 | lib_LTLIBRARIES += libpangowin32-1.0.la | ||
450 | endif | ||
451 | |||
452 | libpangowin32_1_0_la_LDFLAGS = $(LIBRARY_LIBTOOL_OPTIONS) | ||
453 | libpangowin32_1_0_la_LIBADD = \ | ||
454 | libpango-$(PANGO_API_VERSION).la \ | ||
455 | $(INCLUDED_WIN32_MODULES) \ | ||
456 | $(GLIB_LIBS) \ | ||
457 | $(WIN32_LIBS) | ||
458 | libpangowin32_1_0_la_DEPENDENCIES = \ | ||
459 | libpango-$(PANGO_API_VERSION).la \ | ||
460 | $(INCLUDED_WIN32_MODULES) | ||
461 | libpangowin32_1_0_la_SOURCES = \ | ||
462 | modules.h \ | ||
463 | module-defs-win32.c \ | ||
464 | pangowin32.h \ | ||
465 | pangowin32.c \ | ||
466 | pangowin32-private.h \ | ||
467 | pangowin32-fontcache.c \ | ||
468 | pangowin32-fontmap.c | ||
469 | |||
470 | if PLATFORM_WIN32 | ||
471 | libpangowin32_1_0_la_LDFLAGS += -export-symbols $(srcdir)/pangowin32.def -Wl,pangowin32-win32-res.o | ||
472 | libpangowin32_1_0_la_DEPENDENCIES += pangowin32-win32-res.o pangowin32.def | ||
473 | endif | ||
474 | pangowin32-win32-res.o: pangowin32.rc | ||
475 | $(AM_V_GEN) $(WINDRES) $< $@ | ||
476 | |||
477 | |||
478 | # ------------------- win32 build stuff ------------------- | ||
479 | |||
480 | if OS_WIN32 | ||
481 | install-def-files: | ||
482 | $(AM_V_GEN) mkdir -p $(DESTDIR)$(libdir) && \ | ||
483 | $(INSTALL) $(srcdir)/pango.def $(DESTDIR)$(libdir)/pango-$(PANGO_API_VERSION).def | ||
484 | if HAVE_FREETYPE | ||
485 | $(INSTALL) $(srcdir)/pangoft2.def $(DESTDIR)$(libdir)/pangoft2-$(PANGO_API_VERSION).def | ||
486 | endif | ||
487 | $(INSTALL) $(srcdir)/pangowin32.def $(DESTDIR)$(libdir)/pangowin32-$(PANGO_API_VERSION).def | ||
488 | $(INSTALL) $(srcdir)/pangocairo.def $(DESTDIR)$(libdir)/pangocairo-$(PANGO_API_VERSION).def | ||
489 | if HAVE_X | ||
490 | $(INSTALL) $(srcdir)/pangox.def $(DESTDIR)$(libdir)/pangox-$(PANGO_API_VERSION).def | ||
491 | $(INSTALL) $(srcdir)/pangoxft.def $(DESTDIR)$(libdir)/pangoxft-$(PANGO_API_VERSION).def | ||
492 | endif | ||
493 | uninstall-def-files: | ||
494 | -rm $(DESTDIR)$(libdir)/pango$(PANGO_API_VERSION).def | ||
495 | if HAVE_FREETYPE | ||
496 | -rm $(DESTDIR)$(libdir)/pangoft2-$(PANGO_API_VERSION).def | ||
497 | endif | ||
498 | -rm $(DESTDIR)$(libdir)/pangowin32-$(PANGO_API_VERSION).def | ||
499 | -rm $(DESTDIR)$(libdir)/pangocairo-$(PANGO_API_VERSION).def | ||
500 | if HAVE_X | ||
501 | -rm $(DESTDIR)$(libdir)/pangox-$(PANGO_API_VERSION).def | ||
502 | -rm $(DESTDIR)$(libdir)/pangoxft-$(PANGO_API_VERSION).def | ||
503 | endif | ||
504 | else | ||
505 | install-def-files: | ||
506 | uninstall-def-files: | ||
507 | |||
508 | endif | ||
509 | |||
510 | if MS_LIB_AVAILABLE | ||
511 | MS_LIB_FILES = pango-$(PANGO_API_VERSION).lib pangowin32-$(PANGO_API_VERSION).lib pangocairo-$(PANGO_API_VERSION).lib | ||
512 | |||
513 | if HAVE_FREETYPE | ||
514 | MS_LIB_FILES += pangoft2-$(PANGO_API_VERSION).lib | ||
515 | endif | ||
516 | |||
517 | noinst_DATA = $(MS_LIB_FILES) | ||
518 | |||
519 | install-ms-lib: $(MS_LIB_FILES) | ||
520 | $(INSTALL) pango-$(PANGO_API_VERSION).lib $(DESTDIR)$(libdir) | ||
521 | if HAVE_FREETYPE | ||
522 | $(INSTALL) pangoft2-$(PANGO_API_VERSION).lib $(DESTDIR)$(libdir) | ||
523 | endif | ||
524 | $(INSTALL) pangowin32-$(PANGO_API_VERSION).lib $(DESTDIR)$(libdir) | ||
525 | $(INSTALL) pangocairo-$(PANGO_API_VERSION).lib $(DESTDIR)$(libdir) | ||
526 | |||
527 | uninstall-ms-lib: | ||
528 | -rm $(DESTDIR)$(libdir)/pango-$(PANGO_API_VERSION).lib | ||
529 | -rm $(DESTDIR)$(libdir)/pangoft2-$(PANGO_API_VERSION).lib | ||
530 | -rm $(DESTDIR)$(libdir)/pangowin32-$(PANGO_API_VERSION).lib | ||
531 | -rm $(DESTDIR)$(libdir)/pangocairo-$(PANGO_API_VERSION).lib | ||
532 | else | ||
533 | install-ms-lib: | ||
534 | uninstall-ms-lib: | ||
535 | endif | ||
536 | |||
537 | pango-$(PANGO_API_VERSION).lib: libpango-$(PANGO_API_VERSION).la $(srcdir)/pango.def | ||
538 | $(AM_V_GEN) lib -machine:$(LIB_EXE_MACHINE_FLAG) -name:libpango-$(PANGO_API_VERSION)-$(PANGO_CURRENT_MINUS_AGE).dll -def:$(srcdir)/pango.def -out:$@ | ||
539 | |||
540 | pangoft2-$(PANGO_API_VERSION).lib: libpangoft2-$(PANGO_API_VERSION).la $(srcdir)/pangoft2.def | ||
541 | $(AM_V_GEN) lib -machine:$(LIB_EXE_MACHINE_FLAG) -name:libpangoft2-$(PANGO_API_VERSION)-$(PANGO_CURRENT_MINUS_AGE).dll -def:$(srcdir)/pangoft2.def -out:$@ | ||
542 | |||
543 | pangowin32-$(PANGO_API_VERSION).lib: libpangowin32-$(PANGO_API_VERSION).la $(srcdir)/pangowin32.def | ||
544 | $(AM_V_GEN) lib -machine:$(LIB_EXE_MACHINE_FLAG) -name:libpangowin32-$(PANGO_API_VERSION)-$(PANGO_CURRENT_MINUS_AGE).dll -def:$(srcdir)/pangowin32.def -out:$@ | ||
545 | |||
546 | pangocairo-$(PANGO_API_VERSION).lib: libpangocairo-$(PANGO_API_VERSION).la $(srcdir)/pangocairo.def | ||
547 | $(AM_V_GEN) lib -machine:$(LIB_EXE_MACHINE_FLAG) -name:libpangocairo-$(PANGO_API_VERSION)-$(PANGO_CURRENT_MINUS_AGE).dll -def:$(srcdir)/pangocairo.def -out:$@ | ||
548 | |||
549 | |||
550 | # ------------------- introspection ------------------- | ||
551 | |||
552 | if HAVE_INTROSPECTION | ||
553 | |||
554 | girdir = $(GIRDIR) | ||
555 | gir_DATA = $(BUILT_GIRSOURCES) | ||
556 | |||
557 | typelibsdir = $(TYPELIBDIR) | ||
558 | typelibs_DATA = $(BUILT_GIRSOURCES:.gir=.typelib) | ||
559 | |||
560 | %.typelib: %.gir $(G_IR_COMPILER) | ||
561 | $(AM_V_GEN) LD_LIBRARY_PATH=$${LD_LIBRARY_PATH:+$$LD_LIBRARY_PATH:}. $(G_IR_COMPILER) --includedir=$(srcdir) --includedir=. $(G_IR_COMPILER_OPTS) $< -o $(builddir)/$(@F) | ||
562 | |||
563 | endif # HAVE_INTROSPECTION | ||
564 | |||
565 | # ------------------- pango-querymodules ------------------- | ||
566 | |||
567 | bin_PROGRAMS = pango-querymodules | ||
568 | |||
569 | # | ||
570 | # As a temporary hack, we pull in libpangox here so that we can link | ||
571 | # | ||
572 | pango_querymodules_SOURCES = \ | ||
573 | querymodules.c | ||
574 | |||
575 | pango_querymodules_LDADD = | ||
576 | if HAVE_X | ||
577 | pango_querymodules_LDADD += libpangox-$(PANGO_API_VERSION).la | ||
578 | endif | ||
579 | if HAVE_XFT | ||
580 | pango_querymodules_LDADD += libpangoxft-$(PANGO_API_VERSION).la | ||
581 | endif | ||
582 | if HAVE_FREETYPE | ||
583 | pango_querymodules_LDADD += libpangoft2-$(PANGO_API_VERSION).la | ||
584 | endif | ||
585 | if HAVE_WIN32 | ||
586 | pango_querymodules_LDADD += libpangowin32-$(PANGO_API_VERSION).la | ||
587 | endif | ||
588 | pango_querymodules_LDADD += libpango-$(PANGO_API_VERSION).la $(GLIB_LIBS) | ||
589 | |||
590 | EXTRA_DIST += \ | ||
591 | pango-enum-types.h \ | ||
592 | module-defs.h \ | ||
593 | module-defs-fc.c.win32 \ | ||
594 | module-defs-win32.c.win32 \ | ||
595 | pango.def \ | ||
596 | pangocairo.def \ | ||
597 | pangowin32.def \ | ||
598 | pangoft2.def \ | ||
599 | makefile.msc \ | ||
600 | pango.rc \ | ||
601 | pango.rc.in \ | ||
602 | pangox.aliases \ | ||
603 | pangoft2.rc \ | ||
604 | pangoft2.rc.in \ | ||
605 | pangowin32.rc \ | ||
606 | pangowin32.rc.in \ | ||
607 | pangox.rc \ | ||
608 | pangox.rc.in \ | ||
609 | pangoxft.rc \ | ||
610 | pangoxft.rc.in \ | ||
611 | check.defs | ||
612 | |||
613 | |||
614 | if HAVE_INCLUDED_MODULES | ||
615 | included-modules: | ||
616 | $(AM_V_GEN) cd $(top_builddir)/modules && $(MAKE) $(AM_MAKEFLAGS) included-modules | ||
617 | |||
618 | $(INCLUDED_LANG_MODULES) $(INCLUDED_X_MODULES) $(INCLUDED_FC_MODULES) $(INCLUDED_WIN32_MODULES) $(INCLUDED_ATSUI_MODULES): included-modules | ||
619 | $(AM_V_GEN) true | ||
620 | |||
621 | .PHONY: included-modules | ||
622 | endif | ||
623 | |||
624 | MODULE_DEF_FILES = \ | ||
625 | module-defs.h \ | ||
626 | module-defs-lang.c \ | ||
627 | module-defs-x.c \ | ||
628 | module-defs-fc.c \ | ||
629 | module-defs-win32.c \ | ||
630 | module-defs-atsui.c | ||
631 | |||
632 | $(MODULE_DEF_FILES): $(top_builddir)/config.status | ||
633 | $(AM_V_GEN) cd $(top_builddir) && $(SHELL) ./config.status pango/$@ | ||
634 | |||
635 | CLEANFILES = \ | ||
636 | pango-enum-types.h \ | ||
637 | s-enum-types-h \ | ||
638 | pango-enum-types.c \ | ||
639 | s-enum-types-c | ||
640 | |||
641 | MOSTLYCLEANFILES = \ | ||
642 | *.list \ | ||
643 | *.expected | ||
644 | |||
645 | DISTCLEANFILES = \ | ||
646 | pango-features.h \ | ||
647 | $(MODULE_DEF_FILES) | ||
648 | |||
649 | install-data-local: install-ms-lib install-def-files | ||
650 | |||
651 | install-exec-hook: | ||
652 | if DISABLE_EXPLICIT_DEPS | ||
653 | -for i in libpangoft2-$(PANGO_API_VERSION).la libpangoxft-$(PANGO_API_VERSION).la libpangox-$(PANGO_API_VERSION).la libpangowin32-$(PANGO_API_VERSION).la; do \ | ||
654 | test -f $(DESTDIR)$(libdir)/$$i && $(SHELL) $(top_srcdir)/sanitize-la.sh $(DESTDIR)$(libdir)/$$i ; \ | ||
655 | done | ||
656 | endif | ||
657 | |||
658 | uninstall-local: uninstall-ms-lib uninstall-def-files | ||
659 | |||
660 | TESTS = check.defs | ||
661 | |||
662 | -include $(top_srcdir)/git.mk | ||