summaryrefslogtreecommitdiffstats
path: root/meta-lsb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-07-21 19:20:52 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 00:01:28 +0100
commit6da4a6688cbd90acb949d68247d9ab9c676021cf (patch)
tree4ab35dd7fbdec010fa56289bd0097f1b467986de /meta-lsb
parent18b33a2ce54e4272203c2eb42fbaabc879ccb8c5 (diff)
downloadpoky-6da4a6688cbd90acb949d68247d9ab9c676021cf.tar.gz
meta-lsb: Add basic infrastructure to create lsb image
Move tar and at to meta-lsb Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-lsb')
-rw-r--r--meta-lsb/conf/layer.conf10
-rw-r--r--meta-lsb/packages/images/poky-image-basic.bb23
-rw-r--r--meta-lsb/packages/images/poky-image-lsb.bb13
-rw-r--r--meta-lsb/packages/images/poky-image-small.bb7
-rw-r--r--meta-lsb/packages/tasks/task-poky-basic.bb149
-rw-r--r--meta-lsb/packages/tasks/task-poky-lsb.bb127
-rw-r--r--meta-lsb/packages/tasks/task-poky-small.bb38
7 files changed, 367 insertions, 0 deletions
diff --git a/meta-lsb/conf/layer.conf b/meta-lsb/conf/layer.conf
new file mode 100644
index 0000000000..1ef5c73a80
--- /dev/null
+++ b/meta-lsb/conf/layer.conf
@@ -0,0 +1,10 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/packages/*/*.bb"
6
7BBFILE_COLLECTIONS += "lsb"
8BBFILE_PATTERN_lsb := "^${LAYERDIR}/"
9BBFILE_PRIORITY_lsb = "5"
10
diff --git a/meta-lsb/packages/images/poky-image-basic.bb b/meta-lsb/packages/images/poky-image-basic.bb
new file mode 100644
index 0000000000..5dae327019
--- /dev/null
+++ b/meta-lsb/packages/images/poky-image-basic.bb
@@ -0,0 +1,23 @@
1IMAGE_FEATURES += "apps-console-core "
2
3IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \
5 task-poky-small \
6 task-poky-basic-libs \
7 task-poky-basic-libs-dbg \
8 task-poky-basic-libs-dev \
9 task-poky-basic-utils \
10 task-poky-basic-utils-dbg \
11 task-poky-basic-utils-dev \
12 task-poky-minimal-extras \
13 task-poky-minimal-extras-dbg \
14 task-poky-minimal-extras-dev \
15 task-poky-pkg-managment-opkg \
16 task-poky-pkg-managment-opkg-dbg \
17 task-poky-pkg-managment-opkg-dev \
18 task-poky-network-services \
19 task-poky-network-services-dbg \
20 task-poky-network-services-dev \
21 "
22
23inherit poky-image
diff --git a/meta-lsb/packages/images/poky-image-lsb.bb b/meta-lsb/packages/images/poky-image-lsb.bb
new file mode 100644
index 0000000000..af97894f80
--- /dev/null
+++ b/meta-lsb/packages/images/poky-image-lsb.bb
@@ -0,0 +1,13 @@
1IMAGE_FEATURES += "apps-console-core "
2
3IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \
5 task-poky-small-utils \
6 task-poky-basic-libs \
7 task-poky-basic-utils \
8 task-poky-extended-libs \
9 task-poky-extended-utils \
10 task-poky-network-services \
11 "
12
13inherit poky-image
diff --git a/meta-lsb/packages/images/poky-image-small.bb b/meta-lsb/packages/images/poky-image-small.bb
new file mode 100644
index 0000000000..33248c3e5a
--- /dev/null
+++ b/meta-lsb/packages/images/poky-image-small.bb
@@ -0,0 +1,7 @@
1IMAGE_FEATURES += "apps-console-core "
2
3IMAGE_INSTALL = "\
4 ${POKY_BASE_INSTALL} \
5 task-poky-small-utils"
6
7inherit poky-image
diff --git a/meta-lsb/packages/tasks/task-poky-basic.bb b/meta-lsb/packages/tasks/task-poky-basic.bb
new file mode 100644
index 0000000000..4ee7e540a7
--- /dev/null
+++ b/meta-lsb/packages/tasks/task-poky-basic.bb
@@ -0,0 +1,149 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Small Image Tasks"
6PR = "r0"
7
8PACKAGES = "\
9 task-poky-small \
10 task-poky-basic-libs \
11 task-poky-basic-libs-dbg \
12 task-poky-basic-libs-dev \
13 task-poky-basic-utils \
14 task-poky-basic-utils-dbg \
15 task-poky-basic-utils-dev \
16 task-poky-minimal-extras \
17 task-poky-minimal-extras-dbg \
18 task-poky-minimal-extras-dev \
19 task-poky-pkg-managment-opkg \
20 task-poky-pkg-managment-opkg-dbg \
21 task-poky-pkg-managment-opkg-dev \
22 task-poky-network-services \
23 task-poky-network-services-dbg \
24 task-poky-network-services-dev \
25 "
26
27ALLOW_EMPTY = "1"
28
29RDEPENDS_task-poky-minimal-extras = "\
30 makedevs \
31 ncurses \
32 zlib \
33 udev \
34 udev-extraconf \
35 expat \
36 "
37
38RDEPENDS_task-poky-pkg-managment-opkg = "\
39 curl \
40 gnutls \
41 gpgme \
42 libgcrypt \
43 libgpg-error \
44 lzo \
45 opkg-config-base \
46 opkg-collateral \
47 opkg \
48 pth \
49 "
50
51RDEPENDS_task-poky-network-services = "\
52# iproute \
53# iputils \
54# iptables \
55 nfs-utils \
56 "
57
58RDEPENDS_task-poky-shells = "\
59 bash \
60 mktemp \
61
62
63RDEPENDS_task-poky-misc = "\
64 strace \
65 lsof \
66 elfutils \
67 usbutils \
68 zlib \
69 libusb \
70 libstdcxx \
71 bluez4 \
72 "
73
74RDEPENDS_task-poky-basic-libs = "\
75# libssh2 \
76 dbus-glib \
77# nfs-utils-lib \
78 "
79
80RDEPENDS_task-poky-basic-utils = "\
81# openssh \
82 openssl \
83 pam \
84 sudo \
85 beecrypt \
86 curl \
87 elfutils \
88 neon \
89# mktemp \
90 rpm \
91 bzip2 \
92# crontabs \
93 dbus \
94 python-dbus \
95 e2fsprogs \
96 gdbm \
97 hal \
98 less \
99 popt \
100 portmap \
101 readline \
102# cron \
103# yaffs2 \
104 "
105
106RDEPENDS_task-poky-extended-libs = "\
107# cracklib \
108 glib-2.0 \
109 libcap \
110 libevent \
111 "
112
113RDEPENDS_task-poky-extended-utils = "\
114# acl \
115# at \
116 attr \
117# bc \
118 binutils \
119# cpio \
120# cracklib \
121# logrotate \
122# pax \
123# shadow \
124 sqlite3 \
125# syslog \
126# ed \
127# lsb \
128# mailx \
129# man \
130# sendmail \
131 tcl \
132 "
133
134RDEPENDS_task-poky-python = "\
135 gdbm \
136 perl \
137 zlib \
138 "
139
140RDEPENDS_task-poky-python = "\
141 expat \
142 gdbm \
143 gmp \
144 ncurses \
145 openssl \
146 python \
147 readline \
148 zlib \
149 "
diff --git a/meta-lsb/packages/tasks/task-poky-lsb.bb b/meta-lsb/packages/tasks/task-poky-lsb.bb
new file mode 100644
index 0000000000..034a5ca4c4
--- /dev/null
+++ b/meta-lsb/packages/tasks/task-poky-lsb.bb
@@ -0,0 +1,127 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Small Image Tasks"
6PR = "r0"
7
8PACKAGES = "\
9 task-poky-small \
10 task-poky-basic-libs \
11 task-poky-basic-libs-dbg \
12 task-poky-basic-libs-dev \
13 task-poky-basic-utils \
14 task-poky-basic-utils-dbg \
15 task-poky-basic-utils-dev \
16 task-poky-extended-libs \
17 task-poky-extended-libs-dbg \
18 task-poky-extended-libs-dev \
19 task-poky-extended-utils \
20 task-poky-extended-utils-dbg \
21 task-poky-extended-utils-dev \
22 task-poky-network-services \
23 task-poky-network-services-dbg \
24 task-poky-network-services-dev \
25 "
26
27ALLOW_EMPTY = "1"
28
29RDEPENDS_task-poky-network-services = "\
30# iproute \
31# iputils \
32# iptables \
33 nfs-utils \
34 "
35
36RDEPENDS_task-poky-shells = "\
37 bash \
38 mktemp \
39
40
41RDEPENDS_task-poky-misc = "\
42 strace \
43 lsof \
44 elfutils \
45 usbutils \
46 zlib \
47 libusb \
48 libstdcxx \
49 bluez4 \
50 "
51
52RDEPENDS_task-poky-basic-libs = "\
53# libssh2 \
54 dbus-glib \
55# nfs-utils-lib \
56 "
57
58RDEPENDS_task-poky-basic-utils = "\
59# openssh \
60 openssl \
61 pam \
62 sudo \
63 beecrypt \
64 curl \
65 elfutils \
66 neon \
67# mktemp \
68 rpm \
69 bzip2 \
70# crontabs \
71 dbus \
72 python-dbus \
73 e2fsprogs \
74 gdbm \
75 hal \
76 less \
77 popt \
78 portmap \
79 readline \
80# cron \
81# yaffs2 \
82 "
83
84RDEPENDS_task-poky-extended-libs = "\
85# cracklib \
86 glib-2.0 \
87 libcap \
88 libevent \
89 "
90
91RDEPENDS_task-poky-extended-utils = "\
92# acl \
93# at \
94 attr \
95# bc \
96 binutils \
97# cpio \
98# cracklib \
99# logrotate \
100# pax \
101# shadow \
102 sqlite3 \
103# syslog \
104# ed \
105# lsb \
106# mailx \
107# man \
108# sendmail \
109 tcl \
110 "
111
112RDEPENDS_task-poky-python = "\
113 gdbm \
114 perl \
115 zlib \
116 "
117
118RDEPENDS_task-poky-python = "\
119 expat \
120 gdbm \
121 gmp \
122 ncurses \
123 openssl \
124 python \
125 readline \
126 zlib \
127 "
diff --git a/meta-lsb/packages/tasks/task-poky-small.bb b/meta-lsb/packages/tasks/task-poky-small.bb
new file mode 100644
index 0000000000..b966dc72cc
--- /dev/null
+++ b/meta-lsb/packages/tasks/task-poky-small.bb
@@ -0,0 +1,38 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Small Image Tasks"
6PR = "r0"
7
8PACKAGES = "\
9 task-poky-small-utils \
10 task-poky-small-utils-dbg \
11 task-poky-small-utils-dev \
12 "
13
14ALLOW_EMPTY = "1"
15
16RDEPENDS_task-poky-small-utils = "\
17 bash \
18 coreutils \
19 file \
20 findutils \
21 ncurses \
22 psmisc \
23 sed \
24 time \
25 zlib \
26 udev \
27 udev-extraconf \
28# gawk \
29# grep \
30# gzip \
31# makedev \
32# mktemp \
33# net-tools \
34# procps \
35# passwd \
36# tar \
37# util-linux \
38 "