summaryrefslogtreecommitdiffstats
path: root/meta-lsb/packages/which/which_2.20.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:56:49 +0100
commitbb75c1810454a90a070370fee724da156acb888f (patch)
treeb8ae6e5c6ec1ad15108e20fdd52976ff93705d58 /meta-lsb/packages/which/which_2.20.bb
parent5abb132fec3e084bcefb4b6197b4806f6b05f515 (diff)
downloadpoky-bb75c1810454a90a070370fee724da156acb888f.tar.gz
Move byacc, which, libconvert-asn1-perl and libtimedate-perl to meta-lsb
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-lsb/packages/which/which_2.20.bb')
-rw-r--r--meta-lsb/packages/which/which_2.20.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-lsb/packages/which/which_2.20.bb b/meta-lsb/packages/which/which_2.20.bb
new file mode 100644
index 0000000000..b7730de3b3
--- /dev/null
+++ b/meta-lsb/packages/which/which_2.20.bb
@@ -0,0 +1,35 @@
1DESCRIPTION = "which - shows the full path of (shell) commands."
2SECTION = "libs"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504\
5 file://which.c;beginline=1;endline=17;md5=a9963693af2272e7a8df6f231164e7a2"
6HOMEPAGE = "http://ftp.gnu.org/gnu/which/"
7DEPENDS = "cwautomacros-native"
8
9inherit autotools
10
11PR = "r0"
12
13SRC_URI = "http://ftp.gnu.org/gnu/which/which-${PV}.tar.gz \
14 file://remove-declaration.patch"
15
16do_configure_prepend() {
17 sed -i -e 's%@ACLOCAL_CWFLAGS@%-I ${STAGING_DIR_NATIVE}/usr/share/cwautomacros/m4%g' ${S}/Makefile.am ${S}/tilde/Makefile.am
18}
19
20do_install() {
21 autotools_do_install
22 mv ${D}${bindir}/which ${D}${bindir}/which.${PN}
23}
24
25pkg_postinst_${PN} () {
26 if [ "${PN}" = "${BPN}" ] ; then
27 update-alternatives --install ${bindir}/which which which.${PN} 100
28 fi
29}
30
31pkg_prerm_${PN} () {
32 if [ "${PN}" = "${BPN}" ] ; then
33 update-alternatives --remove which which.${PN}
34 fi
35}