diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:14:24 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-08-27 15:29:45 +0100 |
commit | 29d6678fd546377459ef75cf54abeef5b969b5cf (patch) | |
tree | 8edd65790e37a00d01c3f203f773fe4b5012db18 /meta-lsb/packages/which/which_2.18.bb | |
parent | da49de6885ee1bc424e70bc02f21f6ab920efb55 (diff) | |
download | poky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz |
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things
and is generally overwhelming. This commit splits it into several
logical sections roughly based on function, recipes.txt gives more
information about the classifications used.
The opportunity is also used to switch from "packages" to "recipes"
as used in OpenEmbedded as the term "packages" can be confusing to
people and has many different meanings.
Not all recipes have been classified yet, this is just a first pass
at separating things out. Some packages are moved to meta-extras as
they're no longer actively used or maintained.
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-lsb/packages/which/which_2.18.bb')
-rw-r--r-- | meta-lsb/packages/which/which_2.18.bb | 40 |
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-lsb/packages/which/which_2.18.bb b/meta-lsb/packages/which/which_2.18.bb deleted file mode 100644 index b177949788..0000000000 --- a/meta-lsb/packages/which/which_2.18.bb +++ /dev/null | |||
@@ -1,40 +0,0 @@ | |||
1 | DESCRIPTION = "Which is a utility that prints out the full path of the \ | ||
2 | executables that bash(1) would execute when the passed \ | ||
3 | program names would have been entered on the shell prompt. \ | ||
4 | It does this by using the exact same algorithm as bash." | ||
5 | HOMEPAGE = "http://www.xs4all.nl/~carlo17/which/" | ||
6 | BUGTRACKER = "n/a" | ||
7 | |||
8 | LICENSE = "GPLv2+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | ||
10 | |||
11 | PR = "r0" | ||
12 | |||
13 | SRC_URI = "http://www.xs4all.nl/~carlo17/which/which-${PV}.tar.gz \ | ||
14 | file://fix_name_conflict_group_member.patch" | ||
15 | |||
16 | DEPENDS = "cwautomacros-native" | ||
17 | |||
18 | inherit autotools | ||
19 | |||
20 | do_configure_prepend() { | ||
21 | OLD="@ACLOCAL_CWFLAGS@" | ||
22 | NEW="-I ${STAGING_DIR_NATIVE}/${datadir}/cwautomacros/m4" | ||
23 | sed -i "s#${OLD}#${NEW}#g" `grep -rl ${OLD} ${S}` | ||
24 | } | ||
25 | do_install_append() { | ||
26 | mv ${D}/${bindir}/which ${D}/${bindir}/which.${PN} | ||
27 | } | ||
28 | |||
29 | pkg_postinst_${PN}() { | ||
30 | if [ "${PN}" = "${BPN}" ] ; then | ||
31 | update-alternatives --install ${bindir}/which which which.${PN} 100 | ||
32 | fi | ||
33 | } | ||
34 | |||
35 | pkg_prerm_${PN}() { | ||
36 | if [ "${PN}" = "${BPN}" ] ; then | ||
37 | update-alternatives --remove which which.${PN} | ||
38 | fi | ||
39 | } | ||
40 | |||