summaryrefslogtreecommitdiffstats
path: root/meta-lsb/packages/at/at-3.1.10.2/configure.patch
diff options
context:
space:
mode:
authorScott Garman <sgarman@zenlinux.com>2010-07-23 12:04:10 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-24 00:01:28 +0100
commit0d333290a530164a7cbb62b5bc0e848d644069b6 (patch)
treed3cc48765936cb4826df964c231ba940bd09b051 /meta-lsb/packages/at/at-3.1.10.2/configure.patch
parent6da4a6688cbd90acb949d68247d9ab9c676021cf (diff)
downloadpoky-0d333290a530164a7cbb62b5bc0e848d644069b6.tar.gz
at: New recipe additions 3.1.10.2 and 3.1.12
* at 3.1.12 is GPLv3 * at 3.1.10.2 is latest GPLv2 Recipes and patches derived from OpenEmbedded Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta-lsb/packages/at/at-3.1.10.2/configure.patch')
-rw-r--r--meta-lsb/packages/at/at-3.1.10.2/configure.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-lsb/packages/at/at-3.1.10.2/configure.patch b/meta-lsb/packages/at/at-3.1.10.2/configure.patch
new file mode 100644
index 0000000000..f6720111d6
--- /dev/null
+++ b/meta-lsb/packages/at/at-3.1.10.2/configure.patch
@@ -0,0 +1,22 @@
1# Fix cross-compilation issues in configure.ac
2# Derived from an OE patch for at-3.1.8
3
4--- at-3.1.10.2.orig/configure.in 2005-08-04 20:16:02.000000000 -0700
5+++ at-3.1.10.2/configure.in 2010-07-21 15:52:38.000000000 -0700
6@@ -37,12 +37,11 @@
7 AC_MSG_RESULT(no)
8 ;;
9 esac
10+if [ X"${cross_compiling}" = Xno ]; then
11 AC_MSG_CHECKING(Trying to compile a trivial ANSI C program)
12-AC_TRY_RUN([ main(int ac, char **av) { return 0; } ],
13- AC_MSG_RESULT(yes),
14- AC_MSG_RESULT(no)
15- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.),
16- AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.))
17+AC_RUN_IFELSE([AC_LANG_SOURCE([[ main(int ac, char **av) { return 0; } ]])],[AC_MSG_RESULT(yes)],[AC_MSG_RESULT(no)
18+ AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)],[AC_MSG_ERROR(Could not compile and run even a trivial ANSI C program - check CC.)])
19+fi
20
21 AC_MSG_CHECKING(__attribute__((noreturn)))
22 AC_TRY_COMPILE([], [void __attribute__((noreturn)) panic(void);],