summaryrefslogtreecommitdiffstats
path: root/meta-hob
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2012-02-23 21:48:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-24 00:39:10 +0000
commitcc2ef82c0c456e40ada94b5a23c3cf8384198785 (patch)
tree5717c3943217d81379f7599edab9ae330bc64903 /meta-hob
parent99c805a168953e9d9a1968fee15c590dd46bfd60 (diff)
downloadpoky-cc2ef82c0c456e40ada94b5a23c3cf8384198785.tar.gz
meta-hob: Add a new meta-hob layer
This new layer contains hob-image.bb and hob-toolchain.bb that are used by hob to build images or toolchain. (From OE-Core rev: 213b5038215b1d7df10f1df0375610034fa156c7) Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-hob')
-rw-r--r--meta-hob/COPYING.MIT17
-rw-r--r--meta-hob/conf/layer.conf9
-rw-r--r--meta-hob/recipes-core/images/hob-image.bb1
-rw-r--r--meta-hob/recipes-core/meta/hob-toolchain.bb10
4 files changed, 37 insertions, 0 deletions
diff --git a/meta-hob/COPYING.MIT b/meta-hob/COPYING.MIT
new file mode 100644
index 0000000000..fb950dc69f
--- /dev/null
+++ b/meta-hob/COPYING.MIT
@@ -0,0 +1,17 @@
1Permission is hereby granted, free of charge, to any person obtaining a copy
2of this software and associated documentation files (the "Software"), to deal
3in the Software without restriction, including without limitation the rights
4to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
5copies of the Software, and to permit persons to whom the Software is
6furnished to do so, subject to the following conditions:
7
8The above copyright notice and this permission notice shall be included in
9all copies or substantial portions of the Software.
10
11THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
12IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
13FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
14AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
15LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
16OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
17THE SOFTWARE.
diff --git a/meta-hob/conf/layer.conf b/meta-hob/conf/layer.conf
new file mode 100644
index 0000000000..5f5eb8218c
--- /dev/null
+++ b/meta-hob/conf/layer.conf
@@ -0,0 +1,9 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH := "${BBPATH}:${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
6
7BBFILE_COLLECTIONS += "hob"
8BBFILE_PATTERN_hob := "^${LAYERDIR}/"
9BBFILE_PRIORITY_hob = "1"
diff --git a/meta-hob/recipes-core/images/hob-image.bb b/meta-hob/recipes-core/images/hob-image.bb
new file mode 100644
index 0000000000..c8d6f49e6e
--- /dev/null
+++ b/meta-hob/recipes-core/images/hob-image.bb
@@ -0,0 +1 @@
inherit image
diff --git a/meta-hob/recipes-core/meta/hob-toolchain.bb b/meta-hob/recipes-core/meta/hob-toolchain.bb
new file mode 100644
index 0000000000..6535253744
--- /dev/null
+++ b/meta-hob/recipes-core/meta/hob-toolchain.bb
@@ -0,0 +1,10 @@
1DESCRIPTION = "dummy toolchain"
2LICENSE = "MIT"
3
4PR = "r0"
5
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
7 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9IMAGETEST ?= "dummy"
10inherit populate_sdk imagetest-${IMAGETEST}