summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-07-22 11:27:13 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-22 11:44:28 +0100
commitdc807f54f858419f97e211cd62fd2d30db9a80de (patch)
tree59adc7578ccccd566b5db07ed2a8e764c30510d8 /meta-gnome
parent5c63f8a2494cd74792e1a67b114a90a0a2fdbbcc (diff)
downloadpoky-dc807f54f858419f97e211cd62fd2d30db9a80de.tar.gz
Finally deprecate all legacy do_stage functions. This changes the existing warning
into a fatal error if any legacy do_stage functions are found. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/packages/gnome/libbonobo.inc28
-rw-r--r--meta-gnome/packages/gnome/libbonoboui_2.18.0.bb44
-rw-r--r--meta-gnome/packages/gnome/libgnome_2.24.0.bb3
-rw-r--r--meta-gnome/packages/gnome/libgnomeui_2.24.0.bb4
-rw-r--r--meta-gnome/packages/gnome/orbit2_2.14.16.bb16
-rw-r--r--meta-gnome/packages/gthumb/gthumb_2.10.11.bb4
6 files changed, 0 insertions, 99 deletions
diff --git a/meta-gnome/packages/gnome/libbonobo.inc b/meta-gnome/packages/gnome/libbonobo.inc
index 9f3642b80b..db5c58a51e 100644
--- a/meta-gnome/packages/gnome/libbonobo.inc
+++ b/meta-gnome/packages/gnome/libbonobo.inc
@@ -27,38 +27,10 @@ do_configure_prepend() {
27 install ${WORKDIR}/gtk-doc.make ./ 27 install ${WORKDIR}/gtk-doc.make ./
28} 28}
29 29
30ACTIVATION_HEADERS = "Bonobo_Unknown.h Bonobo_GenericFactory.h Bonobo_Activation_types.h \
31 bonobo-activation.h bonobo-activation-async.h bonobo-activation-activate.h \
32 bonobo-activation-init.h bonobo-activation-shlib.h bonobo-activation-register.h \
33 bonobo-activation-server-info.h bonobo-activation-version.h"
34
35BONOBO_HEADERS = "Bonobo.h bonobo-arg.h bonobo-context.h bonobo-event-source.h bonobo-exception.h \
36 bonobo-generic-factory.h bonobo-item-container.h bonobo-item-handler.h \
37 bonobo-listener.h bonobo-main.h bonobo-macros.h bonobo-moniker-extender.h \
38 bonobo-moniker-simple.h bonobo-moniker-util.h bonobo-moniker.h bonobo-object.h \
39 bonobo-foreign-object.h bonobo-persist-file.h bonobo-persist-stream.h \
40 bonobo-persist.h bonobo-persist-client.h bonobo-property-bag.h \
41 bonobo-property-bag-client.h bonobo-shlib-factory.h bonobo-storage.h \
42 bonobo-stream.h bonobo-stream-client.h bonobo-stream-memory.h \
43 bonobo-storage-memory.h bonobo-xobject.h bonobo-i18n.h bonobo-types.h \
44 bonobo-app-client.h bonobo-application.h"
45
46do_compile() { 30do_compile() {
47 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" 31 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
48} 32}
49 33
50do_stage() {
51 install -d ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation
52 for i in ${ACTIVATION_HEADERS}; do install -m 0644 bonobo-activation/$i ${STAGING_INCDIR}/bonobo-activation-2.0/bonobo-activation/; done
53 install -d ${STAGING_INCDIR}/libbonobo-2.0/bonobo
54 for i in ${BONOBO_HEADERS}; do install -m 0644 bonobo/$i ${STAGING_INCDIR}/libbonobo-2.0/bonobo/; done
55 install -m 0644 libbonobo.h ${STAGING_INCDIR}/libbonobo-2.0/
56 install -d ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
57 install idl/*.idl ${STAGING_DATADIR}/idl/bonobo-activation-2.0/
58 oe_libinstall -so -C bonobo libbonobo-2 ${STAGING_LIBDIR}
59 oe_libinstall -so -C bonobo-activation libbonobo-activation ${STAGING_LIBDIR}
60}
61
62do_install() { 34do_install() {
63 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install 35 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
64} 36}
diff --git a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
index 53380c6fa0..85840f705c 100644
--- a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
+++ b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
@@ -13,47 +13,3 @@ FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade" 13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
14 14
15EXTRA_OECONF = "--disable-gtk-doc" 15EXTRA_OECONF = "--disable-gtk-doc"
16
17HEADERS = " \
18bonobo/bonobo-zoomable.h \
19bonobo/bonobo-ui-component.h \
20bonobo/bonobo-dock-layout.h \
21bonobo/bonobo-ui-type-builtins.h \
22bonobo/bonobo-canvas-component.h \
23bonobo/bonobo-widget.h \
24bonobo/bonobo-ui-engine.h \
25bonobo/bonobo-window.h \
26bonobo/bonobo-ui-toolbar.h \
27bonobo/bonobo-dock-band.h \
28bonobo/bonobo-ui-toolbar-item.h \
29bonobo/bonobo-control.h \
30bonobo/bonobo-dock-item.h \
31bonobo/bonobo-ui-config-widget.h \
32bonobo/bonobo-zoomable-frame.h \
33bonobo/bonobo-control-frame.h \
34bonobo/bonobo-dock.h \
35bonobo/bonobo-ui-main.h \
36bonobo/bonobo-canvas-item.h \
37bonobo/bonobo-ui-node.h \
38bonobo/bonobo-socket.h \
39bonobo/bonobo-selector.h \
40bonobo/bonobo-ui-sync.h \
41bonobo/bonobo-ui-util.h \
42bonobo/bonobo-plug.h \
43bonobo/bonobo-ui-toolbar-button-item.h \
44bonobo/bonobo-ui-toolbar-toggle-button-item.h \
45bonobo/bonobo-ui-container.h \
46bonobo/bonobo-file-selector-util.h \
47bonobo/bonobo-property-control.h \
48bonobo/bonobo-selector-widget.h \
49libbonoboui.h \
50bonobo.h \
51"
52
53do_stage() {
54 install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
55 for i in ${HEADERS}; do
56 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
57 done
58 oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
59}
diff --git a/meta-gnome/packages/gnome/libgnome_2.24.0.bb b/meta-gnome/packages/gnome/libgnome_2.24.0.bb
index 549cda2855..21c5aaa8c1 100644
--- a/meta-gnome/packages/gnome/libgnome_2.24.0.bb
+++ b/meta-gnome/packages/gnome/libgnome_2.24.0.bb
@@ -14,6 +14,3 @@ FILES_${PN} += "${libdir}/bonobo/servers ${libdir}/bonobo/monikers/*.so \
14FILES_${PN}-dev += "${libdir}/bonobo/monikers/*a" 14FILES_${PN}-dev += "${libdir}/bonobo/monikers/*a"
15FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug" 15FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug"
16 16
17do_stage() {
18 autotools_stage_all
19}
diff --git a/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
index d216942140..c379cee729 100644
--- a/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
+++ b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
@@ -18,7 +18,3 @@ EXTRA_OECONF = "--disable-gtk-doc"
18do_configure_prepend() { 18do_configure_prepend() {
19 install -m 0644 ${WORKDIR}/gnome-stock-pixbufs.h ${S}/libgnomeui/pixmaps/gnome-stock-pixbufs.h 19 install -m 0644 ${WORKDIR}/gnome-stock-pixbufs.h ${S}/libgnomeui/pixmaps/gnome-stock-pixbufs.h
20} 20}
21
22do_stage() {
23 autotools_stage_all
24}
diff --git a/meta-gnome/packages/gnome/orbit2_2.14.16.bb b/meta-gnome/packages/gnome/orbit2_2.14.16.bb
index 5f6e6f6105..42ade84d1f 100644
--- a/meta-gnome/packages/gnome/orbit2_2.14.16.bb
+++ b/meta-gnome/packages/gnome/orbit2_2.14.16.bb
@@ -28,19 +28,3 @@ do_configure_prepend() {
28 install ${WORKDIR}/gtk-doc.make ./ 28 install ${WORKDIR}/gtk-doc.make ./
29} 29}
30 30
31do_stage() {
32 oe_libinstall -so -C src/orb libORBit-2 ${STAGING_LIBDIR}
33 oe_libinstall -so -C src/services/name libORBitCosNaming-2 ${STAGING_LIBDIR}
34 oe_libinstall -so -C src/services/imodule libORBit-imodule-2 ${STAGING_LIBDIR}
35 install -m 0644 src/services/name/libname-server-2.a ${STAGING_LIBDIR}/
36
37 for dir in orbit orbit/poa orbit/orb-core orbit/util orbit/dynamic; do
38 install -d ${STAGING_INCDIR}/orbit-2.0/$dir
39 ( cd include/$dir; for i in *.h; do install -m 0644 $i ${STAGING_INCDIR}/orbit-2.0/$dir/$i; done )
40 done
41
42 install -d ${STAGING_INCDIR}/orbit-2.0/ORBitservices
43 install -m 0644 src/services/name/CosNaming.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
44 install -m 0644 src/services/name/CosNaming_impl.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
45 install -m 0644 src/services/imodule/orbit-imodule.h ${STAGING_INCDIR}/orbit-2.0/ORBitservices/
46}
diff --git a/meta-gnome/packages/gthumb/gthumb_2.10.11.bb b/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
index 1b957e0a8d..2e588d71a8 100644
--- a/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
+++ b/meta-gnome/packages/gthumb/gthumb_2.10.11.bb
@@ -7,9 +7,5 @@ DEPENDS = "glib-2.0 gtk+ libbonobo libgnome libgnomeui gnome-vfs libxml2 libglad
7 7
8inherit gnome pkgconfig 8inherit gnome pkgconfig
9 9
10do_stage () {
11 autotools_stage_all
12}
13
14FILES_${PN} += "${datadir}/icons" 10FILES_${PN} += "${datadir}/icons"
15FILES_${PN}-dbg += "${libdir}/gthumb/modules/.debug" \ No newline at end of file 11FILES_${PN}-dbg += "${libdir}/gthumb/modules/.debug" \ No newline at end of file