summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-07-30 05:53:29 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-30 14:43:47 +0100
commitda1332a7dd5432dea0fbbce90641dbd2f2803fec (patch)
tree87ebad63a554334fef25a32d8e641eed71313a71 /meta-gnome
parent7f8c1bfb08c0b5b503856db79c536686b3cc7aca (diff)
downloadpoky-da1332a7dd5432dea0fbbce90641dbd2f2803fec.tar.gz
bonono/orbit2: Move to meta-extras
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/packages/gnome/files/acinclude.m490
-rw-r--r--meta-gnome/packages/gnome/files/gtk-doc.m453
-rw-r--r--meta-gnome/packages/gnome/files/gtk-doc.make148
-rw-r--r--meta-gnome/packages/gnome/files/tasn.m4161
-rw-r--r--meta-gnome/packages/gnome/libbonobo.inc36
-rw-r--r--meta-gnome/packages/gnome/libbonobo/configure-gthread.patch11
-rw-r--r--meta-gnome/packages/gnome/libbonobo_2.22.0.bb6
-rw-r--r--meta-gnome/packages/gnome/libbonoboui_2.18.0.bb15
-rw-r--r--meta-gnome/packages/gnome/orbit2-native_2.14.12.bb23
-rw-r--r--meta-gnome/packages/gnome/orbit2/configure-lossage.patch35
-rw-r--r--meta-gnome/packages/gnome/orbit2/pkgconfig-fix.patch12
-rw-r--r--meta-gnome/packages/gnome/orbit2_2.14.16.bb30
12 files changed, 0 insertions, 620 deletions
diff --git a/meta-gnome/packages/gnome/files/acinclude.m4 b/meta-gnome/packages/gnome/files/acinclude.m4
deleted file mode 100644
index 53518fb2eb..0000000000
--- a/meta-gnome/packages/gnome/files/acinclude.m4
+++ /dev/null
@@ -1,90 +0,0 @@
1## this one is commonly used with AM_PATH_PYTHONDIR ...
2dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
3dnl Check if a module containing a given symbol is visible to python.
4AC_DEFUN(AM_CHECK_PYMOD,
5[AC_REQUIRE([AM_PATH_PYTHON])
6py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
7AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
8AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
9ifelse([$2],[], [prog="
10import sys
11try:
12 import $1
13except ImportError:
14 sys.exit(1)
15except:
16 sys.exit(0)
17sys.exit(0)"], [prog="
18import $1
19$1.$2"])
20if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
21 then
22 eval "py_cv_mod_$py_mod_var=yes"
23 else
24 eval "py_cv_mod_$py_mod_var=no"
25 fi
26])
27py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
28if test "x$py_val" != xno; then
29 AC_MSG_RESULT(yes)
30 ifelse([$3], [],, [$3
31])dnl
32else
33 AC_MSG_RESULT(no)
34 ifelse([$4], [],, [$4
35])dnl
36fi
37])
38
39dnl a macro to check for ability to create python extensions
40dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
41dnl function also defines PYTHON_INCLUDES
42AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
43[AC_REQUIRE([AM_PATH_PYTHON])
44AC_MSG_CHECKING(for headers required to compile python extensions)
45dnl deduce PYTHON_INCLUDES
46AC_ARG_WITH(python-includes,
47 [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
48if test x$py_exec_prefix != x; then
49PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
50else
51py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
52py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
53PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
54if test "$py_prefix" != "$py_exec_prefix"; then
55 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
56fi
57fi
58AC_SUBST(PYTHON_INCLUDES)
59dnl check if the headers exist:
60save_CPPFLAGS="$CPPFLAGS"
61CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
62AC_TRY_CPP([#include <Python.h>],dnl
63[AC_MSG_RESULT(found)
64$1],dnl
65[AC_MSG_RESULT(not found)
66$2])
67CPPFLAGS="$save_CPPFLAGS"
68])
69
70dnl
71dnl JH_ADD_CFLAG(FLAG)
72dnl checks whether the C compiler supports the given flag, and if so, adds
73dnl it to $CFLAGS. If the flag is already present in the list, then the
74dnl check is not performed.
75AC_DEFUN([JH_ADD_CFLAG],
76[
77case " $CFLAGS " in
78*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
79 ;;
80*)
81 save_CFLAGS="$CFLAGS"
82 CFLAGS="$CFLAGS $1"
83 AC_MSG_CHECKING([whether [$]CC understands $1])
84 AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
85 AC_MSG_RESULT($jh_has_option)
86 if test $jh_has_option = no; then
87 CFLAGS="$save_CFLAGS"
88 fi
89 ;;
90esac])
diff --git a/meta-gnome/packages/gnome/files/gtk-doc.m4 b/meta-gnome/packages/gnome/files/gtk-doc.m4
deleted file mode 100644
index 3ec41666b2..0000000000
--- a/meta-gnome/packages/gnome/files/gtk-doc.m4
+++ /dev/null
@@ -1,53 +0,0 @@
1dnl -*- mode: autoconf -*-
2
3# serial 1
4
5dnl Usage:
6dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
7AC_DEFUN([GTK_DOC_CHECK],
8[
9 AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
10 AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
11 dnl for overriding the documentation installation directory
12 AC_ARG_WITH(html-dir,
13 AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
14 [with_html_dir='${datadir}/gtk-doc/html'])
15 HTML_DIR="$with_html_dir"
16 AC_SUBST(HTML_DIR)
17
18 dnl enable/disable documentation building
19 AC_ARG_ENABLE(gtk-doc,
20 AC_HELP_STRING([--enable-gtk-doc],
21 [use gtk-doc to build documentation [default=no]]),,
22 enable_gtk_doc=no)
23
24 have_gtk_doc=no
25 if test -z "$PKG_CONFIG"; then
26 AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
27 fi
28 if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
29 have_gtk_doc=yes
30 fi
31
32 dnl do we want to do a version check?
33ifelse([$1],[],,
34 [gtk_doc_min_version=$1
35 if test "$have_gtk_doc" = yes; then
36 AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
37 if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
38 AC_MSG_RESULT(yes)
39 else
40 AC_MSG_RESULT(no)
41 have_gtk_doc=no
42 fi
43 fi
44])
45 if test x$enable_gtk_doc = xyes; then
46 if test "$have_gtk_doc" != yes; then
47 enable_gtk_doc=no
48 fi
49 fi
50
51 AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
52 AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
53])
diff --git a/meta-gnome/packages/gnome/files/gtk-doc.make b/meta-gnome/packages/gnome/files/gtk-doc.make
deleted file mode 100644
index c319e7ad7c..0000000000
--- a/meta-gnome/packages/gnome/files/gtk-doc.make
+++ /dev/null
@@ -1,148 +0,0 @@
1# -*- mode: makefile -*-
2
3####################################
4# Everything below here is generic #
5####################################
6
7if GTK_DOC_USE_LIBTOOL
8GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
9GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
10else
11GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CFLAGS) $(CFLAGS)
12GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS)
13endif
14
15# We set GPATH here; this gives us semantics for GNU make
16# which are more like other make's VPATH, when it comes to
17# whether a source that is a target of one rule is then
18# searched for in VPATH/GPATH.
19#
20GPATH = $(srcdir)
21
22TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
23
24EXTRA_DIST = \
25 $(content_files) \
26 $(HTML_IMAGES) \
27 $(DOC_MAIN_SGML_FILE) \
28 $(DOC_MODULE).types \
29 $(DOC_MODULE)-sections.txt \
30 $(DOC_MODULE)-overrides.txt
31
32DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
33 $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
34
35SCANOBJ_FILES = \
36 $(DOC_MODULE).args \
37 $(DOC_MODULE).hierarchy \
38 $(DOC_MODULE).interfaces \
39 $(DOC_MODULE).prerequisites \
40 $(DOC_MODULE).signals
41
42CLEANFILES = $(SCANOBJ_FILES) $(DOC_MODULE)-scan.o $(DOC_MODULE)-unused.txt $(DOC_STAMPS)
43
44if ENABLE_GTK_DOC
45all-local: html-build.stamp
46
47#### scan ####
48
49scan-build.stamp: $(HFILE_GLOB)
50 @echo '*** Scanning header files ***'
51 @-chmod -R u+w $(srcdir)
52 if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null ; then \
53 CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
54 else \
55 cd $(srcdir) ; \
56 for i in $(SCANOBJ_FILES) ; do \
57 test -f $$i || touch $$i ; \
58 done \
59 fi
60 cd $(srcdir) && \
61 gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
62 touch scan-build.stamp
63
64$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES): scan-build.stamp
65 @true
66
67#### templates ####
68
69tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
70 @echo '*** Rebuilding template files ***'
71 @-chmod -R u+w $(srcdir)
72 cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE)
73 touch tmpl-build.stamp
74
75tmpl.stamp: tmpl-build.stamp
76 @true
77
78#### xml ####
79
80sgml-build.stamp: tmpl.stamp $(CFILE_GLOB) $(srcdir)/tmpl/*.sgml
81 @echo '*** Building XML ***'
82 @-chmod -R u+w $(srcdir)
83 cd $(srcdir) && \
84 gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml $(MKDB_OPTIONS)
85 touch sgml-build.stamp
86
87sgml.stamp: sgml-build.stamp
88 @true
89
90#### html ####
91
92html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
93 @echo '*** Building HTML ***'
94 @-chmod -R u+w $(srcdir)
95 rm -rf $(srcdir)/html
96 mkdir $(srcdir)/html
97 cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
98 test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
99 @echo '-- Fixing Crossreferences'
100 cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
101 touch html-build.stamp
102endif
103
104##############
105
106clean-local:
107 rm -f *~ *.bak
108
109maintainer-clean-local: clean
110 cd $(srcdir) && rm -rf xml html $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
111
112install-data-local:
113 $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR)
114 (installfiles=`echo $(srcdir)/html/*`; \
115 if test "$$installfiles" = '$(srcdir)/html/*'; \
116 then echo '-- Nothing to install' ; \
117 else \
118 for i in $$installfiles; do \
119 echo '-- Installing '$$i ; \
120 $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
121 done; \
122 echo '-- Installing $(srcdir)/html/index.sgml' ; \
123 $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
124 fi)
125
126uninstall-local:
127 rm -f $(DESTDIR)$(TARGET_DIR)/*
128
129#
130# Require gtk-doc when making dist
131#
132if ENABLE_GTK_DOC
133dist-check-gtkdoc:
134else
135dist-check-gtkdoc:
136 @echo "*** gtk-doc must be installed and enabled in order to make dist"
137 @false
138endif
139
140dist-hook: dist-check-gtkdoc dist-hook-local
141 mkdir $(distdir)/tmpl
142 mkdir $(distdir)/xml
143 mkdir $(distdir)/html
144 -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
145 -cp $(srcdir)/xml/*.xml $(distdir)/xml
146 -cp $(srcdir)/html/* $(distdir)/html
147
148.PHONY : dist-hook-local
diff --git a/meta-gnome/packages/gnome/files/tasn.m4 b/meta-gnome/packages/gnome/files/tasn.m4
deleted file mode 100644
index 6df32085a8..0000000000
--- a/meta-gnome/packages/gnome/files/tasn.m4
+++ /dev/null
@@ -1,161 +0,0 @@
1dnl Autoconf macros for libtasn1
2dnl $id$
3
4# Modified for LIBTASN1 -- nmav
5# Configure paths for LIBGCRYPT
6# Shamelessly stolen from the one of XDELTA by Owen Taylor
7# Werner Koch 99-12-09
8
9dnl AM_PATH_LIBTASN1([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
10dnl Test for libtasn1, and define LIBTASN1_CFLAGS and LIBTASN1_LIBS
11dnl
12AC_DEFUN([AM_PATH_LIBTASN1],
13[dnl
14dnl Get the cflags and libraries from the libtasn1-config script
15dnl
16AC_ARG_WITH(libtasn1-prefix,
17 [ --with-libtasn1-prefix=PFX Prefix where libtasn1 is installed (optional)],
18 libtasn1_config_prefix="$withval", libtasn1_config_prefix="")
19
20 if test x$libtasn1_config_prefix != x ; then
21 if test x${LIBTASN1_CONFIG+set} != xset ; then
22 LIBTASN1_CONFIG=$libtasn1_config_prefix/bin/libtasn1-config
23 fi
24 fi
25
26 AC_PATH_PROG(LIBTASN1_CONFIG, libtasn1-config, no)
27 min_libtasn1_version=ifelse([$1], ,0.1.0,$1)
28 AC_MSG_CHECKING(for libtasn1 - version >= $min_libtasn1_version)
29 no_libtasn1=""
30 if test "$LIBTASN1_CONFIG" = "no" ; then
31 no_libtasn1=yes
32 else
33 LIBTASN1_CFLAGS=`$LIBTASN1_CONFIG $libtasn1_config_args --cflags`
34 LIBTASN1_LIBS=`$LIBTASN1_CONFIG $libtasn1_config_args --libs`
35 libtasn1_config_version=`$LIBTASN1_CONFIG $libtasn1_config_args --version`
36
37
38 ac_save_CFLAGS="$CFLAGS"
39 ac_save_LIBS="$LIBS"
40 CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
41 LIBS="$LIBS $LIBTASN1_LIBS"
42dnl
43dnl Now check if the installed libtasn1 is sufficiently new. Also sanity
44dnl checks the results of libtasn1-config to some extent
45dnl
46 rm -f conf.libtasn1test
47 AC_TRY_RUN([
48#include <stdio.h>
49#include <stdlib.h>
50#include <string.h>
51#include <libtasn1.h>
52
53int
54main ()
55{
56 system ("touch conf.libtasn1test");
57
58 if( strcmp( asn1_check_version(NULL), "$libtasn1_config_version" ) )
59 {
60 printf("\n*** 'libtasn1-config --version' returned %s, but LIBTASN1 (%s)\n",
61 "$libtasn1_config_version", asn1_check_version(NULL) );
62 printf("*** was found! If libtasn1-config was correct, then it is best\n");
63 printf("*** to remove the old version of LIBTASN1. You may also be able to fix the error\n");
64 printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
65 printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
66 printf("*** required on your system.\n");
67 printf("*** If libtasn1-config was wrong, set the environment variable LIBTASN1_CONFIG\n");
68 printf("*** to point to the correct copy of libtasn1-config, and remove the file config.cache\n");
69 printf("*** before re-running configure\n");
70 }
71 else if ( strcmp(asn1_check_version(NULL), LIBTASN1_VERSION ) )
72 {
73 printf("\n*** LIBTASN1 header file (version %s) does not match\n", LIBTASN1_VERSION);
74 printf("*** library (version %s)\n", asn1_check_version(NULL) );
75 }
76 else
77 {
78 if ( asn1_check_version( "$min_libtasn1_version" ) )
79 {
80 return 0;
81 }
82 else
83 {
84 printf("no\n*** An old version of LIBTASN1 (%s) was found.\n",
85 asn1_check_version(NULL) );
86 printf("*** You need a version of LIBTASN1 newer than %s. The latest version of\n",
87 "$min_libtasn1_version" );
88 printf("*** LIBTASN1 is always available from ftp://gnutls.hellug.gr/pub/gnutls/libtasn1.\n");
89 printf("*** \n");
90 printf("*** If you have already installed a sufficiently new version, this error\n");
91 printf("*** probably means that the wrong copy of the libtasn1-config shell script is\n");
92 printf("*** being found. The easiest way to fix this is to remove the old version\n");
93 printf("*** of LIBTASN1, but you can also set the LIBTASN1_CONFIG environment to point to the\n");
94 printf("*** correct copy of libtasn1-config. (In this case, you will have to\n");
95 printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
96 printf("*** so that the correct libraries are found at run-time))\n");
97 }
98 }
99 return 0;
100}
101],, no_libtasn1=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
102 CFLAGS="$ac_save_CFLAGS"
103 LIBS="$ac_save_LIBS"
104 fi
105
106 if test "x$no_libtasn1" = x ; then
107 AC_MSG_RESULT(yes)
108 ifelse([$2], , :, [$2])
109 else
110 if test -f conf.libtasn1test ; then
111 :
112 else
113 AC_MSG_RESULT(no)
114 fi
115 if test "$LIBTASN1_CONFIG" = "no" ; then
116 echo "*** The libtasn1-config script installed by LIBTASN1 could not be found"
117 echo "*** If LIBTASN1 was installed in PREFIX, make sure PREFIX/bin is in"
118 echo "*** your path, or set the LIBTASN1_CONFIG environment variable to the"
119 echo "*** full path to libtasn1-config."
120 else
121 if test -f conf.libtasn1test ; then
122 :
123 else
124 echo "*** Could not run libtasn1 test program, checking why..."
125 CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
126 LIBS="$LIBS $LIBTASN1_LIBS"
127 AC_TRY_LINK([
128#include <stdio.h>
129#include <stdlib.h>
130#include <string.h>
131#include <libtasn1.h>
132], [ return !!asn1_check_version(NULL); ],
133 [ echo "*** The test program compiled, but did not run. This usually means"
134 echo "*** that the run-time linker is not finding LIBTASN1 or finding the wrong"
135 echo "*** version of LIBTASN1. If it is not finding LIBTASN1, you'll need to set your"
136 echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
137 echo "*** to the installed location Also, make sure you have run ldconfig if that"
138 echo "*** is required on your system"
139 echo "***"
140 echo "*** If you have an old version installed, it is best to remove it, although"
141 echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
142 echo "***" ],
143 [ echo "*** The test program failed to compile or link. See the file config.log for the"
144 echo "*** exact error that occured. This usually means LIBTASN1 was incorrectly installed"
145 echo "*** or that you have moved LIBTASN1 since it was installed. In the latter case, you"
146 echo "*** may want to edit the libtasn1-config script: $LIBTASN1_CONFIG" ])
147 CFLAGS="$ac_save_CFLAGS"
148 LIBS="$ac_save_LIBS"
149 fi
150 fi
151 LIBTASN1_CFLAGS=""
152 LIBTASN1_LIBS=""
153 ifelse([$3], , :, [$3])
154 fi
155 rm -f conf.libtasn1test
156 AC_SUBST(LIBTASN1_CFLAGS)
157 AC_SUBST(LIBTASN1_LIBS)
158])
159
160dnl *-*wedit:notab*-* Please keep this as the last line.
161
diff --git a/meta-gnome/packages/gnome/libbonobo.inc b/meta-gnome/packages/gnome/libbonobo.inc
deleted file mode 100644
index db5c58a51e..0000000000
--- a/meta-gnome/packages/gnome/libbonobo.inc
+++ /dev/null
@@ -1,36 +0,0 @@
1DESCRIPTION = "Bonobo CORBA interfaces library"
2LICENSE = "GPL"
3SECTION = "x11/gnome/libs"
4DEPENDS = "glib-2.0 orbit2 intltool-native libxml2"
5
6inherit gnome
7
8SRC_URI += "file://gtk-doc.m4 \
9 file://gtk-doc.make \
10 "
11
12ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
13
14FILES_${PN} += "${libdir}/orbit-2.0/*.so ${libdir}/bonobo/monikers/*.so"
15FILES_${PN}-dbg += "${libdir}/bonobo/monikers/.debug \
16 ${libdir}/bonobo-2.0/samples/.debug ${libdir}/orbit-2.0/.debug"
17FILES_${PN}-dev += "${libdir}/orbit-2.0/* ${libdir}/bonobo/monikers/* \
18 ${libdir}/bonobo-2.0/samples"
19
20LEAD_SONAME = "libbonobo-2.so"
21
22PARALLEL_MAKE = ""
23
24do_configure_prepend() {
25 install -d m4
26 install ${WORKDIR}/gtk-doc.m4 m4/
27 install ${WORKDIR}/gtk-doc.make ./
28}
29
30do_compile() {
31 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
32}
33
34do_install() {
35 oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
36}
diff --git a/meta-gnome/packages/gnome/libbonobo/configure-gthread.patch b/meta-gnome/packages/gnome/libbonobo/configure-gthread.patch
deleted file mode 100644
index 005fa6760a..0000000000
--- a/meta-gnome/packages/gnome/libbonobo/configure-gthread.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- libbonobo-2.14.0/configure.in.orig 2006-09-04 09:21:54.000000000 +0100
2+++ libbonobo-2.14.0/configure.in 2006-09-04 09:22:58.000000000 +0100
3@@ -166,7 +166,7 @@
4 AC_MSG_RESULT(no)
5 AC_MSG_ERROR(
6 [No working gthread-2.0 support found, using --disable-threads IS DISCOURAGED])
7- ]
8+ ],[AC_MSG_RESULT(yes)]
9 )
10 CFLAGS=$libbonobo_save_CFLAGS
11 LIBS=$libbonobo_save_LIBS
diff --git a/meta-gnome/packages/gnome/libbonobo_2.22.0.bb b/meta-gnome/packages/gnome/libbonobo_2.22.0.bb
deleted file mode 100644
index feecaf590a..0000000000
--- a/meta-gnome/packages/gnome/libbonobo_2.22.0.bb
+++ /dev/null
@@ -1,6 +0,0 @@
1require libbonobo.inc
2
3PR = "r0"
4
5SRC_URI += "file://configure-gthread.patch;patch=1"
6
diff --git a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
deleted file mode 100644
index 85840f705c..0000000000
--- a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1LICENSE = "GPL"
2SECTION = "x11/gnome/libs"
3PR = "r1"
4
5inherit gnome pkgconfig
6
7FILES_${PN} += "${libdir}/libglade/2.0/*.so"
8FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
9 ${libdir}/bonobo-2.0/samples"
10FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
11 ${libdir}/libglade/2.0/.debug"
12
13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
14
15EXTRA_OECONF = "--disable-gtk-doc"
diff --git a/meta-gnome/packages/gnome/orbit2-native_2.14.12.bb b/meta-gnome/packages/gnome/orbit2-native_2.14.12.bb
deleted file mode 100644
index 009974ade3..0000000000
--- a/meta-gnome/packages/gnome/orbit2-native_2.14.12.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "CORBA ORB"
2PR = "r0"
3LICENSE = "LGPL GPL"
4SECTION = "x11/gnome/libs"
5SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
6 file://configure-lossage.patch;patch=1;pnum=1 \
7 file://gtk-doc.m4 \
8 file://gtk-doc.make"
9DEPENDS = "libidl-native popt-native gtk-doc"
10
11S = "${WORKDIR}/ORBit2-${PV}"
12FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/orbit2"
13
14PARALLEL_MAKE = ""
15inherit autotools native pkgconfig
16
17EXTRA_OECONF = "--disable-gtk-doc"
18
19do_configure_prepend() {
20 mkdir -p m4
21 install ${WORKDIR}/gtk-doc.m4 ./m4/
22 install ${WORKDIR}/gtk-doc.make ./
23}
diff --git a/meta-gnome/packages/gnome/orbit2/configure-lossage.patch b/meta-gnome/packages/gnome/orbit2/configure-lossage.patch
deleted file mode 100644
index 7485a0ce0c..0000000000
--- a/meta-gnome/packages/gnome/orbit2/configure-lossage.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1--- orbit/configure.in~ 2004-05-07 09:31:32.000000000 +0100
2+++ orbit/configure.in 2004-05-08 19:27:35.000000000 +0100
3@@ -193,19 +193,19 @@
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]))
19-LIBS="$dofus_save_libs"
20+dnl dofus_save_libs="$LIBS"
21+dnl LIBS="$ORBIT_LIBS $LIBS"
22+dnl AC_TRY_RUN([ #include <stdio.h>
23+dnl main ()
24+dnl {
25+dnl return 0;
26+dnl } ],,
27+dnl AC_MSG_ERROR([
28+dnl Linking is badly borked on your system. Please ensure your library path is correct
29+dnl Check config.log for details - check near the end of the log above 'failed program was'
30+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
31+dnl prefix you're compiling on: '${prefix}' ]))
32+dnl LIBS="$dofus_save_libs"
33
34 orig_CPPFLAGS=$CPPFLAGS
35 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-gnome/packages/gnome/orbit2/pkgconfig-fix.patch b/meta-gnome/packages/gnome/orbit2/pkgconfig-fix.patch
deleted file mode 100644
index f629e506dd..0000000000
--- a/meta-gnome/packages/gnome/orbit2/pkgconfig-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
1diff -urN ORBit2-2.14.12.orig/ORBit-2.0.pc.in ORBit2-2.14.12/ORBit-2.0.pc.in
2--- ORBit2-2.14.12.orig/ORBit-2.0.pc.in 2008-01-29 13:45:22.000000000 +0100
3+++ ORBit2-2.14.12/ORBit-2.0.pc.in 2008-09-23 20:13:07.000000000 +0200
4@@ -2,7 +2,7 @@
5 exec_prefix=@exec_prefix@
6 libdir=@libdir@
7 includedir=@includedir@
8-orbit_idl=@bindir@/orbit-idl-2@EXEEXT@
9+orbit_idl=@exec_prefix@/bin/orbit-idl-2@EXEEXT@
10
11
12 Name: ORBit-2.0
diff --git a/meta-gnome/packages/gnome/orbit2_2.14.16.bb b/meta-gnome/packages/gnome/orbit2_2.14.16.bb
deleted file mode 100644
index 42ade84d1f..0000000000
--- a/meta-gnome/packages/gnome/orbit2_2.14.16.bb
+++ /dev/null
@@ -1,30 +0,0 @@
1LICENSE = "GPL"
2DESCRIPTION = "CORBA ORB"
3SECTION = "x11/gnome/libs"
4SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
5 file://configure-lossage.patch;patch=1;pnum=1 \
6 file://pkgconfig-fix.patch;patch=1 \
7 file://gtk-doc.m4 \
8 file://gtk-doc.make"
9DEPENDS = "libidl popt orbit2-native gtk-doc"
10PARALLEL_MAKE = ""
11
12FILES_${PN} += "${libdir}/orbit-2.0/*.so"
13FILES_${PN}-dev += "${libdir}/orbit-2.0/*.a ${libdir}/orbit-2.0/*.la"
14FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
15
16S = "${WORKDIR}/ORBit2-${PV}"
17
18LEAD_SONAME = "libORBit-2.so"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--disable-gtk-doc"
23EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
24
25do_configure_prepend() {
26 mkdir -p m4
27 install ${WORKDIR}/gtk-doc.m4 ./m4/
28 install ${WORKDIR}/gtk-doc.make ./
29}
30