summaryrefslogtreecommitdiffstats
path: root/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-06-10 11:07:02 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2009-06-10 11:07:02 +0100
commit5f37dfd98b624111d573bcdadfad0ee82c999cbe (patch)
tree76b32d8c557eff2d90889371a0d93c4217e386c9 /meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
parentd10060c3305a6c1307878f723cd7b28045ed2a2b (diff)
downloadpoky-5f37dfd98b624111d573bcdadfad0ee82c999cbe.tar.gz
Add meta-gnome overlay information for gnome packages which aren't part of standard Poky (based on OE.dev but with additions/modifications)
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-gnome/packages/gnome/libgnomeui_2.24.0.bb')
-rw-r--r--meta-gnome/packages/gnome/libgnomeui_2.24.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
new file mode 100644
index 0000000000..d216942140
--- /dev/null
+++ b/meta-gnome/packages/gnome/libgnomeui_2.24.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "GNOME User Interface Library"
2LICENSE = "GPL"
3SECTION = "x11/gnome/libs"
4DEPENDS = "libgnome libgnomecanvas gnome-keyring libbonoboui"
5
6inherit gnome
7
8FILES_${PN} += "${libdir}/gtk-2.0/*/filesystems/lib*.so \
9 ${libdir}/libglade/*/lib*.so \
10 ${datadir}/pixmaps/gnome-about-logo.png"
11FILES_${PN}-dev += "${libdir}/gtk-2.0/*/filesystems/*.la ${libdir}/gtk-2.0/*/filesystems/*.a ${libdir}/libglade/*/*.la ${libdir}/libglade/*/*.a"
12FILES_${PN}-dbg += "${libdir}/gtk-2.0/*/filesystems/.debug/ ${libdir}/libglade/*/.debug/"
13
14SRC_URI += "file://gnome-stock-pixbufs.h file://no-pixbuf-csource.patch;patch=1"
15
16EXTRA_OECONF = "--disable-gtk-doc"
17
18do_configure_prepend() {
19 install -m 0644 ${WORKDIR}/gnome-stock-pixbufs.h ${S}/libgnomeui/pixmaps/gnome-stock-pixbufs.h
20}
21
22do_stage() {
23 autotools_stage_all
24}