summaryrefslogtreecommitdiffstats
path: root/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-07-22 11:27:13 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-22 11:44:28 +0100
commitdc807f54f858419f97e211cd62fd2d30db9a80de (patch)
tree59adc7578ccccd566b5db07ed2a8e764c30510d8 /meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
parent5c63f8a2494cd74792e1a67b114a90a0a2fdbbcc (diff)
downloadpoky-dc807f54f858419f97e211cd62fd2d30db9a80de.tar.gz
Finally deprecate all legacy do_stage functions. This changes the existing warning
into a fatal error if any legacy do_stage functions are found. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-gnome/packages/gnome/libbonoboui_2.18.0.bb')
-rw-r--r--meta-gnome/packages/gnome/libbonoboui_2.18.0.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
index 53380c6fa0..85840f705c 100644
--- a/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
+++ b/meta-gnome/packages/gnome/libbonoboui_2.18.0.bb
@@ -13,47 +13,3 @@ FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade" 13DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
14 14
15EXTRA_OECONF = "--disable-gtk-doc" 15EXTRA_OECONF = "--disable-gtk-doc"
16
17HEADERS = " \
18bonobo/bonobo-zoomable.h \
19bonobo/bonobo-ui-component.h \
20bonobo/bonobo-dock-layout.h \
21bonobo/bonobo-ui-type-builtins.h \
22bonobo/bonobo-canvas-component.h \
23bonobo/bonobo-widget.h \
24bonobo/bonobo-ui-engine.h \
25bonobo/bonobo-window.h \
26bonobo/bonobo-ui-toolbar.h \
27bonobo/bonobo-dock-band.h \
28bonobo/bonobo-ui-toolbar-item.h \
29bonobo/bonobo-control.h \
30bonobo/bonobo-dock-item.h \
31bonobo/bonobo-ui-config-widget.h \
32bonobo/bonobo-zoomable-frame.h \
33bonobo/bonobo-control-frame.h \
34bonobo/bonobo-dock.h \
35bonobo/bonobo-ui-main.h \
36bonobo/bonobo-canvas-item.h \
37bonobo/bonobo-ui-node.h \
38bonobo/bonobo-socket.h \
39bonobo/bonobo-selector.h \
40bonobo/bonobo-ui-sync.h \
41bonobo/bonobo-ui-util.h \
42bonobo/bonobo-plug.h \
43bonobo/bonobo-ui-toolbar-button-item.h \
44bonobo/bonobo-ui-toolbar-toggle-button-item.h \
45bonobo/bonobo-ui-container.h \
46bonobo/bonobo-file-selector-util.h \
47bonobo/bonobo-property-control.h \
48bonobo/bonobo-selector-widget.h \
49libbonoboui.h \
50bonobo.h \
51"
52
53do_stage() {
54 install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
55 for i in ${HEADERS}; do
56 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
57 done
58 oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
59}