diff options
author | Ross Burton <ross@openedhand.com> | 2007-09-25 15:52:21 +0000 |
---|---|---|
committer | Ross Burton <ross@openedhand.com> | 2007-09-25 15:52:21 +0000 |
commit | 2c13e1b5b5fd442c3d0baa3391a49054df03392d (patch) | |
tree | 8a4bcb22c698e78875dea108d3e51e26802f32e8 /meta-extras | |
parent | 3cc1591ead410cb4a5f4d3600546361d3432f99d (diff) | |
download | poky-2c13e1b5b5fd442c3d0baa3391a49054df03392d.tar.gz |
Remove dhcdbd, NM 0.7 doesn't need it
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2790 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r-- | meta-extras/packages/dhcdbd/dhcdbd_2.0.bb | 25 | ||||
-rw-r--r-- | meta-extras/packages/dhcdbd/files/dbus-api-fix.patch | 20 | ||||
-rw-r--r-- | meta-extras/packages/dhcdbd/files/dhcdbd | 28 | ||||
-rw-r--r-- | meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch | 26 | ||||
-rw-r--r-- | meta-extras/packages/dhcdbd/files/no-ext-options.patch | 13 |
5 files changed, 0 insertions, 112 deletions
diff --git a/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb b/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb deleted file mode 100644 index de9e24abd5..0000000000 --- a/meta-extras/packages/dhcdbd/dhcdbd_2.0.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | DESCRIPTION="DBus-enabled dhcp client" | ||
2 | SECTION="net" | ||
3 | LICENSE="GPL" | ||
4 | HOMEPAGE="http://people.redhat.com/jvdias/dhcdbd/" | ||
5 | |||
6 | DEPENDS = "dbus" | ||
7 | RDEPENDS = "dhcp-client" | ||
8 | |||
9 | PR = "r0" | ||
10 | |||
11 | SRC_URI="http://people.redhat.com/dcantrel/dhcdbd/dhcdbd-${PV}.tar.bz2 \ | ||
12 | file://no-ext-options.patch;patch=1 \ | ||
13 | file://dhcdbd" | ||
14 | |||
15 | do_compile() { | ||
16 | CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make | ||
17 | } | ||
18 | |||
19 | do_install() { | ||
20 | DESTDIR=${D} make install | ||
21 | install -d ${D}/etc/init.d | ||
22 | install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/ | ||
23 | } | ||
24 | |||
25 | FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*" | ||
diff --git a/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch b/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch deleted file mode 100644 index ce05fc7bf8..0000000000 --- a/meta-extras/packages/dhcdbd/files/dbus-api-fix.patch +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | --- /tmp/dbus_service.c 2006-08-24 22:09:14.000000000 +0200 | ||
2 | +++ dhcdbd-1.14/dbus_service.c 2006-08-24 22:09:44.228306000 +0200 | ||
3 | @@ -1412,7 +1412,7 @@ | ||
4 | return ( cs ); | ||
5 | |||
6 | give_up: | ||
7 | - dbus_connection_disconnect( connection ); | ||
8 | + dbus_connection_close( connection ); | ||
9 | dbus_shutdown(); | ||
10 | return ( 0L ); | ||
11 | } | ||
12 | @@ -1456,7 +1456,7 @@ | ||
13 | cs->roots=0L; | ||
14 | |||
15 | |||
16 | - dbus_connection_disconnect( cs->connection ); | ||
17 | + dbus_connection_close( cs->connection ); | ||
18 | dbus_shutdown(); | ||
19 | free( cs ); | ||
20 | } | ||
diff --git a/meta-extras/packages/dhcdbd/files/dhcdbd b/meta-extras/packages/dhcdbd/files/dhcdbd deleted file mode 100644 index 568753c28c..0000000000 --- a/meta-extras/packages/dhcdbd/files/dhcdbd +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | # | ||
3 | # DHCDBD startup script | ||
4 | |||
5 | . /etc/profile | ||
6 | |||
7 | case $1 in | ||
8 | 'start') | ||
9 | echo -n "Starting dhcdbd daemon: dhcdbd" | ||
10 | /sbin/dhcdbd --system | ||
11 | echo "." | ||
12 | ;; | ||
13 | |||
14 | 'stop') | ||
15 | echo -n "Stopping dhcdbd: dhcdbd" | ||
16 | killall `ps |grep /sbin/dhcdbd | grep -v grep | cut "-d " -f2` | ||
17 | echo "." | ||
18 | ;; | ||
19 | |||
20 | 'restart') | ||
21 | $0 stop | ||
22 | $0 start | ||
23 | ;; | ||
24 | |||
25 | *) | ||
26 | echo "Usage: $0 { start | stop | restart }" | ||
27 | ;; | ||
28 | esac | ||
diff --git a/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch b/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch deleted file mode 100644 index c2e2151d17..0000000000 --- a/meta-extras/packages/dhcdbd/files/dhcdbd-1.14-pkgconfig_dbus.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | diff -Naur dhcdbd-1.14/Makefile dhcdbd-1.14-mod/Makefile | ||
2 | --- dhcdbd-1.14/Makefile 2006-01-17 22:23:51.000000000 +0100 | ||
3 | +++ dhcdbd-1.14-mod/Makefile 2006-08-02 18:02:42.000000000 +0200 | ||
4 | @@ -7,8 +7,8 @@ | ||
5 | LDFLAGS ?= -g | ||
6 | DESTDIR ?= / | ||
7 | LIBDIR ?= lib | ||
8 | -DBUS_INCLUDES ?= -I/usr/$(LIBDIR)/dbus-1.0/include -I/usr/include/dbus-1.0 | ||
9 | -DBUS_LIBS ?= -ldbus-1 | ||
10 | +DBUS_INCLUDES ?= `pkg-config dbus-1 --cflags` | ||
11 | +DBUS_LIBS ?= `pkg-config dbus-1 --libs` | ||
12 | OBJS = dbus_service.o dhcdbd.o dhcp_options.o main.o | ||
13 | SRCS = dbus_service.c dhcdbd.c dhcp_options.c main.c | ||
14 | INCS = dbus_service.h dhcdbd.h dhcp_options.h includes.h | ||
15 | diff -Naur dhcdbd-1.14/tests/Makefile dhcdbd-1.14-mod/tests/Makefile | ||
16 | --- dhcdbd-1.14/tests/Makefile 2006-01-17 22:23:51.000000000 +0100 | ||
17 | +++ dhcdbd-1.14-mod/tests/Makefile 2006-08-02 18:11:43.000000000 +0200 | ||
18 | @@ -2,7 +2,7 @@ | ||
19 | LD = ${CC} | ||
20 | CFLAGS ?= -g -Wall | ||
21 | LDFLAGS ?= -g | ||
22 | -DBUS_LIBS ?= -ldbus-1 | ||
23 | +DBUS_LIBS ?= `pkg-config dbus-1 --libs` | ||
24 | |||
25 | all: test_dhcp_options test_dhcdbd_state test_subscriber test_subscriber_dbus test_prospective_subscriber | ||
26 | |||
diff --git a/meta-extras/packages/dhcdbd/files/no-ext-options.patch b/meta-extras/packages/dhcdbd/files/no-ext-options.patch deleted file mode 100644 index 774a2cf140..0000000000 --- a/meta-extras/packages/dhcdbd/files/no-ext-options.patch +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | Index: dhcdbd-2.0/include/dhcdbd.h | ||
2 | =================================================================== | ||
3 | --- dhcdbd-2.0.orig/include/dhcdbd.h 2006-10-18 09:38:18.000000000 +0100 | ||
4 | +++ dhcdbd-2.0/include/dhcdbd.h 2006-10-18 09:38:45.000000000 +0100 | ||
5 | @@ -76,7 +76,7 @@ | ||
6 | #endif | ||
7 | |||
8 | #ifndef DHCLIENT_EXTENDED_OPTION_ENVIRONMENT | ||
9 | -#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 1 | ||
10 | +#define DHCLIENT_EXTENDED_OPTION_ENVIRONMENT 0 | ||
11 | #endif | ||
12 | |||
13 | #define DHCDBD_INTERFACE_TEXT "text" | ||