summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2008-01-18 14:58:24 +0000
committerRoss Burton <ross@openedhand.com>2008-01-18 14:58:24 +0000
commit979d581764369a0bd618a6445a43c068a3ed3aaa (patch)
treeb31e3e67a85dedb875de2fdbf57c0c48660afe5c /meta-extras
parent38fb1d45b9a0462a2187e7af67cf5e7b56deb08a (diff)
downloadpoky-979d581764369a0bd618a6445a43c068a3ed3aaa.tar.gz
Add notifation-daemon and libnotify
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3542 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/libnotify/libnotify_0.4.4.bb14
-rw-r--r--meta-extras/packages/notification-daemon/files/no-wnck-sexy.patch98
-rw-r--r--meta-extras/packages/notification-daemon/notification-daemon_0.3.7.bb21
3 files changed, 133 insertions, 0 deletions
diff --git a/meta-extras/packages/libnotify/libnotify_0.4.4.bb b/meta-extras/packages/libnotify/libnotify_0.4.4.bb
new file mode 100644
index 0000000000..9152133b4d
--- /dev/null
+++ b/meta-extras/packages/libnotify/libnotify_0.4.4.bb
@@ -0,0 +1,14 @@
1DESCRIPTION = "Send desktop notifications to a notification daemon"
2HOMEPAGE = "http://www.galago-project.org/"
3SECTION = "libs"
4LICENSE = "LGPL"
5DEPENDS = "dbus gtk+"
6PR = "r0"
7
8SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${PN}-${PV}.tar.gz"
9
10inherit autotools pkgconfig
11
12do_stage() {
13 autotools_stage_all
14}
diff --git a/meta-extras/packages/notification-daemon/files/no-wnck-sexy.patch b/meta-extras/packages/notification-daemon/files/no-wnck-sexy.patch
new file mode 100644
index 0000000000..3367292e1f
--- /dev/null
+++ b/meta-extras/packages/notification-daemon/files/no-wnck-sexy.patch
@@ -0,0 +1,98 @@
1diff -ur notification-daemon-0.3.7.orig/configure.ac notification-daemon-0.3.7/configure.ac
2--- notification-daemon-0.3.7.orig/configure.ac 2007-02-28 05:16:16.000000000 +0000
3+++ notification-daemon-0.3.7/configure.ac 2008-01-18 11:29:28.000000000 +0000
4@@ -82,9 +82,7 @@
5 glib-2.0 >= $REQ_GLIB_VERSION, \
6 dbus-1 >= $REQ_DBUS_VERSION, \
7 dbus-glib-1 >= $REQ_DBUS_VERSION, \
8- libsexy >= $REQ_SEXY_VERSION, \
9- gconf-2.0, \
10- libwnck-1.0 \
11+ gconf-2.0 \
12 "
13 PKG_CHECK_MODULES(NOTIFICATION_DAEMON, $pkg_modules)
14 AC_SUBST(NOTIFICATION_DAEMON_CFLAGS)
15Only in notification-daemon-0.3.7/: configure.ac~
16Only in notification-daemon-0.3.7.orig/: debian
17diff -ur notification-daemon-0.3.7.orig/src/daemon/daemon.c notification-daemon-0.3.7/src/daemon/daemon.c
18--- notification-daemon-0.3.7.orig/src/daemon/daemon.c 2007-02-15 10:47:09.000000000 +0000
19+++ notification-daemon-0.3.7/src/daemon/daemon.c 2008-01-18 11:24:40.000000000 +0000
20@@ -39,9 +39,6 @@
21 #include <X11/Xatom.h>
22 #include <gdk/gdkx.h>
23
24-#define WNCK_I_KNOW_THIS_IS_UNSTABLE
25-#include <libwnck/libwnck.h>
26-
27 #include "daemon.h"
28 #include "engines.h"
29 #include "stack.h"
30@@ -771,37 +768,6 @@
31 static gboolean
32 fullscreen_window_exists(GtkWidget *nw)
33 {
34- WnckScreen *wnck_screen;
35- GList *l;
36-
37- wnck_screen = wnck_screen_get(GDK_SCREEN_XNUMBER(
38- gdk_drawable_get_screen(GDK_DRAWABLE(GTK_WIDGET(nw)->window))));
39- wnck_screen_force_update(wnck_screen);
40-
41- for (l = wnck_screen_get_windows_stacked(wnck_screen);
42- l != NULL;
43- l = l->next)
44- {
45- WnckWindow *wnck_win = (WnckWindow *)l->data;
46-
47- if (wnck_window_is_fullscreen(wnck_win))
48- {
49- /*
50- * Sanity check if the window is _really_ fullscreen to
51- * work around a bug in libwnck that doesn't get all
52- * unfullscreen events.
53- */
54- int sw = wnck_screen_get_width(wnck_screen);
55- int sh = wnck_screen_get_height(wnck_screen);
56- int x, y, w, h;
57-
58- wnck_window_get_geometry(wnck_win, &x, &y, &w, &h);
59-
60- if (sw == w && sh == h)
61- return TRUE;
62- }
63- }
64-
65 return FALSE;
66 }
67
68Only in notification-daemon-0.3.7/src/daemon: daemon.c~
69diff -ur notification-daemon-0.3.7.orig/src/themes/standard/theme.c notification-daemon-0.3.7/src/themes/standard/theme.c
70--- notification-daemon-0.3.7.orig/src/themes/standard/theme.c 2007-01-26 04:20:15.000000000 +0000
71+++ notification-daemon-0.3.7/src/themes/standard/theme.c 2008-01-18 11:34:58.000000000 +0000
72@@ -1,7 +1,6 @@
73 #include "config.h"
74
75 #include <gtk/gtk.h>
76-#include <libsexy/sexy-url-label.h>
77
78 typedef void (*ActionInvokedCb)(GtkWindow *nw, const char *key);
79 typedef void (*UrlClickedCb)(GtkWindow *nw, const char *url);
80@@ -799,7 +798,7 @@
81 gtk_widget_show(vbox);
82 gtk_box_pack_start(GTK_BOX(windata->content_hbox), vbox, TRUE, TRUE, 0);
83
84- windata->body_label = sexy_url_label_new();
85+ windata->body_label = gtk_label_new(NULL);
86 gtk_box_pack_start(GTK_BOX(vbox), windata->body_label, TRUE, TRUE, 0);
87 gtk_misc_set_alignment(GTK_MISC(windata->body_label), 0, 0);
88 gtk_label_set_line_wrap(GTK_LABEL(windata->body_label), TRUE);
89@@ -874,7 +873,7 @@
90 gtk_label_set_markup(GTK_LABEL(windata->summary_label), str);
91 g_free(str);
92
93- sexy_url_label_set_markup(SEXY_URL_LABEL(windata->body_label), body);
94+ gtk_label_set_markup(GTK_LABEL(windata->body_label), body);
95
96 if (body == NULL || *body == '\0')
97 gtk_widget_hide(windata->body_label);
98Only in notification-daemon-0.3.7/src/themes/standard: theme.c~
diff --git a/meta-extras/packages/notification-daemon/notification-daemon_0.3.7.bb b/meta-extras/packages/notification-daemon/notification-daemon_0.3.7.bb
new file mode 100644
index 0000000000..f443e307c9
--- /dev/null
+++ b/meta-extras/packages/notification-daemon/notification-daemon_0.3.7.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "A dbus service that listens to desktop notification requests and displays them"
2HOMEPAGE = "http://www.galago-project.org/"
3SECTION = "x11"
4LICENSE = "GPL"
5DEPENDS = "dbus gtk+ gconf"
6
7SRC_URI = "http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.gz \
8 file://no-wnck-sexy.patch;patch=1"
9
10EXTRA_OECONF = "--disable-binreloc"
11
12inherit autotools pkgconfig
13
14FILES_${PN} = "\
15 ${libexecdir}/notification-daemon \
16 ${datadir}/dbus-1/services/ \
17 ${libdir}/notification-daemon-1.0/engines/*.so \
18 ${sysconfdir}/gconf/schemas/notification-daemon.schemas \
19"
20
21FILES_${PN}-dbg += "${libexecdir}/.debug ${libdir}/notification-daemon-1.0/engines/.debug"