summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRichard Purdie <richard@ted.(none)>2009-01-18 13:06:29 +0000
committerRichard Purdie <richard@ted.(none)>2009-01-18 13:06:29 +0000
commit4cdb6114facdf78a50ef931688732a2fcbb52416 (patch)
treee8f1d0d2bf86b4df70a00034c68788d524139c10 /meta-extras
parente9ee1e5ceffd9b553a3892b88ae466a71abe5a74 (diff)
downloadpoky-4cdb6114facdf78a50ef931688732a2fcbb52416.tar.gz
Drop sqlite3 from meta-extras
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch92
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch67
-rw-r--r--meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch25
-rw-r--r--meta-extras/packages/sqlite/sqlite3.inc44
-rw-r--r--meta-extras/packages/sqlite/sqlite3_3.3.7.bb2
5 files changed, 0 insertions, 230 deletions
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch
deleted file mode 100644
index 31d4f0d162..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch
+++ /dev/null
@@ -1,92 +0,0 @@
1--- sqlite-3.3.7/configure.ac.orig 2006-08-21 00:20:50.000000000 +0200
2+++ sqlite-3.3.7/configure.ac 2006-08-21 00:22:35.000000000 +0200
3@@ -187,10 +187,11 @@
4 default_build_cflags="-g"
5 if test "$config_BUILD_CC" = ""; then
6 AC_PROG_CC
7- if test "$cross_compiling" = "yes"; then
8- AC_MSG_ERROR([unable to find a compiler for building build tools])
9- fi
10- BUILD_CC=$CC
11+# if test "$cross_compiling" = "yes"; then
12+# AC_MSG_ERROR([unable to find a compiler for building build tools])
13+# fi
14+# BUILD_CC=$CC
15+BUILD_CC=gcc
16 default_build_cflags=$CFLAGS
17 else
18 BUILD_CC=$config_BUILD_CC
19@@ -238,6 +239,12 @@
20 TARGET_LINK=$config_TARGET_LINK
21 fi
22 AC_MSG_RESULT($TARGET_LINK)
23+if test "$config_TARGET_LFLAGS" != ""; then
24+ TARGET_LFLAGS=$config_TARGET_LFLAGS
25+ else
26+ TARGET_LFLAGS=$BUILD_LFLAGS
27+ fi
28+AC_MSG_RESULT($TARGET_LFLAGS)
29 AC_MSG_CHECKING([switches on the target compiler])
30 if test "$config_TARGET_TFLAGS" != ""; then
31 TARGET_TFLAGS=$config_TARGET_TFLAGS
32@@ -592,15 +599,7 @@
33 # Figure out what C libraries are required to compile programs
34 # that use "readline()" library.
35 #
36-if test "$config_TARGET_READLINE_LIBS" != ""; then
37- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
38-else
39- CC=$TARGET_CC
40- LIBS=""
41- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
42- AC_CHECK_LIB([readline], [readline])
43- TARGET_READLINE_LIBS="$LIBS"
44-fi
45+TARGET_READLINE_LIBS="-lreadline"
46 AC_SUBST(TARGET_READLINE_LIBS)
47
48 ##########
49@@ -615,41 +614,8 @@
50 ##########
51 # Figure out where to get the READLINE header files.
52 #
53-AC_MSG_CHECKING([readline header files])
54-found=no
55-if test "$config_TARGET_READLINE_INC" != ""; then
56- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
57- found=yes
58-fi
59-if test "$found" = "yes"; then
60- AC_MSG_RESULT($TARGET_READLINE_INC)
61-else
62- AC_MSG_RESULT(not specified: still searching...)
63- AC_CHECK_HEADER(readline.h, [found=yes])
64-fi
65-if test "$found" = "no"; then
66- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
67- AC_CHECK_FILE($dir/include/readline.h, found=yes)
68- if test "$found" = "yes"; then
69- TARGET_READLINE_INC="-I$dir/include"
70- break
71- fi
72- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
73- if test "$found" = "yes"; then
74- TARGET_READLINE_INC="-I$dir/include/readline"
75- break
76- fi
77- done
78-fi
79-if test "$found" = "yes"; then
80- if test "$TARGET_READLINE_LIBS" = ""; then
81- TARGET_HAVE_READLINE=0
82- else
83- TARGET_HAVE_READLINE=1
84- fi
85-else
86- TARGET_HAVE_READLINE=0
87-fi
88+TARGET_READLINE_INC=""
89+TARGET_HAVE_READLINE=1
90 AC_SUBST(TARGET_READLINE_INC)
91 AC_SUBST(TARGET_HAVE_READLINE)
92
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch
deleted file mode 100644
index ee5105ffff..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1--- sqlite-3.3.7/Makefile.in.orig 2006-08-20 23:05:36.000000000 +0200
2+++ sqlite-3.3.7/Makefile.in 2006-08-20 23:42:49.000000000 +0200
3@@ -31,6 +31,10 @@
4 #
5 TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
6
7+# OE overrides
8+#
9+TARGET_LFLAGS = @TARGET_LFLAGS@
10+
11 # Define -DNDEBUG to compile without debugging (i.e., for production usage)
12 # Omitting the define will cause extra debugging code to be inserted and
13 # includes extra comments when "EXPLAIN stmt" is used.
14@@ -257,17 +261,17 @@
15 | $(NAWK) '{print $$5,$$6}' >last_change
16
17 libsqlite3.la: $(LIBOBJ)
18- $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
19+ $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
20 ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
21
22 libtclsqlite3.la: tclsqlite.lo libsqlite3.la
23 $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
24- $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
25+ $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
26 -rpath $(libdir)/sqlite \
27 -version-info "8:6:8"
28
29 sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
30- $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
31+ $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
32 -o $@ $(TOP)/src/shell.c libsqlite3.la \
33 $(LIBREADLINE) $(TLIBS)
34
35@@ -456,12 +460,12 @@
36
37 tclsqlite3: tclsqlite-shell.lo libsqlite3.la
38 $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
39- libsqlite3.la $(LIBTCL)
40+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
41
42 testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
43 $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 -DSQLITE_CRASH_TEST=1 \
44 $(TEMP_STORE) -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
45- libsqlite3.la $(LIBTCL)
46+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
47
48
49 fulltest: testfixture$(TEXE) sqlite3$(TEXE)
50@@ -471,7 +475,7 @@
51 ./testfixture $(TOP)/test/quick.test
52
53 sqlite3_analyzer$(TEXE): $(TOP)/src/tclsqlite.c libtclsqlite3.la \
54- $(TESTSRC) $(TOP)/tool/spaceanal.tcl
55+ $(TARGET_LFLAGS) $(TESTSRC) $(TOP)/tool/spaceanal.tcl
56 sed \
57 -e '/^#/d' \
58 -e 's,\\,\\\\,g' \
59@@ -481,7 +485,7 @@
60 $(TOP)/tool/spaceanal.tcl >spaceanal_tcl.h
61 $(LTLINK) -DTCLSH=2 -DSQLITE_TEST=1 $(TEMP_STORE)\
62 -o sqlite3_analyzer$(EXE) $(TESTSRC) $(TOP)/src/tclsqlite.c \
63- libtclsqlite3.la $(LIBTCL)
64+ libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
65
66 # Rules used to build documentation
67 #
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch
deleted file mode 100644
index ccf9993ed2..0000000000
--- a/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1Index: sqlite-3.2.1/Makefile.in
2===================================================================
3--- sqlite-3.2.1.orig/Makefile.in 2005-03-23 17:09:39.000000000 +0100
4+++ sqlite-3.2.1/Makefile.in 2005-04-25 23:11:20.000000000 +0200
5@@ -15,7 +15,10 @@
6 # The toplevel directory of the source tree. This is the directory
7 # that contains this "Makefile.in" and the "configure.in" script.
8 #
9-TOP = @srcdir@
10+TOP = $(srcdir)
11+srcdir = @srcdir@
12+top_srcdir = @top_srcdir@
13+top_builddir = .
14
15 # C Compiler and options for use in building executables that
16 # will run on the platform that is doing the build.
17@@ -96,7 +99,7 @@
18 exec_prefix = @exec_prefix@
19 libdir = @libdir@
20 INSTALL = @INSTALL@
21-LIBTOOL = ./libtool
22+LIBTOOL = @LIBTOOL@
23 ALLOWRELEASE = @ALLOWRELEASE@
24
25 # libtool compile/link/install
diff --git a/meta-extras/packages/sqlite/sqlite3.inc b/meta-extras/packages/sqlite/sqlite3.inc
deleted file mode 100644
index 01290c2e41..0000000000
--- a/meta-extras/packages/sqlite/sqlite3.inc
+++ /dev/null
@@ -1,44 +0,0 @@
1DESCRIPTION = "An Embeddable SQL Database Engine"
2SECTION = "libs"
3PRIORITY = "optional"
4DEPENDS = "readline ncurses"
5LICENSE = "PD"
6
7SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
8 file://cross-compile.patch;patch=1 \
9 file://libtool.patch;patch=1 \
10 file://ldflags.patch;patch=1"
11S = "${WORKDIR}/sqlite-${PV}"
12
13inherit autotools pkgconfig
14
15EXTRA_OECONF = "--disable-tcl --enable-shared \
16 --enable-threadsafe"
17export config_BUILD_CC = "${BUILD_CC}"
18export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
19export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
20export config_TARGET_CC = "${CC}"
21export config_TARGET_LINK = "${CCLD}"
22export config_TARGET_CFLAGS = "${CFLAGS}"
23export config_TARGET_LFLAGS = "${LDFLAGS}"
24
25do_compile_prepend() {
26 oe_runmake sqlite3.h
27 install -m 0644 sqlite3.h ${STAGING_INCDIR}
28}
29
30do_stage() {
31 oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
32}
33
34#do_install() {
35# oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
36#}
37
38PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3 sqlite3-dbg"
39FILES_sqlite3 = "${bindir}/*"
40FILES_libsqlite = "${libdir}/*.so.*"
41FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
42 ${libdir}/pkgconfig ${includedir}"
43FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}"
44AUTO_LIBNAME_PKGS = "libsqlite"
diff --git a/meta-extras/packages/sqlite/sqlite3_3.3.7.bb b/meta-extras/packages/sqlite/sqlite3_3.3.7.bb
deleted file mode 100644
index d21fb6ad3e..0000000000
--- a/meta-extras/packages/sqlite/sqlite3_3.3.7.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1require sqlite3.inc
2PR = "r2"