summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:17 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:17 +0000
commited327197a7e68e72f8d9be9a3e970962c8eea35b (patch)
tree36ee2da3dd70df7e9c1ca9b3dedbd853daf79326 /meta-extras
parent59470e1d06a4c2e44382c233ae98cf6f05b7912c (diff)
downloadpoky-ed327197a7e68e72f8d9be9a3e970962c8eea35b.tar.gz
flumotion: added 0.4.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1912 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch68
-rw-r--r--meta-extras/packages/flumotion/flumotion/python-path.patch25
-rw-r--r--meta-extras/packages/flumotion/flumotion_0.4.1.bb30
3 files changed, 123 insertions, 0 deletions
diff --git a/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch b/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch
new file mode 100644
index 0000000000..08503c82e0
--- /dev/null
+++ b/meta-extras/packages/flumotion/flumotion/no-check-for-python-stuff.patch
@@ -0,0 +1,68 @@
1Index: flumotion-0.4.1/configure.ac
2===================================================================
3--- flumotion-0.4.1.orig/configure.ac 2007-03-05 17:16:48.121264330 +0100
4+++ flumotion-0.4.1/configure.ac 2007-03-05 17:20:40.343837320 +0100
5@@ -73,13 +73,6 @@
6 AC_MSG_ERROR([PyGTK 2.5.2 contains known bugs, please install other version])
7 fi
8
9-if test "x$DISPLAY" != "x"; then
10- AS_PYTHON_IMPORT([gtk.glade],,
11- AC_MSG_ERROR([You need to have python libglade bindings installed]))
12-else
13- AC_MSG_NOTICE([Not trying to import gtk.glade because DISPLAY is unset])
14-fi
15-
16 if test $GST_010_SUPPORTED = "no"; then
17 AC_MSG_ERROR([No appropriate version of PyGTK installed. Correct the above
18 errors and try again.])
19@@ -94,16 +87,6 @@
20 [AC_MSG_RESULT([$PYGST_010_PKG_ERRORS])
21 GST_010_SUPPORTED=no])
22
23- if test $GST_010_SUPPORTED = "yes"; then
24- saved_PYTHONPATH=$PYTHONPATH
25- export PYTHONPATH=$PYGST_010_DIR:$PYTHONPATH
26- AS_PYTHON_IMPORT([gst],,
27- [AC_MSG_NOTICE([Unable to import gst-python 0.10 -- check your PYTHONPATH?])
28- GST_010_SUPPORTED=no],
29- [import pygst; pygst.require('0.10')],
30- [assert gst.pygst_version[[1]] == 10 or (gst.pygst_version[[1]] == 9 and gst.pygst_version[[2]] >= 7)])
31-
32- fi
33 fi
34
35 if test $GST_010_SUPPORTED = "no"; then
36@@ -158,32 +141,7 @@
37 AC_CHECK_PROG(PYCHECKER, pychecker, yes, no)
38 AM_CONDITIONAL(HAVE_PYCHECKER, test "x$PYCHECKER" = "xyes")
39
40-dnl check for Twisted
41-AS_PYTHON_IMPORT(twisted,
42- [
43- AC_MSG_CHECKING(for Twisted >= 2.0.1)
44- prog="
45-import sys
46-import twisted.copyright
47-minver = '2.0.1'
48-if twisted.copyright.version < minver:
49- sys.exit(1)
50-sys.exit(0)
51-"
52- if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
53- then
54- AC_MSG_RESULT(found)
55- else
56- AC_MSG_RESULT(too old)
57- AC_MSG_ERROR([You need at least version 2.0.1 of Twisted])
58- fi
59- ]
60- ,
61- AC_MSG_ERROR([You need at least version 2.0.1 of Twisted])
62-)
63
64-TWISTED_MODULE([twisted.names])
65-TWISTED_MODULE([twisted.web])
66
67 AC_CONFIG_FILES([env], [chmod +x env])
68 AC_CONFIG_FILES([bin/flumotion], [chmod +x bin/flumotion])
diff --git a/meta-extras/packages/flumotion/flumotion/python-path.patch b/meta-extras/packages/flumotion/flumotion/python-path.patch
new file mode 100644
index 0000000000..377994e729
--- /dev/null
+++ b/meta-extras/packages/flumotion/flumotion/python-path.patch
@@ -0,0 +1,25 @@
1Index: flumotion-0.3.1/common/as-python.m4
2===================================================================
3--- flumotion-0.3.1.orig/common/as-python.m4 2007-03-02 15:26:46.704717964 +0100
4+++ flumotion-0.3.1/common/as-python.m4 2007-03-02 15:27:28.601326374 +0100
5@@ -199,6 +199,12 @@
6 AC_MSG_CHECKING(for headers required to compile python extensions)
7
8 dnl deduce PYTHON_INCLUDES
9+
10+ AC_ARG_WITH(python-includes,
11+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
12+ if test x$py_exec_prefix != x; then
13+ PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
14+ else
15 py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
16 py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
17 PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
18@@ -206,6 +212,7 @@
19 if test "$py_prefix" != "$py_exec_prefix"; then
20 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
21 fi
22+ fi
23 AC_SUBST(PYTHON_INCLUDES)
24
25 dnl check if the headers exist:
diff --git a/meta-extras/packages/flumotion/flumotion_0.4.1.bb b/meta-extras/packages/flumotion/flumotion_0.4.1.bb
new file mode 100644
index 0000000000..42474e011b
--- /dev/null
+++ b/meta-extras/packages/flumotion/flumotion_0.4.1.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Fluendo Streaming Server"
2LICENSE = "GPL"
3DEPENDS = "gstreamer python-gst twisted python-pygtk2"
4RDEPENDS = "python-twisted-core python-twisted-web python-core python-gst"
5RDEPENDS_${PN}-gui = "${PN} python-pygtk2"
6PR = "r3"
7
8SRC_URI = "http://www.flumotion.net/src/flumotion/flumotion-${PV}.tar.bz2 \
9 file://python-path.patch;patch=1 \
10 file://no-check-for-python-stuff.patch;patch=1"
11
12inherit autotools distutils-base pkgconfig
13
14export EPYDOC = "no"
15
16EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
17
18PACKAGES =+ "flumotion-gui"
19
20FILES_${PN} = "${bindir} ${sbindir} ${libdir}/flumotion"
21FILES_${PN}-dev += "${libdir}/pkgconfig"
22FILES_${PN}-gui = "${bindir}/flumotion-admin ${bindir}/flumotion-tester \
23 ${libdir}/flumotion/python/flumotion/admin/gtk \
24 ${libdir}/flumotion/python/flumotion/component/*/admin_gtk* \
25 ${libdir}/flumotion/python/flumotion/component/*/*/admin_gtk* \
26 ${libdir}/flumotion/python/flumotion/extern \
27 ${libdir}/flumotion/python/flumotion/manager \
28 ${libdir}/flumotion/python/flumotion/ui \
29 ${libdir}/flumotion/python/flumotion/wizard \
30 ${datadir}/pixmaps ${datadir}/flumotion ${datadir}/applications"