summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:32 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-06-11 12:12:32 +0000
commitead8b803b3c7f2fa03caf5af0e3223151a812b74 (patch)
treed9f6d99687dfe7b2438b856e60e3cc7659d752f9 /meta-extras
parented327197a7e68e72f8d9be9a3e970962c8eea35b (diff)
downloadpoky-ead8b803b3c7f2fa03caf5af0e3223151a812b74.tar.gz
zope: added 3.3.1
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1913 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/zope/zope_3.3.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-extras/packages/zope/zope_3.3.1.bb b/meta-extras/packages/zope/zope_3.3.1.bb
new file mode 100644
index 0000000000..4c4664904c
--- /dev/null
+++ b/meta-extras/packages/zope/zope_3.3.1.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "A full fledged pluggable content management system with integrated web server and much more."
2SECTION = "console/network"
3PRIORITY = "optional"
4DEPENDS = "python"
5RDEPENDS = "python-core python-shell"
6LICENSE = "ZPL"
7PR = "r1"
8
9SRC_URI = "http://www.zope.org/Products/Zope3/${PV}/Zope-${PV}.tgz"
10
11S = "${WORKDIR}/Zope-${PV}"
12
13do_configure() {
14 ./configure --with-python=${STAGING_BINDIR_NATIVE}/python --prefix=${prefix} --force
15}
16
17do_compile() {
18 oe_runmake HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
19}
20
21do_install() {
22 oe_runmake install prefix=${D}${prefix} HOST_SYS=${HOST_SYS} BUILD_SYS=${BUILD_SYS}
23}
24
25PACKAGES =+ "python-zopeinterface"
26
27FILES_${PN} = "${prefix}"
28FILES_${PN}_doc = "${prefix}/doc"
29FILES_python-zopeinterface = "${libdir}/python/zope/interface/*.* ${libdir}/python/zope/interface/common"