summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-03-02 13:36:58 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-03-02 13:36:58 +0000
commitdbfd391485a414700864ad98ca38deaf64d26145 (patch)
tree2873abc1c17a194591a035351993eea6620bb903 /meta-extras
parent2d9ec4cd5ca9ee2224ef96f169e1e3e3fd1cc70e (diff)
downloadpoky-dbfd391485a414700864ad98ca38deaf64d26145.tar.gz
python-gst: added 0.10.7 version of Python bindings to Gstreamer + patch to get it build on 64bit host
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1320 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/python/python-gst/python-path.patch24
-rw-r--r--meta-extras/packages/python/python-gst_0.10.7.bb21
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-gst/python-path.patch b/meta-extras/packages/python/python-gst/python-path.patch
new file mode 100644
index 0000000000..465d5b180a
--- /dev/null
+++ b/meta-extras/packages/python/python-gst/python-path.patch
@@ -0,0 +1,24 @@
1Index: gst-python-0.10.7/acinclude.m4
2===================================================================
3--- gst-python-0.10.7.orig/acinclude.m4 2007-03-02 14:10:28.652128590 +0100
4+++ gst-python-0.10.7/acinclude.m4 2007-03-02 14:41:00.106728708 +0100
5@@ -43,12 +43,19 @@
6 [AC_REQUIRE([AM_PATH_PYTHON])
7 AC_MSG_CHECKING(for headers required to compile python extensions)
8 dnl deduce PYTHON_INCLUDES
9+
10+AC_ARG_WITH(python-includes,
11+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
12+if test x$py_exec_prefix != x; then
13+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
14+else
15 py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
16 py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
17 PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
18 if test "$py_prefix" != "$py_exec_prefix"; then
19 PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
20 fi
21+fi
22 AC_SUBST(PYTHON_INCLUDES)
23 dnl check if the headers exist:
24 save_CPPFLAGS="$CPPFLAGS"
diff --git a/meta-extras/packages/python/python-gst_0.10.7.bb b/meta-extras/packages/python/python-gst_0.10.7.bb
new file mode 100644
index 0000000000..bf65595be9
--- /dev/null
+++ b/meta-extras/packages/python/python-gst_0.10.7.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Python Gstreamer bindings"
2SECTION = "devel/python"
3LICENSE = "LGPL"
4DEPENDS = "gstreamer"
5
6SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
7 file://python-path.patch;patch=1"
8
9S = "${WORKDIR}/gst-python-${PV}"
10
11inherit autotools distutils-base pkgconfig
12
13EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
14
15do_configure_prepend() {
16 install -m 0644 ${S}/common/m4/*.m4 ${S}/m4/
17}
18
19do_stage() {
20 autotools_stage_all
21}