summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-07-09 13:24:31 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-07-09 13:24:31 +0000
commit5ff8d3eb52c2cfce75a15108567546820d651597 (patch)
tree9f4f65ec30042d198d5c27d1038b77ca38873855 /meta-extras
parentea9a2560dffc03b8dbea5c0fd27651970a14eaef (diff)
downloadpoky-5ff8d3eb52c2cfce75a15108567546820d651597.tar.gz
libxosd: added version from OE + fixed packaging
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@2131 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/libxosd/files/autofoo.patch116
-rw-r--r--meta-extras/packages/libxosd/files/use-sane-default-font.patch13
-rw-r--r--meta-extras/packages/libxosd/libxosd_svn.bb24
3 files changed, 153 insertions, 0 deletions
diff --git a/meta-extras/packages/libxosd/files/autofoo.patch b/meta-extras/packages/libxosd/files/autofoo.patch
new file mode 100644
index 0000000000..e26f15e9e5
--- /dev/null
+++ b/meta-extras/packages/libxosd/files/autofoo.patch
@@ -0,0 +1,116 @@
1Index: current/configure.ac
2===================================================================
3--- current.orig/configure.ac 2007-06-14 09:06:04.000000000 +0000
4+++ current/configure.ac 2007-06-14 09:14:37.000000000 +0000
5@@ -52,8 +52,6 @@
6 CFLAGS="$CFLAGS $X_CFLAGS -Wall"
7
8 dnl Checks for libraries.
9-AM_PATH_GTK(1.2.2,,
10- AC_MSG_WARN([*** GTK+ >= 1.2.2 not found ***]))
11 AC_CHECK_LIB(X11, XInitThreads,,
12 AC_MSG_ERROR([*** X11 not threadsafe ***]))
13 AC_CHECK_LIB(Xext, XShapeQueryExtension,,
14@@ -107,63 +105,6 @@
15 AC_MSG_WARN("beep media player not found")
16 fi
17
18-dnl Check for xmms
19-AM_PATH_XMMS(1.2.7,,
20- AC_MSG_WARN("xmms plugins can not be built"))
21-dnl Override where to place libxmms_xosd.so
22-AC_ARG_WITH([plugindir],
23- AC_HELP_STRING([--with-plugindir=DIR],
24- [Set the xmms plugin directory]),
25- [XMMS_PLUGIN_DIR="$withval"],
26- [XMMS_PLUGIN_DIR="$XMMS_GENERAL_PLUGIN_DIR"])
27-
28-dnl Check for gdk-pixbuf
29-AM_PATH_GDK_PIXBUF(0.22.0,,
30- AC_MSG_WARN("new xmms plugin can not be built"))
31-dnl Override where to place pixmaps for libxmms_xosd.so
32-AC_ARG_WITH([pixmapdir],
33- AC_HELP_STRING([--with-pixmapdir=DIR],
34- [Set the directory for xmms plugin pixmaps]),
35- [XMMS_PIXMAPDIR="$withval"],
36- [XMMS_PIXMAPDIR="${datadir}/xosd"])
37-AC_SUBST(XMMS_PIXMAPDIR)
38-
39-dnl NEW plugin
40-AC_ARG_ENABLE([new-plugin],
41- AC_HELP_STRING([--disable-new-plugin],
42- [Disable new xmms plugin (enabled by default)]),
43- [enable_new_plugin="$enableval"],
44- [enable_new_plugin="yes"])
45-AC_MSG_CHECKING([whether new xmms plugin was requested])
46-AC_MSG_RESULT($enable_new_plugin)
47-AM_CONDITIONAL([BUILD_NEW_PLUGIN],
48- [test x"$enable_new_plugin" = "xyes" -a x"$no_xmms" != "xyes" -a x"$no_gdk_pixbuf" != "xyes"])
49-
50-
51-dnl Check for Beep Media player
52-AC_ARG_ENABLE([beep_media_player_plugin],
53- AC_HELP_STRING([--enable-beep_media_player_plugin],
54- [Enable beep media plugin (enabled by default)]),
55- [beep_media_player_plugin="$enableval"],
56- [beep_media_player_plugin="yes"])
57-AC_MSG_CHECKING([whether beep media plugin was requested])
58-AC_MSG_RESULT($beep_media_player_plugin)
59-
60-AM_CONDITIONAL([BUILD_BEEP_MEDIA_PLUGIN],
61- [test x"$beep_media_player_plugin" = "xyes" -a x"$no_bmp" == "xyes"])
62-
63-dnl OLD plugin
64-AC_ARG_ENABLE([old-plugin],
65- AC_HELP_STRING([--enable-old-plugin],
66- [Enable old xmms plugin (disabled by default)]),
67- [enable_old_plugin="$enableval"],
68- [enable_old_plugin="no"])
69-AC_MSG_CHECKING([whether old xmms plugin was requested])
70-AC_MSG_RESULT($enable_old_plugin)
71-AM_CONDITIONAL([BUILD_OLD_PLUGIN],
72- [test x"$enable_old_plugin" = "xyes" -a x"$no_xmms" != "xyes"])
73-
74-
75 dnl Define XOSD_VERSION
76 AC_DEFINE_UNQUOTED(XOSD_VERSION, "${VERSION}")
77
78@@ -174,8 +115,6 @@
79 Makefile
80 src/Makefile
81 src/libxosd/Makefile
82-src/xmms_plugin/Makefile
83-src/bmp_plugin/Makefile
84 macros/Makefile
85 man/Makefile
86 pixmaps/Makefile
87Index: current/src/Makefile.am
88===================================================================
89--- current.orig/src/Makefile.am 2007-06-14 09:06:04.000000000 +0000
90+++ current/src/Makefile.am 2007-06-14 09:14:37.000000000 +0000
91@@ -10,6 +10,4 @@
92
93 include_HEADERS = xosd.h
94
95-AM_CFLAGS = ${GTK_CFLAGS}
96-
97-SUBDIRS=libxosd xmms_plugin bmp_plugin
98+SUBDIRS=libxosd
99Index: current/Makefile.am
100===================================================================
101--- current.orig/Makefile.am 2007-06-14 09:06:04.000000000 +0000
102+++ current/Makefile.am 2007-06-14 09:16:15.000000000 +0000
103@@ -1,11 +1,5 @@
104-if BUILD_NEW_PLUGIN
105- NEW_SUB = pixmaps
106-endif
107-if BUILD_BEEP_MEDIA_PLUGIN
108- NEW_SUB = pixmaps
109-endif
110-SUBDIRS = macros man $(NEW_SUB) src script
111-DIST_SUBDIRS = macros man pixmaps src script
112+SUBDIRS = macros man src script
113+DIST_SUBDIRS = macros man src script
114
115 DISTCLEANFILES = libtool-disable-static
116
diff --git a/meta-extras/packages/libxosd/files/use-sane-default-font.patch b/meta-extras/packages/libxosd/files/use-sane-default-font.patch
new file mode 100644
index 0000000000..0ede1351e2
--- /dev/null
+++ b/meta-extras/packages/libxosd/files/use-sane-default-font.patch
@@ -0,0 +1,13 @@
1Index: current/src/libxosd/xosd.c
2===================================================================
3--- current.orig/src/libxosd/xosd.c 2007-06-16 19:37:48.000000000 +0000
4+++ current/src/libxosd/xosd.c 2007-06-17 05:00:47.000000000 +0000
5@@ -26,7 +26,7 @@
6 #define XOFFSET 10
7
8 const char * const osd_default_font =
9- "-misc-fixed-medium-r-semicondensed--*-*-*-*-c-*-*-*";
10+ "fixed";
11 #if 0
12 "-adobe-helvetica-bold-r-*-*-10-*";
13 #endif
diff --git a/meta-extras/packages/libxosd/libxosd_svn.bb b/meta-extras/packages/libxosd/libxosd_svn.bb
new file mode 100644
index 0000000000..7dfd05d5d9
--- /dev/null
+++ b/meta-extras/packages/libxosd/libxosd_svn.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "A library for displaying a TV-like on-screen display in X."
2SECTION = "libs/x11"
3DEPENDS = "virtual/libx11 libxext"
4LICENSE = "LGPL"
5PV = "2.2.15+svn${SRCDATE}"
6PR = "r5"
7
8SRC_URI = "svn://libxosd.svn.sourceforge.net/svnroot/libxosd/source;module=current;proto=https \
9 file://autofoo.patch;patch=1 \
10 file://use-sane-default-font.patch;patch=1"
11
12S = "${WORKDIR}/current"
13
14inherit autotools binconfig
15
16do_stage() {
17 autotools_stage_all
18}
19
20PACKAGES =+ "${PN}-examples-dbg ${PN}-examples"
21FILES_${PN}-examples = "${bindir}/osd_cat"
22FILES_${PN}-examples-dbg = "${bindir}/.debug/"
23FILES_${PN}-dev += "${bindir}/xosd-config"
24FILES_${PN} = "${libdir}/libxosd.so.*"