summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-29 14:22:10 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-29 15:20:33 +0100
commit5dab2c9aa7ef81115fb3e0d5092cf2f12a23a5d5 (patch)
tree31f9f4f5b01cf597e2ebfe1609c8b70cea58bec5 /meta-extras
parent6418d0492a60ed37d13e1060c2e8c09cd127c450 (diff)
downloadpoky-5dab2c9aa7ef81115fb3e0d5092cf2f12a23a5d5.tar.gz
Move some machines which no longer build to meta-extras
om-gta01, om-gta02, nokia700, nokia800 and mx31litekit no longer build and we don't have a maintainer for them so move them to meta-extras Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/conf/machine/mx31litekit.conf14
-rw-r--r--meta-extras/conf/machine/nokia770.conf35
-rw-r--r--meta-extras/conf/machine/nokia800.conf30
-rw-r--r--meta-extras/conf/machine/om-gta01.conf48
-rw-r--r--meta-extras/conf/machine/om-gta02.conf49
5 files changed, 176 insertions, 0 deletions
diff --git a/meta-extras/conf/machine/mx31litekit.conf b/meta-extras/conf/machine/mx31litekit.conf
new file mode 100644
index 0000000000..2dc2883759
--- /dev/null
+++ b/meta-extras/conf/machine/mx31litekit.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: imx31 Lite Kit
3#@DESCRIPTION: Machine configuration for the imx31 based Lite Kit
4TARGET_ARCH = "arm"
5PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6"
6
7PREFERRED_PROVIDER_virtual/kernel = "linux-mx31"
8
9MACHINE_FEATURES = "kernel26 apm alsa bluetooth irda screen touchscreen"
10
11IMAGE_FSTYPES ?= "tar.gz"
12SERIAL_CONSOLE = "-L 115200 ttymxc0"
13
14require conf/machine/include/tune-arm1136jf-s.inc
diff --git a/meta-extras/conf/machine/nokia770.conf b/meta-extras/conf/machine/nokia770.conf
new file mode 100644
index 0000000000..c8b4c3c912
--- /dev/null
+++ b/meta-extras/conf/machine/nokia770.conf
@@ -0,0 +1,35 @@
1#@TYPE: Machine
2#@NAME: Nokia 770 internet tablet
3#@DESCRIPTION: Machine configuration for the Nokia 770, an omap 1710 based tablet
4TARGET_ARCH = "arm"
5PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te"
6
7PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-xomap"
8PREFERRED_PROVIDER_virtual/bootloader = ""
9
10XSERVER = "xserver-kdrive-xomap"
11
12# 800x480 is big enough for me
13GUI_MACHINE_CLASS = "bigscreen"
14
15require conf/machine/include/tune-arm926ejs.inc
16
17#size of the root partition (yes, it is 123 MB)
18ROOT_FLASH_SIZE = "123"
19EXTRA_IMAGECMD_jffs2_nokia770 = "--pad --little-endian --eraseblock=0x20000 -n"
20
21IMAGE_FSTYPES ?= "jffs2"
22
23# serial console port on devboard rev. B3
24SERIAL_CONSOLE = "115200 ttyS0"
25
26PREFERRED_PROVIDER_virtual/kernel = "linux-nokia800"
27
28#use this if you are using the nokia initfs
29ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
30
31MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost screen vfat"
32MACHINE_EXTRA_RDEPENDS = "usbinit"
33MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "nokia770-init"
34
35KERNEL_IMAGE_MAXSIZE = "2097152"
diff --git a/meta-extras/conf/machine/nokia800.conf b/meta-extras/conf/machine/nokia800.conf
new file mode 100644
index 0000000000..fb2cd02b03
--- /dev/null
+++ b/meta-extras/conf/machine/nokia800.conf
@@ -0,0 +1,30 @@
1#@TYPE: Machine
2#@NAME: Nokia 800/810 internet tablet
3#@DESCRIPTION: Machine configuration for the Nokia 800/810
4TARGET_ARCH = "arm"
5PACKAGE_EXTRA_ARCHS = "armv4 armv4t armv5te armv6"
6
7PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-xomap"
8XSERVER = "xserver-kdrive-xomap"
9
10GUI_MACHINE_CLASS = "bigscreen"
11
12require conf/machine/include/tune-arm1136jf-s.inc
13
14ROOT_FLASH_SIZE = "174"
15EXTRA_IMAGECMD_jffs2_nokia800 = "--pad --little-endian --eraseblock=0x20000 -n"
16
17IMAGE_FSTYPES ?= "jffs2"
18
19SERIAL_CONSOLE = "-L 115200 ttyS0"
20
21PREFERRED_PROVIDER_virtual/kernel = "linux-nokia800"
22
23#use this if you are using the nokia initfs
24ROOTFS_POSTPROCESS_COMMAND += " remove_init_link; "
25
26MACHINE_FEATURES = "kernel26 apm alsa bluetooth usbgadget usbhost vfat"
27MACHINE_EXTRA_RDEPENDS = "cx3110x usbinit"
28MACHINE_ESSENTIAL_EXTRA_RDEPENDS = "nokia770-init"
29
30KERNEL_IMAGE_MAXSIZE = "2097152"
diff --git a/meta-extras/conf/machine/om-gta01.conf b/meta-extras/conf/machine/om-gta01.conf
new file mode 100644
index 0000000000..f40457e226
--- /dev/null
+++ b/meta-extras/conf/machine/om-gta01.conf
@@ -0,0 +1,48 @@
1#-----------------------------------------------------------------------------
2#@TYPE: Machine
3#@NAME: FIC GTA01 (Neo1973)
4#@DESCRIPTION: Machine configuration for the FIC Neo1973/1 GSM phone
5#-----------------------------------------------------------------------------
6
7TARGET_ARCH = "arm"
8MACHINE_CLASS = "neo1973"
9PACKAGE_EXTRA_ARCHS = "armv4t fic-gta01 ${MACHINE_CLASS}"
10
11PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
12UBOOT_ENTRYPOINT = "30008000"
13
14MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone vfat ext2"
15MACHINE_DISPLAY_WIDTH_PIXELS = "480"
16MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
17MACHINE_DISPLAY_ORIENTATION = "0"
18MACHINE_DISPLAY_PPI = "285"
19XSERVER = "xserver-kdrive-fbdev"
20
21MACHINE_EXTRA_RDEPENDS = "usbinit"
22# package machine specific modules
23MACHINE_EXTRA_RRECOMMENDS = "\
24 kernel-module-gta01-pm-bt \
25 kernel-module-gta01-pm-gps \
26 kernel-module-gta01-pm-gsm \
27 kernel-module-gta01kbd \
28 kernel-module-s3cmci \
29 kernel-module-snd-soc-neo1973-wm8753 \
30 kernel-module-snd-soc-smdk2440 \
31"
32
33# do not outcomment, we bypass the sysvinit.bb logic here -- see FIC GTA01 inittab
34#SERIAL_CONSOLE = "115200 ttySAC0"
35
36# used by some images
37ROOT_FLASH_SIZE = "60"
38
39# extra jffs2 tweaks
40IMAGE_FSTYPES ?= "jffs2"
41EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x4000 --pad -n"
42
43# build / upload tools
44#EXTRA_IMAGEDEPENDS += "dfu-util-native"
45
46# tune for S3C24x0
47include conf/machine/include/tune-arm920t.inc
48
diff --git a/meta-extras/conf/machine/om-gta02.conf b/meta-extras/conf/machine/om-gta02.conf
new file mode 100644
index 0000000000..55f4bec21d
--- /dev/null
+++ b/meta-extras/conf/machine/om-gta02.conf
@@ -0,0 +1,49 @@
1#-----------------------------------------------------------------------------
2#@TYPE: Machine
3#@NAME: FIC GTA02 (Neo1973)
4#@DESCRIPTION: Machine configuration for the FIC Neo1973/2 GSM phone
5#-----------------------------------------------------------------------------
6
7TARGET_ARCH = "arm"
8MACHINE_CLASS = "neo1973"
9PACKAGE_EXTRA_ARCHS = "armv4t fic-gta02 ${MACHINE_CLASS}"
10
11PREFERRED_PROVIDER_virtual/kernel = "linux-openmoko"
12PREFERRED_PROVIDER_virtual/xserver = "xserver-kdrive-glamo"
13UBOOT_ENTRYPOINT = "30008000"
14
15MACHINE_FEATURES = "kernel26 apm alsa bluetooth gps usbgadget usbhost phone wifi vfat ext2"
16MACHINE_DISPLAY_WIDTH_PIXELS = "480"
17MACHINE_DISPLAY_HEIGHT_PIXELS = "640"
18MACHINE_DISPLAY_ORIENTATION = "0"
19MACHINE_DISPLAY_PPI = "285"
20XSERVER = "xserver-kdrive-glamo xserver-kdrive-fbdev"
21
22# package machine specific modules
23MACHINE_EXTRA_RRECOMMENDS = "\
24 kernel-module-gta01-pm-bt \
25 kernel-module-gta01-pm-gps \
26 kernel-module-gta01-pm-gsm \
27 kernel-module-gta01kbd \
28 kernel-module-s3cmci \
29 kernel-module-snd-soc-neo1973-gta02-wm8753 \
30"
31
32SERIAL_CONSOLE = "115200 ttySAC2"
33
34# used by some images
35ROOT_FLASH_SIZE = "256"
36
37# extra jffs2 tweaks
38IMAGE_FSTYPES ?= "jffs2"
39EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 --pagesize=0x800 \
40 --no-cleanmarkers --pad -n ; sumtool --eraseblock=0x20000 --no-cleanmarkers \
41 --littleendian --pad \
42 -i ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2 \
43 -o ${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}.rootfs.jffs2.summary"
44
45# build / upload tools
46#EXTRA_IMAGEDEPENDS += "sjf2410-linux-native dfu-util-native"
47
48# tune for S3C24x0
49include conf/machine/include/tune-arm920t.inc