summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-08-09 11:53:13 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-13 13:36:00 +0100
commit1280503a59b24598b1d34931b6e02ed46bf25f66 (patch)
tree28cbd3a23d7e29a2df11a9cadd47b8efee2ead6c /meta-extras
parent858c0d930f49952f74b1f2cbd5cf9ad870019550 (diff)
downloadpoky-1280503a59b24598b1d34931b6e02ed46bf25f66.tar.gz
minicom: move from meta-extras to meta-lsb
Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/minicom/minicom-2.1/configure.patch25
-rw-r--r--meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch44
-rw-r--r--meta-extras/packages/minicom/minicom_2.1.bb12
3 files changed, 0 insertions, 81 deletions
diff --git a/meta-extras/packages/minicom/minicom-2.1/configure.patch b/meta-extras/packages/minicom/minicom-2.1/configure.patch
deleted file mode 100644
index 4db47fb3d8..0000000000
--- a/meta-extras/packages/minicom/minicom-2.1/configure.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1Index: minicom-2.1/configure.in
2===================================================================
3--- minicom-2.1.orig/configure.in 2003-04-29 21:08:25.000000000 +0000
4+++ minicom-2.1/configure.in 2005-07-04 19:03:32.000000000 +0000
5@@ -231,9 +231,9 @@
6 AC_HEADER_STAT
7 AC_HEADER_TIME
8
9-AM_SYS_POSIX_TERMIOS
10+AC_SYS_POSIX_TERMIOS
11 AM_HEADER_TIOCGWINSZ_NEEDS_SYS_IOCTL
12-if test $am_cv_sys_posix_termios = yes; then
13+if test $ac_cv_sys_posix_termios = yes; then
14 AC_DEFINE(POSIX_TERMIOS)
15 fi
16
17@@ -253,7 +253,7 @@
18
19 dnl Checks for library functions.
20 AC_TYPE_SIGNAL
21-AM_FUNC_ERROR_AT_LINE
22+AC_FUNC_ERROR_AT_LINE
23 AC_FUNC_CLOSEDIR_VOID
24 AM_WITH_DMALLOC
25 AC_CHECK_FUNCS(getcwd getwd strerror strstr vsnprintf vprintf)
diff --git a/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch b/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch
deleted file mode 100644
index 5bd47bd354..0000000000
--- a/meta-extras/packages/minicom/minicom-2.1/gcc4-scope.patch
+++ /dev/null
@@ -1,44 +0,0 @@
1--- minicom-2.1/src/window.c.orig 2006-06-14 17:49:53.000000000 +0200
2+++ minicom-2.1/src/window.c 2006-06-14 17:50:14.000000000 +0200
3@@ -62,7 +62,7 @@
4 static char *CS, *SF, *SR, *VB, *BL;
5 static char *VE, *VI, *KS, *KE;
6 static char *CD, *CL, *IC, *DC;
7-static char *BC, *CR, *NL;
8+static char *mcBC, *CR, *NL;
9 #if ST_LINE
10 static char *TS, *FS, *DS;
11 #endif
12@@ -322,8 +322,8 @@
13 else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
14 outstr(NL);
15 #endif
16- else if (BC != CNULL && y == cury && x == curx - 1)
17- outstr(BC);
18+ else if (mcBC != CNULL && y == cury && x == curx - 1)
19+ outstr(mcBC);
20 else
21 outstr(tgoto(CM, x, y));
22 curx = x;
23@@ -1918,7 +1918,7 @@
24 CL = tgetstr("cl", &_tptr);
25 IC = tgetstr("ic", &_tptr);
26 DC = tgetstr("dc", &_tptr);
27- BC = tgetstr("bc", &_tptr);
28+ mcBC = tgetstr("bc", &_tptr);
29 CR = tgetstr("cr", &_tptr);
30 NL = tgetstr("nl", &_tptr);
31 AC = tgetstr("ac", &_tptr);
32@@ -1967,10 +1967,10 @@
33 _has_am = tgetflag("am");
34 _mv_standout = tgetflag("ms");
35 if (tgetflag("bs")) {
36- if (BC == CNULL) BC = "\b";
37+ if (mcBC == CNULL) mcBC = "\b";
38 }
39 else
40- BC = CNULL;
41+ mcBC = CNULL;
42
43 /* Special IBM box-drawing characters */
44 D_UL = 201;
diff --git a/meta-extras/packages/minicom/minicom_2.1.bb b/meta-extras/packages/minicom/minicom_2.1.bb
deleted file mode 100644
index c4a1c3018a..0000000000
--- a/meta-extras/packages/minicom/minicom_2.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
1SECTION = "console/network"
2DEPENDS = "ncurses"
3LICENSE = "GPL"
4SRC_URI = "http://alioth.debian.org/download.php/123/minicom-${PV}.tar.gz \
5 file://configure.patch;patch=1 \
6 file://gcc4-scope.patch;patch=1"
7
8inherit autotools gettext
9
10do_install() {
11 for d in doc extras man intl lib src; do make -C $d DESTDIR=${D} install; done
12}