summaryrefslogtreecommitdiffstats
path: root/meta-extras
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-01-19 16:05:31 +0000
committerRoss Burton <ross@openedhand.com>2007-01-19 16:05:31 +0000
commit1afa154d3e0ee7c80a4cac5db28f84c7d93954a5 (patch)
tree2f6925aab505d6ed6524a6f25ff11416d9306617 /meta-extras
parent4fb6a9e216b856cac62d6c05ce91f8a4b6fa97eb (diff)
downloadpoky-1afa154d3e0ee7c80a4cac5db28f84c7d93954a5.tar.gz
Add libnl, a dependency of network manager (from OE)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@1169 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras')
-rw-r--r--meta-extras/packages/libnl/files/local-includes.patch11
-rw-r--r--meta-extras/packages/libnl/libnl_1.0-pre6.bb18
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-extras/packages/libnl/files/local-includes.patch b/meta-extras/packages/libnl/files/local-includes.patch
new file mode 100644
index 0000000000..5af463004b
--- /dev/null
+++ b/meta-extras/packages/libnl/files/local-includes.patch
@@ -0,0 +1,11 @@
1--- libnl-1.0-pre6/Makefile.opts.in.orig 2006-08-24 14:57:42.000000000 +0200
2+++ libnl-1.0-pre6/Makefile.opts.in 2006-08-24 14:58:20.000000000 +0200
3@@ -10,7 +10,7 @@
4 #
5
6 CC := @CC@
7-CFLAGS := @CFLAGS@
8+CFLAGS := -I./include -I. -I../include @CFLAGS@
9 LDFLAGS := @LDFLAGS@
10 CPPFLAGS := @CPPFLAGS@
11 PACKAGE_NAME := @PACKAGE_NAME@
diff --git a/meta-extras/packages/libnl/libnl_1.0-pre6.bb b/meta-extras/packages/libnl/libnl_1.0-pre6.bb
new file mode 100644
index 0000000000..300222ca42
--- /dev/null
+++ b/meta-extras/packages/libnl/libnl_1.0-pre6.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
2SECTION = "libs/network"
3LICENSE = "LGPL"
4HOMEPAGE = "http://people.suug.ch/~tgr/libnl/"
5PRIORITY = "optional"
6PV = "0.99+1.0-pre6"
7
8inherit autotools pkgconfig
9
10SRC_URI= "http://people.suug.ch/~tgr/libnl/files/${PN}-1.0-pre6.tar.gz \
11 file://local-includes.patch;patch=1"
12
13S = "${WORKDIR}/${PN}-1.0-pre6"
14
15do_stage () {
16 autotools_stage_all prefix=${prefix}
17}
18