summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/yum/files
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta-extras/packages/yum/files
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta-extras/packages/yum/files')
-rw-r--r--meta-extras/packages/yum/files/98_yum1
-rw-r--r--meta-extras/packages/yum/files/extract-postinst.awk11
-rw-r--r--meta-extras/packages/yum/files/fix18
-rw-r--r--meta-extras/packages/yum/files/hacks.patch81
-rw-r--r--meta-extras/packages/yum/files/paths.patch106
-rw-r--r--meta-extras/packages/yum/files/paths2.patch35
-rwxr-xr-xmeta-extras/packages/yum/files/yum-install-recommends.py39
7 files changed, 291 insertions, 0 deletions
diff --git a/meta-extras/packages/yum/files/98_yum b/meta-extras/packages/yum/files/98_yum
new file mode 100644
index 0000000000..cb4047ad2b
--- /dev/null
+++ b/meta-extras/packages/yum/files/98_yum
@@ -0,0 +1 @@
d root root 0755 /var/cache/yum none
diff --git a/meta-extras/packages/yum/files/extract-postinst.awk b/meta-extras/packages/yum/files/extract-postinst.awk
new file mode 100644
index 0000000000..8f2836b32c
--- /dev/null
+++ b/meta-extras/packages/yum/files/extract-postinst.awk
@@ -0,0 +1,11 @@
1/Name:.*/ {
2 package = substr($0, 7)
3 next
4}
5/postinstall.*scriptlet .*/ {
6 next
7}
8{
9 print $0 >> ENVIRON["D"] "/etc/rpm-postinsts/" package ".sh"
10}
11
diff --git a/meta-extras/packages/yum/files/fix b/meta-extras/packages/yum/files/fix
new file mode 100644
index 0000000000..bcb3301e14
--- /dev/null
+++ b/meta-extras/packages/yum/files/fix
@@ -0,0 +1,18 @@
1---
2 rpmUtils/Makefile | 2 +-
3 1 file changed, 1 insertion(+), 1 deletion(-)
4
5--- yum-3.2.18.orig/rpmUtils/Makefile
6+++ yum-3.2.18/rpmUtils/Makefile
7@@ -1,10 +1,10 @@
8 PYTHON=python
9 PACKAGE = $(shell basename `pwd`)
10 PYFILES = $(wildcard *.py)
11 PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
12-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
13+PYSYSDIR := /usr
14 PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
15 PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
16
17 all:
18 echo "Nothing to do"
diff --git a/meta-extras/packages/yum/files/hacks.patch b/meta-extras/packages/yum/files/hacks.patch
new file mode 100644
index 0000000000..61f477172c
--- /dev/null
+++ b/meta-extras/packages/yum/files/hacks.patch
@@ -0,0 +1,81 @@
1---
2 rpmUtils/arch.py | 3 +++
3 rpmUtils/transaction.py | 1 +
4 yum/constants.py | 2 +-
5 yum/depsolve.py | 2 ++
6 4 files changed, 7 insertions(+), 1 deletion(-)
7
8Index: yum-3.2.18/rpmUtils/arch.py
9===================================================================
10--- yum-3.2.18.orig/rpmUtils/arch.py 2008-06-17 14:05:42.000000000 +0100
11+++ yum-3.2.18/rpmUtils/arch.py 2008-10-02 22:09:19.000000000 +0100
12@@ -275,6 +275,12 @@
13 return arch
14
15 def getCanonArch(skipRpmPlatform = 0):
16+ import os
17+ if 'YUM_ARCH_FORCE' in os.environ:
18+ return os.environ['YUM_ARCH_FORCE']
19+
20+ sys.exit(1)
21+
22 if not skipRpmPlatform and os.access("/etc/rpm/platform", os.R_OK):
23 try:
24 f = open("/etc/rpm/platform", "r")
25@@ -331,6 +338,12 @@
26 base arch is the arch before noarch in the arches dict if myarch is not
27 a key in the multilibArches."""
28
29+ import os
30+ if 'YUM_ARCH_FORCE' in os.environ:
31+ return os.environ['YUM_ARCH_FORCE']
32+
33+ sys.exit(1)
34+
35 if not myarch:
36 myarch = canonArch
37
38Index: yum-3.2.18/rpmUtils/transaction.py
39===================================================================
40--- yum-3.2.18.orig/rpmUtils/transaction.py 2008-06-17 14:05:42.000000000 +0100
41+++ yum-3.2.18/rpmUtils/transaction.py 2008-10-02 17:09:57.000000000 +0100
42@@ -43,6 +43,7 @@
43 'clean']
44 self.tsflags = []
45 self.open = True
46+ self.ts.setProbFilter(rpm.RPMPROB_FILTER_IGNOREOS | rpm.RPMPROB_FILTER_IGNOREARCH)
47
48 def __del__(self):
49 # Automatically close the rpm transaction when the reference is lost
50Index: yum-3.2.18/yum/constants.py
51===================================================================
52--- yum-3.2.18.orig/yum/constants.py 2008-07-21 16:56:54.000000000 +0100
53+++ yum-3.2.18/yum/constants.py 2008-10-02 17:09:57.000000000 +0100
54@@ -17,7 +17,7 @@
55 """
56
57 #Constants
58-YUM_PID_FILE = '/var/run/yum.pid'
59+YUM_PID_FILE = '/var/run2/yum.pid'
60
61 #transaction set states
62 TS_UPDATE = 10
63Index: yum-3.2.18/yum/depsolve.py
64===================================================================
65--- yum-3.2.18.orig/yum/depsolve.py 2008-08-06 17:05:16.000000000 +0100
66+++ yum-3.2.18/yum/depsolve.py 2008-10-02 17:09:57.000000000 +0100
67@@ -141,9 +141,14 @@
68 else:
69 self.logger.critical(_('Invalid tsflag in config file: %s'), flag)
70
71+ self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOPOST)
72+ self._ts.addTsFlag(rpm.RPMTRANS_FLAG_NOTRIGGERS)
73+
74 probfilter = 0
75 for flag in self.tsInfo.probFilterFlags:
76 probfilter |= flag
77+ probfilter |= rpm.RPMPROB_FILTER_IGNOREOS
78+ probfilter |= rpm.RPMPROB_FILTER_IGNOREARCH
79 self._ts.setProbFilter(probfilter)
80
81 def whatProvides(self, name, flags, version):
diff --git a/meta-extras/packages/yum/files/paths.patch b/meta-extras/packages/yum/files/paths.patch
new file mode 100644
index 0000000000..0175d05b34
--- /dev/null
+++ b/meta-extras/packages/yum/files/paths.patch
@@ -0,0 +1,106 @@
1---
2 Makefile | 18 +++++++++---------
3 docs/Makefile | 12 ++++++------
4 etc/Makefile | 20 ++++++++++----------
5 3 files changed, 25 insertions(+), 25 deletions(-)
6
7Index: yum-3.2.27/Makefile
8===================================================================
9--- yum-3.2.27.orig/Makefile 2010-03-04 01:10:20.000000000 +0000
10+++ yum-3.2.27/Makefile 2010-03-23 13:49:50.663912930 +0000
11@@ -22,19 +22,19 @@
12 for d in $(SUBDIRS); do make PYTHON=$(PYTHON) -C $$d; [ $$? = 0 ] || exit 1 ; done
13
14 install:
15- mkdir -p $(DESTDIR)/usr/share/yum-cli
16+ mkdir -p $(DESTDIR)$(datadir)/yum-cli
17 for p in $(PYFILES) ; do \
18- install -m 644 $$p $(DESTDIR)/usr/share/yum-cli/$$p; \
19+ install -m 644 $$p $(DESTDIR)$(datadir)/yum-cli/$$p; \
20 done
21- mv $(DESTDIR)/usr/share/yum-cli/yum-updatesd.py $(DESTDIR)/usr/share/yum-cli/yumupd.py
22- $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)/usr/share/yum-cli', 1, '$(PYDIR)', 1)"
23+ mv $(DESTDIR)$(datadir)/yum-cli/yum-updatesd.py $(DESTDIR)$(datadir)/yum-cli/yumupd.py
24+ $(PYTHON) -c "import compileall; compileall.compile_dir('$(DESTDIR)$(datadir)/yum-cli', 1, '$(PYDIR)', 1)"
25
26- mkdir -p $(DESTDIR)/usr/bin $(DESTDIR)/usr/sbin
27- install -m 755 bin/yum.py $(DESTDIR)/usr/bin/yum
28- install -m 755 bin/yum-updatesd.py $(DESTDIR)/usr/sbin/yum-updatesd
29+ mkdir -p $(DESTDIR)$(bindir) $(DESTDIR)$(sbindir)
30+ install -m 755 bin/yum.py $(DESTDIR)$(bindir)/yum
31+ install -m 755 bin/yum-updatesd.py $(DESTDIR)$(sbindir)/yum-updatesd
32
33- mkdir -p $(DESTDIR)/var/cache/yum
34- mkdir -p $(DESTDIR)/var/lib/yum
35+ mkdir -p $(DESTDIR)$(localstatedir)/cache/yum
36+ mkdir -p $(DESTDIR)$(localstatedir)/lib/yum
37
38 for d in $(SUBDIRS); do make PYTHON=$(PYTHON) DESTDIR=`cd $(DESTDIR); pwd` -C $$d install; [ $$? = 0 ] || exit 1; done
39
40Index: yum-3.2.27/docs/Makefile
41===================================================================
42--- yum-3.2.27.orig/docs/Makefile 2009-04-07 14:57:06.000000000 +0100
43+++ yum-3.2.27/docs/Makefile 2010-03-23 13:52:30.086667913 +0000
44@@ -6,10 +6,10 @@
45 rm -fr epydoc
46
47 install:
48- mkdir -p $(DESTDIR)/usr/share/man/man5
49- mkdir -p $(DESTDIR)/usr/share/man/man8
50- install -m 644 yum.8 $(DESTDIR)/usr/share/man/man8/yum.8
51- install -m 644 yum-shell.8 $(DESTDIR)/usr/share/man/man8/yum-shell.8
52- install -m 644 yum.conf.5 $(DESTDIR)/usr/share/man/man5/yum.conf.5
53- install -m 644 yum-updatesd.8 $(DESTDIR)/usr/share/man/man8/yum-updatesd.8
54- install -m 644 yum-updatesd.conf.5 $(DESTDIR)/usr/share/man/man5/yum-updatesd.conf.5
55+ mkdir -p $(DESTDIR)$(mandir)/man5
56+ mkdir -p $(DESTDIR)$(mandir)/man8
57+ install -m 644 yum.8 $(DESTDIR)$(mandir)/man8/yum.8
58+ install -m 644 yum-shell.8 $(DESTDIR)$(mandir)/man8/yum-shell.8
59+ install -m 644 yum.conf.5 $(DESTDIR)$(mandir)/man5/yum.conf.5
60+ install -m 644 yum-updatesd.8 $(DESTDIR)$(mandir)/man8/yum-updatesd.8
61+ install -m 644 yum-updatesd.conf.5 $(DESTDIR)$(mandir)/man5/yum-updatesd.conf.5
62Index: yum-3.2.27/etc/Makefile
63===================================================================
64--- yum-3.2.27.orig/etc/Makefile 2009-10-26 18:56:06.000000000 +0000
65+++ yum-3.2.27/etc/Makefile 2010-03-23 13:54:40.421912460 +0000
66@@ -1,4 +1,4 @@
67-YUMETC=$(DESTDIR)/etc/yum
68+YUMETC=$(DESTDIR)$(sysconfdir)/yum
69
70 all:
71 echo "Nothing to do"
72@@ -7,23 +7,23 @@
73 rm -f *.pyc *.pyo *~
74
75 install:
76- mkdir -p $(DESTDIR)/etc/yum/
77- mkdir -p $(DESTDIR)/etc/yum/repos.d
78+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/
79+ mkdir -p $(DESTDIR)$(sysconfdir)/yum/repos.d
80
81 install -m 644 yum.conf $(YUMETC)/yum.conf
82
83 install -m 644 version-groups.conf $(YUMETC)/version-groups.conf
84
85- mkdir -p $(DESTDIR)/etc/logrotate.d
86- install -m 644 yum.logrotate $(DESTDIR)/etc/logrotate.d/yum
87+ mkdir -p $(DESTDIR)$(sysconfdir)/logrotate.d
88+ install -m 644 yum.logrotate $(DESTDIR)$(sysconfdir)/logrotate.d/yum
89
90- mkdir -p $(DESTDIR)/etc/rc.d/init.d
91- install -m 755 yum-updatesd.init $(DESTDIR)/etc/rc.d/init.d/yum-updatesd
92+ mkdir -p $(DESTDIR)$(sysconfdir)/rc.d/init.d
93+ install -m 755 yum-updatesd.init $(DESTDIR)$(sysconfdir)/rc.d/init.d/yum-updatesd
94
95- mkdir -p $(DESTDIR)/etc/dbus-1/system.d/
96- install -m 755 yum-updatesd-dbus.conf $(DESTDIR)/etc/dbus-1/system.d/yum-updatesd.conf
97+ mkdir -p $(DESTDIR)$(sysconfdir)/dbus-1/system.d/
98+ install -m 755 yum-updatesd-dbus.conf $(DESTDIR)$(sysconfdir)/dbus-1/system.d/yum-updatesd.conf
99
100- install -m 755 yum-updatesd.conf $(DESTDIR)/etc/yum/yum-updatesd.conf
101+ install -m 755 yum-updatesd.conf $(DESTDIR)$(sysconfdir)/yum/yum-updatesd.conf
102
103- mkdir -p $(DESTDIR)/etc/bash_completion.d
104- install -m 644 yum.bash $(DESTDIR)/etc/bash_completion.d
105+ mkdir -p $(DESTDIR)$(sysconfdir)/bash_completion.d
106+ install -m 644 yum.bash $(DESTDIR)$(sysconfdir)/bash_completion.d
diff --git a/meta-extras/packages/yum/files/paths2.patch b/meta-extras/packages/yum/files/paths2.patch
new file mode 100644
index 0000000000..8fe6d0c983
--- /dev/null
+++ b/meta-extras/packages/yum/files/paths2.patch
@@ -0,0 +1,35 @@
1---
2 rpmUtils/Makefile | 2 +-
3 yum/Makefile | 2 +-
4 2 files changed, 2 insertions(+), 2 deletions(-)
5
6Index: yum-3.2.27/rpmUtils/Makefile
7===================================================================
8--- yum-3.2.27.orig/rpmUtils/Makefile 2010-03-24 17:26:39.759798777 +0000
9+++ yum-3.2.27/rpmUtils/Makefile 2010-03-24 17:26:54.835863845 +0000
10@@ -2,8 +2,8 @@
11 PACKAGE = $(shell basename `pwd`)
12 PYFILES = $(wildcard *.py)
13 PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
14-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
15-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
16+PYSYSDIR = $(libdir)
17+PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
18 PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
19
20 all:
21Index: yum-3.2.27/yum/Makefile
22===================================================================
23--- yum-3.2.27.orig/yum/Makefile 2010-03-24 17:26:39.759798777 +0000
24+++ yum-3.2.27/yum/Makefile 2010-03-24 17:26:43.726773783 +0000
25@@ -2,8 +2,8 @@
26 PACKAGE = $(shell basename `pwd`)
27 PYFILES = $(wildcard *.py)
28 PYVER := $(shell $(PYTHON) -c 'import sys; print "%.3s" %(sys.version)')
29-PYSYSDIR := $(shell $(PYTHON) -c 'import sys; print sys.prefix')
30-PYLIBDIR = $(PYSYSDIR)/lib/python$(PYVER)
31+PYSYSDIR = $(libdir)
32+PYLIBDIR = $(PYSYSDIR)/python$(PYVER)
33 PKGDIR = $(PYLIBDIR)/site-packages/$(PACKAGE)
34
35 all:
diff --git a/meta-extras/packages/yum/files/yum-install-recommends.py b/meta-extras/packages/yum/files/yum-install-recommends.py
new file mode 100755
index 0000000000..64716f2c3e
--- /dev/null
+++ b/meta-extras/packages/yum/files/yum-install-recommends.py
@@ -0,0 +1,39 @@
1#!/usr/bin/env python
2import os, sys
3
4root = sys.argv[1]
5installcmd = sys.argv[2]
6
7#
8# Take an rpm image and look through for Recommends:. For each recommends
9# found, try and install any matching packages including any Recommends for
10# packages installed by us.
11#
12
13
14def get_recommends():
15 deps = []
16 output = os.popen("rpm --root %s -aq --recommends" % (root))
17 lines = output.readlines()
18 for line in lines:
19 line = line.replace("(none)","")
20 if line:
21 deps.append(line.split()[0])
22 return deps
23
24processed = []
25
26while True:
27 toinstall = []
28 recommends = set(get_recommends())
29 for item in recommends:
30 if item not in processed:
31 toinstall.append(item)
32 if len(toinstall) != 0:
33 print "Installing %s" % " ".join(toinstall)
34 os.system("%s %s" % (installcmd, " ".join(toinstall)))
35 else:
36 break
37 processed.extend(toinstall)
38
39