summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@openedhand.com>2007-11-05 10:15:24 +0000
committerRoss Burton <ross@openedhand.com>2007-11-05 10:15:24 +0000
commit94b124a62e89e470d3b628307622a492437525fe (patch)
tree2447ea6c3ade08378b91acea26145044ebebf2c7 /meta-extras/packages/ubootchart/ubootchart_svn.bb
parente51fbab510c1a2228b61bfa9dd13e6b964cdc721 (diff)
downloadpoky-94b124a62e89e470d3b628307622a492437525fe.tar.gz
Add ubootchart
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3065 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta-extras/packages/ubootchart/ubootchart_svn.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-extras/packages/ubootchart/ubootchart_svn.bb b/meta-extras/packages/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..b3f1ad30ee
--- /dev/null
+++ b/meta-extras/packages/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE="GPLv3"
4
5SRC_URI = "svn://ubootchart.googlecode.com/svn/;proto=http;module=trunk \
6 file://sysvinit.patch;patch=1;pnum=0"
7
8S = "${WORKDIR}/trunk"
9
10do_compile() {
11 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
12}
13
14do_install() {
15 install -m 0755 -d ${D}/sbin ${D}/etc/ubootchart
16 install -m 0755 ${S}/ubootchartd_bin ${D}/sbin
17 install -m 0755 ${S}/ubootchartd ${D}/sbin
18 install -m 0644 ${S}/ubootchart.conf ${D}/etc/ubootchart
19 install -m 0755 ${S}/start.sh ${D}/etc/ubootchart
20 install -m 0755 ${S}/finish.sh ${D}/etc/ubootchart
21}
22