diff options
author | Richard Purdie <richard@openedhand.com> | 2006-11-29 09:47:42 +0000 |
---|---|---|
committer | Richard Purdie <richard@openedhand.com> | 2006-11-29 09:47:42 +0000 |
commit | bcedd690f7413c535d5279bf9f342b6b90eb68d5 (patch) | |
tree | cf97265f39a0cbd5f03bdf39b54cc345fe0df9a9 /meta-extras/packages/sqlite | |
parent | 23e50d487da3e92df18a325a92d787f834a44570 (diff) | |
download | poky-bcedd690f7413c535d5279bf9f342b6b90eb68d5.tar.gz |
poky-extras: Add bluez, sqlite, maemo-mapper-nohildon
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@969 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/sqlite')
5 files changed, 230 insertions, 0 deletions
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch new file mode 100644 index 0000000000..31d4f0d162 --- /dev/null +++ b/meta-extras/packages/sqlite/sqlite3-3.3.7/cross-compile.patch | |||
@@ -0,0 +1,92 @@ | |||
1 | --- sqlite-3.3.7/configure.ac.orig 2006-08-21 00:20:50.000000000 +0200 | ||
2 | +++ sqlite-3.3.7/configure.ac 2006-08-21 00:22:35.000000000 +0200 | ||
3 | @@ -187,10 +187,11 @@ | ||
4 | default_build_cflags="-g" | ||
5 | if test "$config_BUILD_CC" = ""; then | ||
6 | AC_PROG_CC | ||
7 | - if test "$cross_compiling" = "yes"; then | ||
8 | - AC_MSG_ERROR([unable to find a compiler for building build tools]) | ||
9 | - fi | ||
10 | - BUILD_CC=$CC | ||
11 | +# if test "$cross_compiling" = "yes"; then | ||
12 | +# AC_MSG_ERROR([unable to find a compiler for building build tools]) | ||
13 | +# fi | ||
14 | +# BUILD_CC=$CC | ||
15 | +BUILD_CC=gcc | ||
16 | default_build_cflags=$CFLAGS | ||
17 | else | ||
18 | BUILD_CC=$config_BUILD_CC | ||
19 | @@ -238,6 +239,12 @@ | ||
20 | TARGET_LINK=$config_TARGET_LINK | ||
21 | fi | ||
22 | AC_MSG_RESULT($TARGET_LINK) | ||
23 | +if test "$config_TARGET_LFLAGS" != ""; then | ||
24 | + TARGET_LFLAGS=$config_TARGET_LFLAGS | ||
25 | + else | ||
26 | + TARGET_LFLAGS=$BUILD_LFLAGS | ||
27 | + fi | ||
28 | +AC_MSG_RESULT($TARGET_LFLAGS) | ||
29 | AC_MSG_CHECKING([switches on the target compiler]) | ||
30 | if test "$config_TARGET_TFLAGS" != ""; then | ||
31 | TARGET_TFLAGS=$config_TARGET_TFLAGS | ||
32 | @@ -592,15 +599,7 @@ | ||
33 | # Figure out what C libraries are required to compile programs | ||
34 | # that use "readline()" library. | ||
35 | # | ||
36 | -if test "$config_TARGET_READLINE_LIBS" != ""; then | ||
37 | - TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS" | ||
38 | -else | ||
39 | - CC=$TARGET_CC | ||
40 | - LIBS="" | ||
41 | - AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap]) | ||
42 | - AC_CHECK_LIB([readline], [readline]) | ||
43 | - TARGET_READLINE_LIBS="$LIBS" | ||
44 | -fi | ||
45 | +TARGET_READLINE_LIBS="-lreadline" | ||
46 | AC_SUBST(TARGET_READLINE_LIBS) | ||
47 | |||
48 | ########## | ||
49 | @@ -615,41 +614,8 @@ | ||
50 | ########## | ||
51 | # Figure out where to get the READLINE header files. | ||
52 | # | ||
53 | -AC_MSG_CHECKING([readline header files]) | ||
54 | -found=no | ||
55 | -if test "$config_TARGET_READLINE_INC" != ""; then | ||
56 | - TARGET_READLINE_INC=$config_TARGET_READLINE_INC | ||
57 | - found=yes | ||
58 | -fi | ||
59 | -if test "$found" = "yes"; then | ||
60 | - AC_MSG_RESULT($TARGET_READLINE_INC) | ||
61 | -else | ||
62 | - AC_MSG_RESULT(not specified: still searching...) | ||
63 | - AC_CHECK_HEADER(readline.h, [found=yes]) | ||
64 | -fi | ||
65 | -if test "$found" = "no"; then | ||
66 | - for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do | ||
67 | - AC_CHECK_FILE($dir/include/readline.h, found=yes) | ||
68 | - if test "$found" = "yes"; then | ||
69 | - TARGET_READLINE_INC="-I$dir/include" | ||
70 | - break | ||
71 | - fi | ||
72 | - AC_CHECK_FILE($dir/include/readline/readline.h, found=yes) | ||
73 | - if test "$found" = "yes"; then | ||
74 | - TARGET_READLINE_INC="-I$dir/include/readline" | ||
75 | - break | ||
76 | - fi | ||
77 | - done | ||
78 | -fi | ||
79 | -if test "$found" = "yes"; then | ||
80 | - if test "$TARGET_READLINE_LIBS" = ""; then | ||
81 | - TARGET_HAVE_READLINE=0 | ||
82 | - else | ||
83 | - TARGET_HAVE_READLINE=1 | ||
84 | - fi | ||
85 | -else | ||
86 | - TARGET_HAVE_READLINE=0 | ||
87 | -fi | ||
88 | +TARGET_READLINE_INC="" | ||
89 | +TARGET_HAVE_READLINE=1 | ||
90 | AC_SUBST(TARGET_READLINE_INC) | ||
91 | AC_SUBST(TARGET_HAVE_READLINE) | ||
92 | |||
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch new file mode 100644 index 0000000000..ee5105ffff --- /dev/null +++ b/meta-extras/packages/sqlite/sqlite3-3.3.7/ldflags.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | --- sqlite-3.3.7/Makefile.in.orig 2006-08-20 23:05:36.000000000 +0200 | ||
2 | +++ sqlite-3.3.7/Makefile.in 2006-08-20 23:42:49.000000000 +0200 | ||
3 | @@ -31,6 +31,10 @@ | ||
4 | # | ||
5 | TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src | ||
6 | |||
7 | +# OE overrides | ||
8 | +# | ||
9 | +TARGET_LFLAGS = @TARGET_LFLAGS@ | ||
10 | + | ||
11 | # Define -DNDEBUG to compile without debugging (i.e., for production usage) | ||
12 | # Omitting the define will cause extra debugging code to be inserted and | ||
13 | # includes extra comments when "EXPLAIN stmt" is used. | ||
14 | @@ -257,17 +261,17 @@ | ||
15 | | $(NAWK) '{print $$5,$$6}' >last_change | ||
16 | |||
17 | libsqlite3.la: $(LIBOBJ) | ||
18 | - $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \ | ||
19 | + $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \ | ||
20 | ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8" | ||
21 | |||
22 | libtclsqlite3.la: tclsqlite.lo libsqlite3.la | ||
23 | $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \ | ||
24 | - $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \ | ||
25 | + $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \ | ||
26 | -rpath $(libdir)/sqlite \ | ||
27 | -version-info "8:6:8" | ||
28 | |||
29 | sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h | ||
30 | - $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \ | ||
31 | + $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \ | ||
32 | -o $@ $(TOP)/src/shell.c libsqlite3.la \ | ||
33 | $(LIBREADLINE) $(TLIBS) | ||
34 | |||
35 | @@ -456,12 +460,12 @@ | ||
36 | |||
37 | tclsqlite3: tclsqlite-shell.lo libsqlite3.la | ||
38 | $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \ | ||
39 | - libsqlite3.la $(LIBTCL) | ||
40 | + libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL) | ||
41 | |||
42 | testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC) | ||
43 | $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 -DSQLITE_CRASH_TEST=1 \ | ||
44 | $(TEMP_STORE) -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \ | ||
45 | - libsqlite3.la $(LIBTCL) | ||
46 | + libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL) | ||
47 | |||
48 | |||
49 | fulltest: testfixture$(TEXE) sqlite3$(TEXE) | ||
50 | @@ -471,7 +475,7 @@ | ||
51 | ./testfixture $(TOP)/test/quick.test | ||
52 | |||
53 | sqlite3_analyzer$(TEXE): $(TOP)/src/tclsqlite.c libtclsqlite3.la \ | ||
54 | - $(TESTSRC) $(TOP)/tool/spaceanal.tcl | ||
55 | + $(TARGET_LFLAGS) $(TESTSRC) $(TOP)/tool/spaceanal.tcl | ||
56 | sed \ | ||
57 | -e '/^#/d' \ | ||
58 | -e 's,\\,\\\\,g' \ | ||
59 | @@ -481,7 +485,7 @@ | ||
60 | $(TOP)/tool/spaceanal.tcl >spaceanal_tcl.h | ||
61 | $(LTLINK) -DTCLSH=2 -DSQLITE_TEST=1 $(TEMP_STORE)\ | ||
62 | -o sqlite3_analyzer$(EXE) $(TESTSRC) $(TOP)/src/tclsqlite.c \ | ||
63 | - libtclsqlite3.la $(LIBTCL) | ||
64 | + libtclsqlite3.la $(TARGET_LFLAGS) $(LIBTCL) | ||
65 | |||
66 | # Rules used to build documentation | ||
67 | # | ||
diff --git a/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch b/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch new file mode 100644 index 0000000000..ccf9993ed2 --- /dev/null +++ b/meta-extras/packages/sqlite/sqlite3-3.3.7/libtool.patch | |||
@@ -0,0 +1,25 @@ | |||
1 | Index: sqlite-3.2.1/Makefile.in | ||
2 | =================================================================== | ||
3 | --- sqlite-3.2.1.orig/Makefile.in 2005-03-23 17:09:39.000000000 +0100 | ||
4 | +++ sqlite-3.2.1/Makefile.in 2005-04-25 23:11:20.000000000 +0200 | ||
5 | @@ -15,7 +15,10 @@ | ||
6 | # The toplevel directory of the source tree. This is the directory | ||
7 | # that contains this "Makefile.in" and the "configure.in" script. | ||
8 | # | ||
9 | -TOP = @srcdir@ | ||
10 | +TOP = $(srcdir) | ||
11 | +srcdir = @srcdir@ | ||
12 | +top_srcdir = @top_srcdir@ | ||
13 | +top_builddir = . | ||
14 | |||
15 | # C Compiler and options for use in building executables that | ||
16 | # will run on the platform that is doing the build. | ||
17 | @@ -96,7 +99,7 @@ | ||
18 | exec_prefix = @exec_prefix@ | ||
19 | libdir = @libdir@ | ||
20 | INSTALL = @INSTALL@ | ||
21 | -LIBTOOL = ./libtool | ||
22 | +LIBTOOL = @LIBTOOL@ | ||
23 | ALLOWRELEASE = @ALLOWRELEASE@ | ||
24 | |||
25 | # libtool compile/link/install | ||
diff --git a/meta-extras/packages/sqlite/sqlite3.inc b/meta-extras/packages/sqlite/sqlite3.inc new file mode 100644 index 0000000000..01290c2e41 --- /dev/null +++ b/meta-extras/packages/sqlite/sqlite3.inc | |||
@@ -0,0 +1,44 @@ | |||
1 | DESCRIPTION = "An Embeddable SQL Database Engine" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | DEPENDS = "readline ncurses" | ||
5 | LICENSE = "PD" | ||
6 | |||
7 | SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \ | ||
8 | file://cross-compile.patch;patch=1 \ | ||
9 | file://libtool.patch;patch=1 \ | ||
10 | file://ldflags.patch;patch=1" | ||
11 | S = "${WORKDIR}/sqlite-${PV}" | ||
12 | |||
13 | inherit autotools pkgconfig | ||
14 | |||
15 | EXTRA_OECONF = "--disable-tcl --enable-shared \ | ||
16 | --enable-threadsafe" | ||
17 | export config_BUILD_CC = "${BUILD_CC}" | ||
18 | export config_BUILD_CFLAGS = "${BUILD_CFLAGS}" | ||
19 | export config_BUILD_LIBS = "${BUILD_LDFLAGS}" | ||
20 | export config_TARGET_CC = "${CC}" | ||
21 | export config_TARGET_LINK = "${CCLD}" | ||
22 | export config_TARGET_CFLAGS = "${CFLAGS}" | ||
23 | export config_TARGET_LFLAGS = "${LDFLAGS}" | ||
24 | |||
25 | do_compile_prepend() { | ||
26 | oe_runmake sqlite3.h | ||
27 | install -m 0644 sqlite3.h ${STAGING_INCDIR} | ||
28 | } | ||
29 | |||
30 | do_stage() { | ||
31 | oe_libinstall -so libsqlite3 ${STAGING_LIBDIR} | ||
32 | } | ||
33 | |||
34 | #do_install() { | ||
35 | # oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix} | ||
36 | #} | ||
37 | |||
38 | PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3 sqlite3-dbg" | ||
39 | FILES_sqlite3 = "${bindir}/*" | ||
40 | FILES_libsqlite = "${libdir}/*.so.*" | ||
41 | FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \ | ||
42 | ${libdir}/pkgconfig ${includedir}" | ||
43 | FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}" | ||
44 | AUTO_LIBNAME_PKGS = "libsqlite" | ||
diff --git a/meta-extras/packages/sqlite/sqlite3_3.3.7.bb b/meta-extras/packages/sqlite/sqlite3_3.3.7.bb new file mode 100644 index 0000000000..d21fb6ad3e --- /dev/null +++ b/meta-extras/packages/sqlite/sqlite3_3.3.7.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require sqlite3.inc | ||
2 | PR = "r2" | ||